Closed Bug 509594 Opened 12 years ago Closed 12 years ago

[SeaMonkey] mochitest-plain: test_datepicker.xul fails now, conflicts with SeaMonkey (extension) 'QA' menu

Categories

(Toolkit :: XUL Widgets, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- beta1-fixed
status1.9.1 --- .3-fixed

People

(Reporter: sgautherie, Assigned: sgautherie)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [Bv1: fixed1.9.2b1 fixed1.9.1.4])

Attachments

(1 file)

FireFox: passes.
SM MacOSX: passes.
SM Linux and Windows: fail.

Example log:
{
test_datepicker.xul | datepicker UI alt shortcut command event fired - got false, expected true
test_datepicker.xul | datepicker UI ctrl shortcut command event fired - got false, expected true
test_datepicker.xul | datepicker UI meta shortcut command event fired - got false, expected true
test_datepicker.xul | datepicker popup UI alt shortcut command event fired - got false, expected true
test_datepicker.xul | datepicker popup UI ctrl shortcut command event fired - got false, expected true
test_datepicker.xul | datepicker popup UI meta shortcut command event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key left change event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key left - got "2003-02-22", expected "2003-02-21"
test_datepicker.xul | datepicker popup UI key right change event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key right next week change event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key right next week - got "2003-02-22", expected "2003-02-23"
test_datepicker.xul | datepicker popup UI key left previous week change event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key up change event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key up - got "2003-02-22", expected "2003-02-15"
test_datepicker.xul | datepicker popup UI key down change event fired - got false, expected true
test_datepicker.xul | undefined change event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key down next month - got "2003-02-22", expected "2003-03-01"
test_datepicker.xul | undefined change event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key page down monthchange event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key up after month change monthchange event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key up after month change - got "2003-02-22", expected "2003-02-15"
test_datepicker.xul | datepicker popup UI key page up monthchange event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key page up - got "2003-02-22", expected "2003-02-15"
test_datepicker.xul | datepicker popup UI key left read only - got "2003-02-22", expected "2003-02-15"
test_datepicker.xul | datepicker popup UI key right read only - got "2003-02-22", expected "2003-02-15"
test_datepicker.xul | datepicker popup UI key down read only - got "2003-02-22", expected "2003-02-15"
test_datepicker.xul | datepicker popup UI key up read only - got "2003-02-22", expected "2003-02-15"
test_datepicker.xul | datepicker popup UI key page up read only monthchange event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key page down read only monthchange event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key left changable again change event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key left changable again - got "2003-02-22", expected "2003-02-14"
test_datepicker.xul | datepicker popup UI key left disabled - got "2003-02-22", expected "2003-02-14"
test_datepicker.xul | datepicker popup UI key right disabled - got "2003-02-22", expected "2003-02-14"
test_datepicker.xul | datepicker popup UI key down disabled - got "2003-02-22", expected "2003-02-14"
test_datepicker.xul | datepicker popup UI key up disabled - got "2003-02-22", expected "2003-02-14"
test_datepicker.xul | datepicker popup UI key right enabled again change event fired - got false, expected true
test_datepicker.xul | datepicker popup UI key right enabled again - got "2003-02-22", expected "2003-02-15"
+
test_deck.xul | mouse on deck one click event fired - got false, expected true
+
buildbot.slave.commands.TimeoutError: command timed out: 300 seconds without output
}
Reproducible on my local Windows.

{
22   <key id="key_alt_q" key="Q" oncommand="return" modifiers="alt"/>
}
conflicts with and triggers SeaMonkey (extension) 'QA' menu :-/
Keywords: helpwanted
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/908f0d98d017
(Av1) Temporary bustage fix
Summary: [SeaMonkey] mochitest-plain: test_datepicker.xul fails after bug 504480 landing on m-1.9.1 → [SeaMonkey] mochitest-plain: test_datepicker.xul fails now, conflicts with SeaMonkey (extension) 'QA' menu
Whiteboard: [worked around on m-1.9.1]
And if that's not bad enough, there's a Ctrl+Q which is (for now) Quit - which is why the Meta test is for E, since Cmd+Q still works in Firefox for the Mac.

I didn't understand your choice of dependencies so I tweaked them a bit.
Blocks: 405095
No longer depends on: 386772
I just checked and SeaMonkey has no unused Ctrl+letter shortcuts, although for numbers we fortunately only use 0 to 6, so 7-9 are (so far) still free...
Or is the problem specific to Alt, and we don't need to worry about Ctrl/Meta?
(In reply to comment #3)
> I didn't understand your choice of dependencies so I tweaked them a bit.

Yeah, I searched for the bug which added the test only:
I hadn't checked that the key bindings were added by another bug.


(In reply to comment #5)
> Or is the problem specific to Alt, and we don't need to worry about Ctrl/Meta?

On my local Windows, only Alt is a problem.
2 ways to work around it (in the test: I don't know about real life):
*comment out the Alt+Q synthesizeKeyExpectEvent() line.
*change the binding to Alt+Y for example.
 (= Any key which does not activate a menu/popup!?)

I don't know about Linux.
(In reply to comment #6)
> > Or is the problem specific to Alt, and we don't need to worry about Ctrl/Meta?
> 
> On my local Windows, only Alt is a problem.
> 2 ways to work around it (in the test: I don't know about real life):
> *comment out the Alt+Q synthesizeKeyExpectEvent() line.

This is wrong. We are not willing to stop protecting datepicker behavior.

> *change the binding to Alt+Y for example.
>  (= Any key which does not activate a menu/popup!?)

This is the simplest option.

Option 3 is to put datepicker test observer in the queue before the one from the extension, stop event propagation past the test.
(In reply to comment #7)
> > *comment out the Alt+Q synthesizeKeyExpectEvent() line.
> 
> This is wrong. We are not willing to stop protecting datepicker behavior.

I assume as much: I was simply listing what I had tried locally.

> > *change the binding to Alt+Y for example.
> >  (= Any key which does not activate a menu/popup!?)
> 
> This is the simplest option.

Is Alt+Q (ad the 2 others) related to something real in the application?
Or is it test-only and can be replaced with any non-conflicting key?

> Option 3 is to put datepicker test observer in the queue before the one from

(I don't know how to do that...)

> the extension, stop event propagation past the test.
(In reply to comment #8)
> Is Alt+Q (ad the 2 others) related to something real in the application?
> Or is it test-only and can be replaced with any non-conflicting key?

I apologize for being vague. Alt+Q is a test only combination. Any other letter can be used instead. 'Alt' should be preserved, to be sure.
Fixes Windows.
I don't know about Linux...
Attachment #394087 - Flags: review?(gavin.sharp)
Attachment #394087 - Flags: review?(gavin.sharp) → review+
Comment on attachment 394087 [details] [diff] [review]
(Bv1) Change conflicting key binding
[Checkin: See comment 11 & 12 & 13]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/cc60af4dcd4c
Attachment #394087 - Attachment description: (Bv1) Change conflicting key binding. → (Bv1) Change conflicting key binding [Checkin: Comment 11]
Comment on attachment 394087 [details] [diff] [review]
(Bv1) Change conflicting key binding
[Checkin: See comment 11 & 12 & 13]


http://hg.mozilla.org/mozilla-central/rev/091ea6ebae5b
Attachment #394087 - Attachment description: (Bv1) Change conflicting key binding [Checkin: Comment 11] → (Bv1) Change conflicting key binding [Checkin: See comment 11 & 12]
Assignee: nobody → sgautherie.bz
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-testsuite+
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: [worked around on m-1.9.1] → [c-n: m-1.9.2]
Target Milestone: --- → mozilla1.9.3
Version: 1.9.1 Branch → Trunk
Target Milestone: mozilla1.9.3 → mozilla1.9.3a1
Comment on attachment 394087 [details] [diff] [review]
(Bv1) Change conflicting key binding
[Checkin: See comment 11 & 12 & 13]


http://hg.mozilla.org/releases/mozilla-1.9.2/rev/0333691ae0db
Attachment #394087 - Attachment description: (Bv1) Change conflicting key binding [Checkin: See comment 11 & 12] → (Bv1) Change conflicting key binding [Checkin: See comment 11 & 12 & 13]
Keywords: checkin-needed
Whiteboard: [c-n: m-1.9.2]
Whiteboard: [Bv1: fixed1.9.2b1 fixed1.9.1.4]
You need to log in before you can comment on or make changes to this bug.