If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Special characters like slash in folder name mess up TB

RESOLVED DUPLICATE of bug 29926

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED DUPLICATE of bug 29926
8 years ago
7 years ago

People

(Reporter: Andy Wozniak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1pre) Gecko/20090715 Ubuntu/9.04 (jaunty) Shiretoko/3.5.1pre
Build Identifier: version 2.0.0.22 (20090608)

When creating a folder with a slash '/' character in name, TB responds by creating the folder with a truncating name. When this bad folder is deleted to trash, trash cannot be emptied.

Reproducible: Always

Steps to Reproduce:
1. create new folder (foo/bar) with a '/' in the middle of name, press OK
2. folder is created with slash and remaining chars truncated (foo)
3. folder name is italicized
4. delete the folder. it is moved to trash
5. empty the trash, foo folder remains in trash
Actual Results:  
see 'steps' above

Expected Results:  
Naming a folder with 'special' character should not break things. A error message should inform the user that invalid characters were used.
When emptying the trash, all emails and folders within the trash should be removed. If there is a problem removing them, a warning message should inform the user.

TB is running on a corporate network and is connected to an SMTP/IMAP server.

When I browse over to my webmail acount, that stubborn 'foo' folder is not shown in the trash.

There seems to be no workaround to empty the trash of a badly named folder.
Whiteboard: DUPEME
(Reporter)

Comment 1

8 years ago
A few more steps:

6. at step 5, trash does appear to be emptied - 'foo' folder goes away
7. close TB, start TB and login
8. dialog pops up: "The current command did not succeed. The mail server responded: Mailbox dos not exist"
9. 'foo' folder reappears in the trash folder
Whiteboard: DUPEME
Whiteboard: dupeme
IMAP folder? Local mail folder("Local Folders)?
Ordinal folder? Saved search folder(virtual folder)?
I assume "ordinal IMAP folder" because of "The current command did not succeed".

If delimiter of Mailbox Hierarchy is "/", "foo/bar" means "bar under foo" and IMAP server has to pass folder data as "bar under foo" to IMAP client.
If delimiter of Mailbox Hierarchy is not "/", it's probably a variation of phenomena by Bug 63038. See bugs listed in dependency tree for meta Bug 124287.  

Which case?
(Reporter)

Comment 3

8 years ago
IMAP folder?
(Reporter)

Comment 4

8 years ago
IMAP folder?

  Yes, see original bug report.

Ordinal, virtual folder?

  Please explain what this means. I have never seen these types of TB folders.

...hierarchy.

  Am also confused here. My TB mail folders (the left pane) do not have any slashes in them. The original bug report says that I created a new folder with a slash in its name. "foo/bar" is the folder name. No hierarchy involved.
(Reporter)

Comment 5

8 years ago
Ok, I see that you are referring to the PC or server filesystem hierarchy, and not TB folder hierarchy.

My PC and server environment is Linux/Solaris based. So bug 63038 does not apply because slash "is" the delimiter in my case.
(In reply to comment #5)
> My PC and server environment is Linux/Solaris based.
> So bug 63038 does not apply because slash "is" the delimiter in my case.

I asked about IMAP's delimiter of Mailbox Hierarchy(IMAP mail folder hierarchy) used by your IMAP server. It's different concept from delimiter of filesystem hierarchy used by OS. Read RFC 3501 section 7.2.2, get IMAP log and check your IMAP server's response.
> http://tools.ietf.org/html/rfc3501#section-7.2.2
> 7.2.2. LIST Response
> https://wiki.mozilla.org/MailNews:Logging
(In reply to comment #4)
> Ordinal, virtual folder?
>   Please explain what this means. I have never seen these types of TB folders.

I meant "non saved-search-folder" by "Ordinal folder". "Virtual folder" is another name(internal name) of "Saved Search Folder" or "Search Folder".
Summary: Special characters in folder name mess up TB → Special characters like slash in folder name mess up TB
Whiteboard: dupeme → dupme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 29926
You need to log in before you can comment on or make changes to this bug.