unaligned reads in qcms (crash on http://www.onlinemovies.top-site-list.com/)

RESOLVED FIXED

Status

()

Core
GFX: Color Management
P2
critical
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: skempe, Assigned: vlad)

Tracking

({crash})

Trunk
ARM
Windows CE
crash
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nv], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; Zune 2.0)
Build Identifier: http://people.mozilla.com/~vladimir/ce/firefox.cab (11th July)

firefox crashed when tried to open http://www.onlinemovies.top-site-list.com/

The log is as below. Similar kind of xul.dll crash was observed in bug 502230 but with 11th July version it started to hang the device. 

** We want fake weight
** We want fake weight
** We want fake weight
** We want fake weight
_ogl_surface_create returned OpenGL ES error code 0x500
_ogl_surface_create returned OpenGL ES error code 0x500
Exception 'Data Abort' (4): Thread-Id=086500b2(pth=83e0d708), Proc-Id=0640081e(pprc=841c4bb8) 'firefox.exe', VM-active=0640081e(pprc=841c4bb8) 'firefox.exe'
PC=42dce02c(xul.dll+0x00b9e02c) RA=58595a20(???+0x58595a20) SP=001ff4d8, BVA=00000000


Reproducible: Always

Steps to Reproduce:
1.install firefox 
2.open http://www.onlinemovies.top-site-list.com/
3.
Actual Results:  
firefox crashes
(Reporter)

Updated

9 years ago
OS: Other → Windows CE
Hardware: Other → ARM

Updated

9 years ago
Severity: normal → critical
Keywords: crash
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is qcms related (also, color management should be disabled, will fix) -- it's casting pointers and reading 4-byte values from non-aligned addresses.  Using memcpy to get the data fixes the problem here.
Assignee: nobody → vladimir
Component: General → GFX: Color Management
Product: Firefox → Core
QA Contact: general → color-management
Version: unspecified → Trunk
Created attachment 389214 [details] [diff] [review]
fix

Use memcpy instead of reading directly.
Attachment #389214 - Flags: review?(jmuizelaar)
http://hg.mozilla.org/mozilla-central/rev/944b2cd986d9 for disabling cms on Windows CE -- so this bug should be gone even before this patch lands.
Summary: firefox crashes for http://www.onlinemovies.top-site-list.com/ → unaligned reads in qcms (crash on http://www.onlinemovies.top-site-list.com/)
Attachment #389214 - Flags: review?(jmuizelaar) → review+
Comment on attachment 389214 [details] [diff] [review]
fix

One of the jpeg's on that page has a profile that has unaligned offsets in it. This isn't very common and so that's why we didn't run into the problem before.
Duplicate of this bug: 514002
Priority: -- → P2

Updated

9 years ago
Flags: in-testsuite?
http://hg.mozilla.org/mozilla-central/rev/e8207773d54d
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 585033
This bug should be reopened, as it affects mozilla-firefox 3.6.13 on sparc64 (and probably firefox 3.5.16, as the qcms codebase is the same there). Can someone backport the fix (http://hg.mozilla.org/mozilla-central/rev/e8207773d54d) to 1.9.1 and 1.9.2 branches ? It's been tested to fix the crashes.
(In reply to comment #10)
> This bug should be reopened, as it affects mozilla-firefox 3.6.13 on sparc64
> (and probably firefox 3.5.16, as the qcms codebase is the same there). Can
> someone backport the fix
> (http://hg.mozilla.org/mozilla-central/rev/e8207773d54d) to 1.9.1 and 1.9.2
> branches ? It's been tested to fix the crashes.

Can you file a new bug for those trees. I think it will make tracking the issue easier.

Updated

7 years ago
Blocks: 629057

Updated

7 years ago
Duplicate of this bug: 646961
You need to log in before you can comment on or make changes to this bug.