Text in the search field gets obstructed by placeholder text

VERIFIED DUPLICATE of bug 476953

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED DUPLICATE of bug 476953
9 years ago
2 years ago

People

(Reporter: neilio, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 389141 [details]
Screenshot of the issue (I typed the text "prism")

Steps to reproduce:

1. Load the add-ons' home page.
2. As the page is loading, click into the search field and start typing a search.

Initially, you will see your typed text appear in the field, but as the page finishes loading, the text "search for add-ons" appears on top of your text, making it impossible to see. Screenshot attached.

Comment 1

8 years ago
I can confirm this behavior. I'm accessing the web site using Firefox v3.5.3 running on Windows Vista. I had my won Steps to Reproduce already typed up, so I'm posting them here, since I went into a little more detail.

Web Page: Add-ons for Firefox
URL: https://addons.mozilla.org/en-US/firefox/

STEPS TO REPRODUCE:
----------------------------------------
01. Load the url: https://addons.mozilla.org/en-US/firefox/.
EXPECTED: The search terms field displays the text: "search for add-ons".
RESULTS: Same as EXPECTED -- CORRECT.

02. Click in the search terms field to enter search terms.
EXPECTED: The text: "search for add-ons" disappears and the field appears empty.
RESULTS: Same as EXPECTED -- CORRECT.

03. Type search terms (say "Dictionary") in the search terms field.
EXPECTED: The typed text: "Dictionary" appears in the search terms field.
RESULTS: Same as EXPECTED -- CORRECT.

04. Execute the search by clicking the green button with white arrow.

EXPECTED:
A. The search results page displays all add-ons related to "Dictionary". 
B. The previous search terms: "Dictionary" appears in the search terms field.

RESULTS:
A. Same as EXPECTED -- CORRECT.
B. The previous search terms: "Dictionary" appears in the search terms field but it is overlaid by the text: "search for add-ons" -- INCORRECT.

05. Click in the search terms field to enter search terms.
EXPECTED: The text: "search for add-ons" disappears and the blank appears empty.
RESULTS: The previous search terms: "Dictionary" appears in the search terms field but it is overlaid by the text: "search for add-ons" -- INCORRECT.

06. Type new search terms (say "RSS Feeds") in the search terms field.
EXPECTED: The typed text: "RSS Feeds" appears in the search terms field.
RESULTS: The new search terms: "RSS Feeds" appears in the search terms field but it is overlaid by the text: "search for add-ons" -- INCORRECT.
Neilio: This should be fixed now (was a dupe).

Ken: Please go to bug 517687 and contribute to the discussion there. We are trying to figure out why some people are getting an error there while others are not. Thanks!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476953

Comment 3

8 years ago
verified
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.