Closed Bug 504994 Opened 15 years ago Closed 14 years ago

Update Python to v2.6.x in MozillaBuild

Categories

(Firefox Build System :: MozillaBuild, task)

x86
Windows 2000
task
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gkw, Assigned: ted)

References

Details

Please consider updating Python to pick up fixes till 2.5.4 - or even to 2.6.x if it's viable.
Current workaround is to use a separate Python v2.5.4 instead of MB Python v2.5.

While I would support moving to Python v2.6.2 (bug 427750 comment 12),
it seems too soon for MB as it's not (yet) the Mozilla platform minimum.
Severity: normal → minor
Depends on: 427750
OS: Mac OS X → Windows 2000
Summary: Update Python in MozillaBuild → Update Python to v2.5.4 in MozillaBuild
Bespin 0.6 Customizable requires Python 2.6, per their documentation.  It'd be really nice to have that come with MozillaBuild.
Summary: Update Python to v2.5.4 in MozillaBuild → Update Python to v2.6.x in MozillaBuild
My win32 builds started failing as per this report from Martin Packer on mozilla.dev.builds:

http://groups.google.com/group/mozilla.dev.builds/browse_thread/thread/e0fe0ae808daad9f/62d56446b868f801

Replacing ..\mozilla-build\python25 contents with with an unpacked python 2.6.4, deleting config.cache and rebuilding solved the problem for me.

So it appears to be a must-have.
By must-have I mean an updated python, not necessarily 2.6.4.  I haven't done a python regression test to see what the minimal working version is...
I haven't seen this problem reported elsewhere, and our official Windows builds are produced using MozillaBuild (and the Python contained within), so I don't think this is a major problem.
Well, it's a mystery to me, as MozillaBuild 1.4 was working fine on my XP PC until February, and Python 2.6.4 does fix it.

I am curious as to why the original bug here was filed - I presume there was some bug which needed a workaround.

Just for the record, so others with the same problem can find the solution easily on Bugzilla, the error I got was Identical to Martin Packer's, namely:

Parsing specification ../../dom/plugins/PPluginModule.ipdl
Traceback (most recent call last):
   File "../../config/pythonpath.py", line 40, in <module>
     execfile(script, {'__name__': '__main__', '__file__': script})
   File "./ipdl.py", line 90, in <module>
     ast = ipdl.parse(specstring, filename, includedirs=includedirs)
   File "./ipdl/__init__.py", line 49, in parse
     return Parser().parse(specstring, os.path.abspath(filename),
includedirs, errout)
   File "./ipdl/parser.py", line 94, in parse
     tabmodule="ipdl_yacctab")
   File "../../../../other-licenses/ply/ply/yacc.py", line 2718, in yacc
I don't know why the original bug was filed, comment 0 isn't descriptive enough to say.

Mozilla officially requires only Python 2.4 to build, so any incompatibility would be a bug in our build system. As I said, I don't know what that bug is, I haven't seen it reported anywhere but the newsgroup post you mentioned, so it's apparently not widespread.

All of this is offtopic for this bug, though, since the python included in MozillaBuild seems to be working fine for everyone else.
(In reply to comment #1)
> While I would support moving to Python v2.6.2 (bug 427750 comment 12),
> it seems too soon for MB as it's not (yet) the Mozilla platform minimum.

Actually, MozillaBuild may need to be upgraded first.

(In reply to comment #6)
> I am curious as to why the original bug here was filed

I'm not aware of a bug, but I feel like using a "maintained" version would be good.
It helps to be able to fuzz jsfunfuzz on Windows, using Python 2.6.x. Subprocess.kill is apparently available in that version.
I updated to 2.6.5:
http://hg.mozilla.org/mozilla-build/rev/d4b8b4f97e4e
Assignee: nobody → ted.mielczarek
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Product: mozilla.org → Firefox Build System
You need to log in before you can comment on or make changes to this bug.