Selection lost when leaving a folder and coming back into it (mailnews.remember_selected_message doesn't work)

VERIFIED FIXED in Thunderbird 3.0b4

Status

defect
--
major
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: LpSolit, Assigned: sid0)

Tracking

({regression})

Trunk
Thunderbird 3.0b4
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact][regression range 20090628-20090629])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
This was working fine with beta 2, so this is a regression in beta 3:

- Select a message in your list
- Go into another folder
- Come back to the first folder

The initially selected message should be redisplayed, but is not. The selection is lost.
Flags: blocking-thunderbird3?
Potential duplicate of bug 497348.

Comment 2

10 years ago
Toggling mailnews.remember_selected_message doesn't make a difference, it is treated "false" in either case (testing 3.0b3 build on Linux).

The description for bug 497348 states:

> A server resync is performed, and _then_ the previously selected email is
> selected.

which is different (no mail is selected in this case at all). Also, I'm seeing this for both IMAP and local folders, thus independent of resyncing.
Very annoying regression indeed.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
OS: Linux → All
Hardware: x86 → All
Summary: Selection lost when leaving a folder and coming back into it → Selection lost when leaving a folder and coming back into it (mailnews.remember_selected_message doesn't work)
Target Milestone: --- → Thunderbird 3.0b4
Assigning to clarkbw for input - I think the core issue here is the same as per bug 497348 and we need a UX decision on what we are going to do here. The discussion on bug 497348 is especially worth a read.
Assignee: nobody → clarkbw
Depends on: 497348
I peg the regression range at 20090628-20090629 and likely makes the regressor one of sid0's bugs
* bug 467768 - No way to make mail open in tabs by default 
* Bug 500657 - open message from Search Messages results does not work well
The regression got shipped in beta 3 - which suggests we don't have any tests for this behavior. 

Unless you're someone who lives in one folder this is very dogfoodish, eg flipping folders or doing folder maintenance, which I was doing today in a big way. What saved me from going crazy was (ironically) tabs, because I could have a tab open for each folder I was working with.
Blocks: 467768
Whiteboard: regression range 20090628-20090629
Yes, this was broken by bug 467768 -- <http://hg.mozilla.org/comm-central/diff/01bd846dbb7e/mail/base/content/folderDisplay.js#l1.55>. There were several problems because of this (mainly with multiple message loads on startup with tab persistence on and a few message tabs open), and asuth said that since we're going to be adding folder summaries, it would be fine if I remove that code.

If we decide to add it back we'll need to rework it to prevent multiple loads from happening at startup. It shouldn't be too hard I guess.

Updated

10 years ago
No longer depends on: 497348
Whiteboard: regression range 20090628-20090629 → [regression range 20090628-20090629][no l10n impact]
In the folder summary - bug 492158 - designs we had planned to handle the previous selection inside the summary.  However the folder summary is not landing w/ TB3.0 so we'll need to figure out a way to bring this back.

sid, do you want to take this?
Yep, I'll look at this.
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Assignee: clarkbw → sid.bugzilla
Seems like bug 498514 was the cause of all the grief, which means that all I needed to do was to reintroduce the code :)
Attachment #398701 - Flags: review?(bugmail)
(Assignee)

Updated

10 years ago
Whiteboard: [regression range 20090628-20090629][no l10n impact] → [regression range 20090628-20090629][no l10n impact][needs review asuth]
Attachment #398701 - Flags: review?(bugmail) → review+
Whiteboard: [regression range 20090628-20090629][no l10n impact][needs review asuth] → [no l10n impact][regression range 20090628-20090629][needs review asuth]
(Assignee)

Updated

10 years ago
Whiteboard: [no l10n impact][regression range 20090628-20090629][needs review asuth] → [no l10n impact][regression range 20090628-20090629][needs landing]
http://hg.mozilla.org/comm-central/rev/1a6524fa578d
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][regression range 20090628-20090629][needs landing] → [no l10n impact][regression range 20090628-20090629]
(Assignee)

Updated

10 years ago
Flags: in-testsuite+
(Assignee)

Updated

10 years ago
Depends on: 515151

Comment 11

10 years ago
Can you, please, take a look at this issue as well: https://bugzilla.mozilla.org/show_bug.cgi?id=515301 ?

Thank you!
thanks sid
v.fixed with 20090908 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.