Closed Bug 505047 Opened 12 years ago Closed 12 years ago

Reply button in message header not in-line with other buttons

Categories

(Thunderbird :: Message Reader UI, defect)

x86
Windows XP
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 495478

People

(Reporter: squib, Unassigned)

References

()

Details

(Keywords: polish)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

In Windows XP (I tried Luna and Classic themes) the reply button is positioned one pixel higher than the rest of the buttons on its row. Removing "margin: 0px;" from ".hdrReplyButton > .button-menubutton-button" in classic.jar/skin/classic/messenger/messageHeader.css fixes this, but causes problems in Linux.

It's possible that a different method entirely should be used to make the dual buttons, since they don't look the same as Windows split buttons[1], but that's probably more complicated, since it doesn't appear that Mozilla supports that directly.

[1] http://msdn.microsoft.com/en-us/library/bb775947%28VS.85%29.aspx


Reproducible: Always

Steps to Reproduce:
1. Click on a single message
2. Look at the reply button
3. Oh hey it's higher than the others
Confirmed also here on 20090718 build.
Attached image screenshot
issue screenshot
Confirmed, this misalignment is already present in the 3.0 beta 2 release.
No duplicate found.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
Version: unspecified → Trunk
Blocks: 488061
(In reply to comment #2)
> Created an attachment (id=389357) [details]

There's also an image in the URL of the report. I probably should have mentioned this in the description somewhere, but I forgot!

For maximum clarity (and so the URL doesn't expire or something), I've attached the screenshot too.
Attached file possible solution
This file shows a possible solution I came across, mostly just by hacking around until something looked right. On the plus side, it appears to work equally well in Gnome and Windows. On the minus side, it's basically a hack.

I'm not sure why, but changing the top and bottom margins on the regular buttons affects the height of the dualbutton (happens in both Gnome and Windows). If you remove the "button" CSS class from the 2nd and 3rd buttons, the first (dual) button gets slightly taller. Strange.
Is this fixed as part of the patch for Bug 495478?

Thanks,
Blake.
(In reply to comment #6)
> Is this fixed as part of the patch for Bug 495478?

Works for me in the latest nightly (Aug 6th).
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 495478
You need to log in before you can comment on or make changes to this bug.