Closed Bug 505217 Opened 11 years ago Closed 11 years ago

test_videocontrols.html, test_videocontrols_audio_direction.html, test_videocontrols_video_direction.html, test_handlerApps.xhtml failures with NS_ERROR_XPC_BAD_OP_ON_WN_PROTO exception

Categories

(Core :: XPConnect, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.2b1

People

(Reporter: dbaron, Assigned: mrbkap)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

This appears different from existing bugs on random failures of these tests (bug 477634, bug 501754), so filing separately:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1248079597.1248081795.3791.gz
Linux mozilla-central test mochitests on 2009/07/20 01:46:37  

92139 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred: [ uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://global/content/bindings/videocontrols.xml :: anonymous :: line 778"  data: no] ]
92144 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred: [ uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://global/content/bindings/videocontrols.xml :: anonymous :: line 778"  data: no] ]
92153 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols_video_direction.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred: [ uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://global/content/bindings/videocontrols.xml :: anonymous :: line 778"  data: no] ]
Whiteboard: [orange]
OS X 10.5.2 mozilla-central test mochitests on 2009/07/21 04:01:07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1248174067.1248176344.19256.gz&fulltext=1

mrbkap can you take a look?
Assignee: nobody → mrbkap
Linux mozilla-central unit test on 2009/07/21 09:40:32
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1248194432.1248201710.16935.gz

Failures in test_videocontrols.html and test_videocontrols_audio_direction.html
Also, platform --> All, per comment 1
OS: Linux → All
Hardware: x86 → All
Summary: test_videocontrols.html and test_videocontrols_video_direction.html failures with NS_ERROR_XPC_BAD_OP_ON_WN_PROTO exception → test_videocontrols.html, test_videocontrols_audio_direction.html, test_videocontrols_video_direction.html failures with NS_ERROR_XPC_BAD_OP_ON_WN_PROTO exception
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1248227645.1248235196.31578.gz
WINNT 5.2 try hg unit test on 2009/07/21 18:54:05
Flags: wanted1.9.2?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1248357706.1248360022.29936.gz
OS X 10.5.2 mozilla-central test mochitests on 2009/07/23 07:01:46

This started happening on Jul 20.  If I look at the previous 2 days' checkins, it's a small window:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b980d1f13e87&tochange=247524e19d0c

Only one of those touches video - cpearce - could your changes be causing this intermittent orange?
(In reply to comment #7)
> Only one of those touches video - cpearce - could your changes be causing this
> intermittent orange?

I'd say it's unlikely. My change would only alter behaviour for videos with pixel-height 0. It could be a really subtle timing issue, but I'd say it's unlikely.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1248585509.1248586996.14732.gz
WINNT 5.2 mozilla-central test mochitests on 2009/07/25 22:18:29

*****

How come this is 'blocking1.9.1=needed' when it is reported on trunk only (so far)?
Blocks: 505755
(In reply to comment #11)
> How come this is 'blocking1.9.1=needed' when it is reported on trunk only (so
> far)?

Because that's the default on enter_bug.cgi for anybody who has the power to set blocking1.9.1, and sometimes I forget to change it.   See bug 504467.
blocking1.9.1: needed → ---
WINNT 5.2 mozilla-central test mochitests on 2009/07/28 12:56:30  
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1248810990.1248813014.25157.gz

test_handlerApps.xhtml also failed with a similar error:

92881 ERROR TEST-UNEXPECTED-FAIL | /tests/uriloader/exthandler/tests/mochitest/test_handlerApps.xhtml | [SimpleTest/SimpleTest.js, window.onerror] An error occurred: [ uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://global/content/bindings/videocontrols.xml :: anonymous :: line 778"  data: no] ]
Summary: test_videocontrols.html, test_videocontrols_audio_direction.html, test_videocontrols_video_direction.html failures with NS_ERROR_XPC_BAD_OP_ON_WN_PROTO exception → test_videocontrols.html, test_videocontrols_audio_direction.html, test_videocontrols_video_direction.html, test_handlerApps.xhtml failures with NS_ERROR_XPC_BAD_OP_ON_WN_PROTO exception
I can 100% reproduce this exception:

JavaScript error: , line 0: uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x
8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://global/content/bindings/videocontrols.xml :: anonymou
s :: line 778"  data: no]

All I need to do is load content/media/test/320x240.ogv in Firefox, and mouseover the video volume control, and I'm spammed by these exceptions.
Help us Obi-Dolske!
Flags: wanted1.9.2? → wanted1.9.2+
(In reply to comment #16)
> WINNT 5.2 mozilla-central test mochitests on 2009/07/28 12:56:30  
> 
> test_handlerApps.xhtml also failed with a similar error:

Actually, it would bet (test_videocontrols.html or) test_videocontrols_video_direction.html failures leaked to test_handlerApps.xhtml (for whatever reason) :-/
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1249094475.1249099644.18155.gz

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1249101675.1249107625.5347.gz

91799 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred: [ uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object" nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)" location: "JS frame :: chrome://global/content/bindings/videocontrols.xml :: anonymous :: line 778" data: no] ]
91804 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred: [ uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object" nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)" location: "JS frame :: chrome://global/content/bindings/videocontrols.xml :: anonymous :: line 778" data: no] ]
91813 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols_video_direction.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred: [ uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object" nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)" location: "JS frame :: chrome://global/content/bindings/videocontrols.xml :: anonymous :: line 778" data: no] ]
This issue is caused by patch1 in bug 500850. And patch2 in the same bug fixes this issue.
Depends on: 500850
Component: Video/Audio → XPConnect
QA Contact: video.audio → xpconnect
Attached patch Proposed fix (obsolete) — Splinter Review
The TODO comments are covered by bug 505915. I looked through the MORPH_SLIM_WRAPPER users and think I determined that they *don't* need this treatment. I'd appreciate a double-check on that though!

I think this is rando-orange on tinderboxes because we probably depend on GC happening or not happening to collect a fat (phat?) wrapper before we use the SOW-wrapped slim wrapper.
Attachment #392853 - Flags: superreview?(peterv)
Attachment #392853 - Flags: review?(peterv)
Ugh, how do we end up with a security wrapper around a slim wrapper? I thought we always morphed before security-wrapping. Can our security wrappers even deal with a slim wrapper?
Attachment #392853 - Attachment is obsolete: true
Attachment #393071 - Flags: superreview?(peterv)
Attachment #393071 - Flags: review?(peterv)
Attachment #392853 - Flags: superreview?(peterv)
Attachment #392853 - Flags: review?(peterv)
Comment on attachment 393071 [details] [diff] [review]
Per IRC discussion

Thanks!
Attachment #393071 - Flags: superreview?(peterv)
Attachment #393071 - Flags: superreview+
Attachment #393071 - Flags: review?(peterv)
Attachment #393071 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/45832a03722d
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2b1
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.