starting up in special folder mode results in blank folder pane

RESOLVED FIXED in Thunderbird 3.0rc1

Status

defect
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: mkmelin, Assigned: Bienvenu)

Tracking

unspecified
Thunderbird 3.0rc1
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(1 attachment)

Reporter

Description

10 years ago
1. Check View | Folders | Favorites
2. Restart

You'll have a blank folder pane, and the a lot of stuff non-initialized

Error: this._rowMap[j] is undefined
Source File: chrome://messenger/content/folderPane.js
Line: 339

... which is
  getSelectedFolders: function ftv_getSelectedFolders() {
    let folderArray = [];
    let selection = this._treeElement.view.selection;
    let rangeCount = selection.getRangeCount();
    for (let i = 0; i < rangeCount; i++) {
      let startIndex = {};
      let endIndex = {};
      selection.getRangeAt(i, startIndex, endIndex);
      for (let j = startIndex.value; j <= endIndex.value; j++) {
        folderArray.push(this._rowMap[j]._folder);
      }
    }
    return folderArray;
  },

It seems there's a selection, possibly persisted? But the selection isn't in the folder mode you used before restart.
Flags: blocking-thunderbird3+
Whiteboard: [no l10n impact]
Assignee: nobody → sid.bugzilla
These steps WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090906 Lightning/1.0pre Shredder/3.0b4pre

Magnus/sid are you still seeing this?
Keywords: qawanted
Whiteboard: [no l10n impact] → [no l10n impact][WFM?]
(In reply to comment #1)
> Magnus/sid are you still seeing this?

Nope, WFM too.
Reporter

Comment 3

10 years ago
I'm still seeing it. Or well, the symptoms, the error in the error console is now

Error: uncaught exception: [Exception... "Component returned failure code: 0x80550013 [nsIMsgFolder.subFolders]"  nsresult: "0x80550013 (<unknown>)"  location: "JS frame :: chrome://messenger/content/folderPane.js :: ftv_addSubFolders :: line 1226"  data: no]


And in the native console
Error -> TypeError: GetSelectedMsgFolder() is undefined
Summary: starting up in special folder mode generates errors → starting up in special folder mode results in blank folder pane
Whiteboard: [no l10n impact][WFM?] → [no l10n impact]
Interesting. I get the _rowMap error if I don't have any favourite folders defined -- however, I can switch to another folder view just fine.

Unassigning myself for now, since I just can't reproduce the bustage :(
Assignee: sid.bugzilla → nobody
Ok, so from what I can work out, this issue is only a problem if you start up Thunderbird in the following situation:

1) Either the unread or favourites modes have no entries.
2) You are starting up in either mode that has no entries.

I see the _rowMap errors in this state.

It does not appear to stop you switching modes (although it generates errors) and it doesn't stop you using TB.

Therefore I'm going to say that this has a reasonably easy work around and doesn't totally break Thunderbird. I'd still like to see us fix it as it an obvious error, but I don't think this block b4 in this state so moving out to rc1.
Keywords: qawanted
Target Milestone: Thunderbird 3.0b4 → Thunderbird 3.0rc1
Assignee

Comment 6

10 years ago
Does this still happen? I made exceptions in the generator/builder fall back to all folders mode late in the b4 cycle.
Reporter

Comment 7

10 years ago
Somewhat yes - 

If you unset all your favorite folders, so that you have none, and try to start up in fav folders mode you will get

Error: this._rowMap[j] is undefined
Source File: chrome://messenger/content/folderPane.js
Line: 341

Without restart the other modes won't show anything either if you try to change to them.
(In reply to comment #7)
> Without restart the other modes won't show anything either if you try to change
> to them.

Ok, I see something slightly different. The other modes actually have many extra lines to them and are scrolled right down to the bottom. Scrolling to the top and selecting a folder makes it work again.
Assignee

Updated

10 years ago
Assignee: nobody → bienvenu
Assignee

Comment 9

10 years ago
Posted patch proposed fixSplinter Review
this quiets all the assertions.
Attachment #403296 - Flags: review?(mkmelin+mozilla)
Assignee

Updated

10 years ago
Whiteboard: [no l10n impact] → [no l10n impact][has patch for review mkmelin]
Reporter

Comment 10

10 years ago
Comment on attachment 403296 [details] [diff] [review]
proposed fix

yay! r=mkmelin
Attachment #403296 - Flags: review?(mkmelin+mozilla) → review+
Reporter

Updated

10 years ago
OS: Linux → All
Hardware: x86 → All
Whiteboard: [no l10n impact][has patch for review mkmelin] → [no l10n impact][ready to land]
Assignee

Comment 11

10 years ago
fix pushed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][ready to land] → [no l10n impact]
Duplicate of this bug: 518614
You need to log in before you can comment on or make changes to this bug.