If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash [@ nsPropertyTable::GetPropertyInternal(nsPropertyOwner, unsigned short, nsIAtom*, int, unsigned int*)]

RESOLVED DUPLICATE of bug 471493

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 471493
8 years ago
6 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash, topcrash})

Trunk
x86
Windows XP
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(from crash-stats)
crash [@ nsPropertyTable::GetPropertyInternal(nsPropertyOwner, unsigned short, nsIAtom*, int, unsigned int*)]

#8 topcrash for 3.0b2 - doesn't appear yet in 3.0b3, so requesting blocking for analysis. perhaps extension related, or gone?  

nsPropertyTable::GetPropertyInternal also occurs in FF-land, but is not a topcrash there

most stacks are flagged "This dump is too long and has triggered the automatic truncation routine"

bp-a33bbd1e-d8ec-477e-a6ea-3b3912090429
0	thunderbird.exe	nsPropertyTable::GetPropertyInternal	 content/base/src/nsPropertyTable.cpp:185
1	thunderbird.exe	nsIFrame::GetClosestView	layout/generic/nsFrame.cpp:5510
2	xpcom_core.dll	PL_DHashTableOperate	pldhash.c:609
3	thunderbird.exe	nsIFrame::GetScreenRect	layout/generic/nsFrame.cpp:3564
4	thunderbird.exe	nsIFrame::GetScreenRectExternal	layout/generic/nsFrame.cpp:3559
5	thunderbird.exe	nsXULTreeAccessible::GetChildAtPoint	accessible/src/xul/nsXULTreeAccessible.cpp:336
6	thunderbird.exe	nsXULTreeAccessible::GetDeepestChildAtPoint	accessible/src/xul/nsXULTreeAccessible.cpp:363
7	thunderbird.exe	nsAccessible::GetChildAtPoint	accessible/src/base/nsAccessible.cpp:1154
(5-7 repeats)
13126	thunderbird.exe	nsAccessible::GetChildAtPoint	accessible/src/base/nsAccessible.cpp:1154
13127	thunderbird.exe	nsXULTreeAccessible::GetChildAtPoint	accessible/src/xul/nsXULTreeAccessible.cpp:352
13128	thunderbird.exe	nsXULTreeAccessible::GetDeepestChildAtPoint	accessible/src/xul/nsXULTreeAccessible.cpp:363
13129	thunderbird.exe	nsAccessible::GetChildAtPoint	accessible/src/base/nsAccessible.cpp:1154
13130	thunderbird.exe	nsXULTreeAccessible::GetChildAtPoint	accessible/src/xul/nsXULTreeAccessible.cpp:352
13131	thunderbird.exe	nsAccessibleWrap::accHitTest	accessible/src/msaa/nsAccessibleWrap.cpp:1026
13132	oleacc.dll	AccWrap_Base::accHitTest	
13133	oleacc.dll	AccessibleObjectFromPoint	
13134	oleacc.dll	EXTERNAL_AccessibleObjectFromPoint
Flags: blocking-thunderbird3?
based on http://www.processlibrary.com/directory/files/oleacc/23265 this might have to do with some accessibility extension.

Comment 2

8 years ago
This looks like the same as bug 471493, which was fixed and has been verified by wsmwk. Does this still not appear in 3.0b3 crash stats? If so, I suggest closing as dup of bug 471493.
this is totally off the radar for 3.0b3 3.0b4pre - gone. So trusting Marco's suggestion and duping, and removing blocking request
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: blocking-thunderbird3?
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 471493
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsPropertyTable::GetPropertyInternal(nsPropertyOwner, unsigned short, nsIAtom*, int, unsigned int*)]
You need to log in before you can comment on or make changes to this bug.