[meta] Send tabs to other browsers

RESOLVED FIXED

Status

()

P4
enhancement
RESOLVED FIXED
10 years ago
4 months ago

People

(Reporter: spiffytech, Unassigned)

Tracking

(Depends on: 3 bugs, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: 

The ability to pull tabs from other Firefox instances via Weave is
very handy to me but could be improved for certain scenarios. While at
work I frequently stumble across something that I want to look at when
I get home. I could wait until I get home, then pull the interesting
tab from my work computer, but that means I have to keep the tab open
all day at work, then remember to pull it when I get home. I'd like to
send tabs from my work computer to my home computer, have them
magically open there (immediately, if the browser is open, or whenever
I next sync). This would be a very handy feature for me. 

Reproducible: Couldn't Reproduce

Updated

10 years ago
Target Milestone: --- → Future
Really, you want something more like Read It Later or something similar.
Status: UNCONFIRMED → NEW
Component: General → Sync
Ever confirmed: true
QA Contact: general → sync
(Reporter)

Comment 2

9 years ago
Read It Later's functionality is close, but I'm particularly interested in the automatic-tab-open feature. Read It Later requires me to remember that there was something I wanted to read. To me, Weave is the logical place for this feature because it already has the code in place to manipulate browser instances, and Weave already does something somewhat close to sending tabs between browsers.
I think this is on our roadmap for mobile, at the very least... but not super high priority.
OS: Linux → All
Priority: -- → P5
Hardware: x86 → All
Target Milestone: Future → ---
Duplicate of this bug: 675360
This is on the roadmap and is being tracked at https://wiki.mozilla.org/Services/Sync/Push_to_device.

The current plan is to implement the functionality in phases:

1) Implement "send URI to other device" feature in the Sync core API
2) Implement UX in desktop and mobile

We will be tracking both independently, in separate bugs. It is possible the core feature/API will be released before the UI is present.
Assignee: nobody → gps
Depends on: 676375
Depends on: 677372
Depends on: 686704
Depends on: 696285
Figured I'd drop a link to this here, save me searching for it in the future:

https://addons.mozilla.org/firefox/addon/send-tab-to-device/
Depends on: 732147
Keywords: meta
Priority: P5 → P4
Summary: Send tabs to other browsers → [meta] Send tabs to other browsers
Duplicate of this bug: 732622
Depends on: 763171
Depends on: 769744

Comment 8

7 years ago
Should you consider bug 777799 in the implementation of this - if you're going to push a mobile-oriented page to another device, it might be better to use the canonical URL (or some similar mechanism).
(In reply to Oliver Henshaw from comment #8)
> Should you consider bug 777799 in the implementation of this - if you're
> going to push a mobile-oriented page to another device, it might be better
> to use the canonical URL (or some similar mechanism).

If you can come up with a 100%-reliable method for finding out the canonical URL for a page from its mobile URL, then we can think about doing that!
Note that this would really be part of the bookmark and history formats of the browser itself, not Sync. Sync doesn't see the page that you load, so it can't see <link> elements.

Comment 11

7 years ago
(In reply to Richard Newman [:rnewman] from comment #9)
> 
> If you can come up with a 100%-reliable method for finding out the canonical
> URL for a page from its mobile URL, then we can think about doing that!

Well, you can only use the canonical url when its provided somehow: according to http://support.google.com/webmasters/bin/answer.py?hl=en&answer=139066 it can be provided by the page itself or in the HTTP header. I see that it can be specified out-of-band in a sitemap, too.
Duplicate of this bug: 778075
(In reply to Oliver Henshaw from comment #11)

> Well, you can only use the canonical url when its provided somehow:

See my last comment: it's more than that.
Depends on: 767663

Updated

5 years ago
Duplicate of this bug: 913879
Assignee: gps → nobody

Comment 15

4 years ago
Would love to see this prioritised to make Firefox on Android even higher value
Duplicate of this bug: 1222598

Comment 17

a year ago
With the move to WebExtensions-only in Firefox 57, the only support for "push-like" (as opposed to "pull-like") tab workflows on desktop, currently provided by the Send Tab to Device addon(https://addons.mozilla.org/en-US/firefox/addon/send-tab-to-device/), will cease to function.

As push-based workflows are very useful in various cases (when one doesn't intend to leave the tab open in the source, when the source has enough tabs that going through them on a small mobile device is painful, etc.), could this be revisited?
(In reply to Alex Elsayed from comment #17)
> could this be revisited?

What specifically do you want revisited? This feature is built into Firefox desktop and mobile (at least on iOS) for a while now without any extensions. On desktop, try right-clicking on a tab or webpage and open the "Send _ to Device >" menu.
(In reply to Alex Elsayed from comment #17)

> As push-based workflows are very useful in various cases (when one doesn't
> intend to leave the tab open in the source, when the source has enough tabs
> that going through them on a small mobile device is painful, etc.), could
> this be revisited?

Send Tab is built into Firefox: right-click on a tab in the tab bar and choose "Send Tab to Device", or right-click on a link and choose "Send Link to Device".

Send Tab uses push on all modern Firefoxes.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Updated

4 months ago
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.