Closed Bug 508761 Opened 12 years ago Closed 11 years ago

Ship a separate Toolbar.png optimized for Personas

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 578422

People

(Reporter: dao, Unassigned)

References

Details

spin-off from bug 494927 comment 26:

> >The more domination of the background over individual controls, the less
> >usability (depending on the background of course, which we can't control).
> 
> I agree, but I think the lower mockup in attachment 392552 [details] works well.  The
> buttons and glyphs have a strong black and white outline (considerably stronger
> than we would consider useing for a normal theme) so they remain well defined
> on a range of backgrounds, and the center areas are clear enough to let the hot
> pink (or whatever) still dominate the design.

I think that mock-up has issues with the tabs, esp. background tabs, and I don't think the toolbar is ideal either. Again, it depends on the background. I think Chrome gets this right for the toolbar buttons (and not so right for the tabs and the Page/Tools buttons):
<http://tools.google.com/chrome/intl/en/themes/>. But Personas are (intentionally) less powerful than themes, and we don't have the data we'd need to colorize the buttons automatically.

The Chrome theme gallery also contains some nice examples for very vivid backgrounds, by the way, which attachment 392552 [details] wouldn't handle that nicely.
Summary: Ship a separate, optimized Toolbar.png for Personas → Ship a separate Toolbar.png optimized for Personas
I was actually advocating against a one-size-fits-all universal approach with that mockup. Although I disagree that there is a problem with the way the mockup handles tabs or the toolbar.

Attachment 392552 [details] was supposed to illustrate that on dark backgrounds you would want a different approach. On a light background you would want a different approach still.

I think Chrome actually does a smart thing with those themes because they allow limited manipulation of background elements, foreground elements and the toolbar buttons. The themes are really just a 20 line XML file and a few images far simpler than a full fledged theme but enough control to make the elements mesh visually.

Or course those are all developed by Google so it is still up to the designer to not screw it up.
(In reply to comment #1)
> Although I disagree that there is a problem with the way the
> mockup handles tabs or the toolbar.

We may be talking about different things. The mock-up looks mostly fine as is (although I think the background tab labels are too faint already). I don't think it would look as fine with different, more vivid backgrounds.
Blocks: 511104
What's the next action required here?
Depends on: 511107
Dao - Is this bug still valid, given the built in support for personas? Does the add-on still want this for some reason?
I don't know if the add-on wants this, but this bug is about what we ship. Right now we don't ship a separate Toolbar.png for personas, so this is still open.
Themes and Personas are different. Personas are only a basic change, mostly for fun, they do not affect many places, do not affect button appearance, etc. Themes, on the contrary, are a result of a very detailed work, with a completely changed appearance. To satisfy the request in this bug's reporter, users should choose themes.

I deny Personas... They are just a toy, and a very sad one, because they are now called "themes", though they aren't serious at all... As I can easily throw Personas away from Firefox, I vote for wontfix.
"Themes and Personas are different."

^Apparently not so anymore- which is soooo annoying. My favorite theme, Strata40, (which, incidentally, is the theme depicted in the attachment images) works beautifully with Personas- but since upgrading to Firefox 3.6, I am only able to use Persona's with (bleh!) the Default theme... uuh, the yucky green Forward/Back buttons of the Default theme look horrendous with a number of Personas- totally clashing with them - at least the Strata40 buttons are neutral & match anything & everything- you can't go wrong with it.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578422
You need to log in before you can comment on or make changes to this bug.