Closed Bug 509315 Opened 10 years ago Closed 10 years ago

NS_ERROR_MALFORMED_URI on session restore (in nsSessionStore.js)

Categories

(SeaMonkey :: Session Restore, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0

People

(Reporter: sune, Assigned: misak.bugzilla)

References

Details

(Keywords: fixed-seamonkey2.0)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; rv:1.9.2a2pre) Gecko/20090809 SeaMonkey/2.1a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.9.2a2pre) Gecko/20090809 SeaMonkey/2.1a1pre

Starting after a crash, and selecting to load the last session, only the 3 first and the last 7 tabs actually load - the remaining ones have empty locations, but show the animation for "loading".

Error console reports:

Error: uncaught exception: [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIIOService.newURI]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: file:///opt/seamonkey-2.1a1pre-2/components/nsSessionStore.js :: sss_deserializeHistoryEntry :: line 1827"  data: no]

Setting severity to major, since this is quite bad - especially considering that crashes aren't unheard of (hence the feature, i guess).

Reproducible: Didn't try
Can you reproduce with SeaMonkey current v2.0b2pre?
Version: unspecified → Trunk
Yes, except now, it's only the first 3 and the last tab that loads anything. The message in the error console is the same.
Could someone provide a link with directions for pulling and building 2.1a1pre so I can build it with debugging enabled? The usual directions produce a 2.0b2pre package...

With official nightlies, I have gotten most of the tabs back (only two were completely blank), but only a few would load - the others had the location bar filled out, but getting nothing until manually reloading, however, after closing the fully blank tabs, most tabs now load as expected.

I get frequent segfaults, enabling me to keep this original number of tabs plus added ones since last segfault, but newly added tabs sometimes turn up completely blank...
This bug might be caused by some form of corruption in a state file (which?), also causing https://bugzilla.mozilla.org/show_bug.cgi?id=510196
This will be quite difficult to debug without having a sessionstore.js from your profile which actually exhibits this issue.
I have a reduced test case & wallpaper patch in bug 514751.
Depends on: 514751
Straight port of patch. Test passes on my Linux box.
Assignee: nobody → misak
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #400264 - Flags: superreview?(neil)
Attachment #400264 - Flags: review?(neil)
Attachment #400264 - Flags: approval-seamonkey2.0?
This bug also depends on bug 516073, where proper fix will be available.
Blocks: 516073
Attachment #400264 - Flags: superreview?(neil)
Attachment #400264 - Flags: superreview+
Attachment #400264 - Flags: review?(neil)
Attachment #400264 - Flags: review+
Keywords: checkin-needed
OS: Linux → All
Hardware: x86_64 → All
Attachment #400264 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
Comment on attachment 400264 [details] [diff] [review]
ported patch
[Checkin: Comment 9]


http://hg.mozilla.org/comm-central/rev/0205bb7bedbb
Attachment #400264 - Attachment description: ported patch → ported patch [Checkin: Comment 9]
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0
You need to log in before you can comment on or make changes to this bug.