Closed Bug 509501 Opened 15 years ago Closed 13 years ago

Prepare a Add-on Compatibility Center for SeaMonkey 2.1

Categories

(addons.mozilla.org Graveyard :: Compatibility Tools, enhancement, P4)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED
Future

People

(Reporter: kairo, Unassigned)

References

()

Details

Attachments

(2 files)

The URL that one would expect to bring up the SeaMonkey compatibility center results in some unexpected output: https://addons.mozilla.org/en-US/seamonkey/compatibility

As we're preparing for a SeaMonkey 2.0 final in October, it would be good to have such a site operable as well.

Can this be done easily enough?

What material/info would you need from the SeaMonkey side?

[BTW, looks like Thunderbird has the same filed for their side as bug 477824 - their final will come a few weeks after ours, though]
Fligtar: can you advise on what all this entails?  I see bug 477824 is assigned to non-amo dev - are we waiting on something there?  I guess I'm asking for steps to generate the output we need.  I thought it was just a cron job.
Cesar talked over in bug 477824 that he'll do the work here as well once he has finished the stuff for Thunderbird, and that wordmarks are needed.

Am I right that we'll need the same as the ones in http://svn.mozilla.org/addons/trunk/site/app/webroot/img/wordmarks/ for SeaMonkey 2.0 here?

I'll be on vacation the next three weeks and don't want to block something being made to work here, so assuming it's correct that we need those, should I attach them here, or would I even be OK to pre-land them in the repo?
(In reply to comment #2)
> Am I right that we'll need the same as the ones in
> http://svn.mozilla.org/addons/trunk/site/app/webroot/img/wordmarks/ for
> SeaMonkey 2.0 here?

Yep. That's the only thing I will need to complete this bug.

There is hard-coded links in the compatibility dashboard to MDC. I can give you the exact link later (it'll be something like https://developer.mozilla.org/en/SeaMonkey_2.0_for_developers). But under Information for add-on developers, we need to make sure that SeaMonkey has an MDC article or some other information page for developers wanting to upgrade their extension for SeaMonkey 2.0
> we need to make sure that SeaMonkey has an
> MDC article or some other information page for developers wanting to upgrade
> their extension for SeaMonkey 2.0

We have an MDC entry at:
<https://developer.mozilla.org/en/Extensions_support_in_SeaMonkey_2>
Component: Public Pages → Compatibility Tools
QA Contact: web-ui → compatibility
Assignee: nobody → a.sacred.line+bugzilla
Severity: normal → enhancement
Priority: -- → P4
Target Milestone: --- → Future
Depends on: 525416
Depends on: 477824
Attached image seamonkey-2.0.png
Here's the large wordmark - I hope those images are not too wide, else I'll need to look into how making our official artwort font more condensed.
Attached image seamonkey-2.0_small.png
Cesar, any ETA when you can get this going? Anything you stilol need from our side?
Nothing I need from your side. I hope to get this completed by 5.6, hopefully it will be one of the bugs chosen for that release.
Status: NEW → ASSIGNED
Cesar, any ETA when you might around to that? The add-ons blog advices people to add SeaMonkey 2.0 support to their add-ons, but we unfortunately don't have much around to watch compatibility...
No sense any more to do this for 2.0, unfortunately this has completely stalled. :(

Perhaps there's still a chance for 2.1, which is planned for fall of 2010.
Summary: Prepare a Add-on Compatibility Center for SeaMonkey 2.0 → Prepare a Add-on Compatibility Center for SeaMonkey 2.1
Blocks: 576305
Un-assigning as we haven't heard from Cesar in a long time.

That said, I'm told porting his Thunderbird work from bug 477824 probably should still work as the compat dashboard is still running from remora (PHP) and not yet on zamboni (Python).
The uber-work would be if someone would port the dashboard for all products to zamboni and make SeaMonkey work in the process, but I think we might just want to settle for the easy solution and port SeaMonkey support into remora before that feature is migrated to zamboni...
Assignee: a.sacred.line+bugzilla → nobody
Status: ASSIGNED → NEW
I don't think you'll find many volunteers to write or review old code that is just going to be rewritten.  I think you should aim for zamboni.
The problem is that there is no compat center code for zamboni from what I'm told, and we would want this running yesterday, and with our thin-spread resources and nobody in SeaMonkey knowing zamboni code, I doubt someone from our side would write the new zamboni compat center code.
So I see no alternative to either trying and writing a remora patch based on bug 477824 or waiting indefinitely until there might be a zamboni compat center and in the mean time continuing to have a bad major release experience wrt AMO.

Sure, all two/three alternatives are suboptimal, but I see no other one :(
Note that until bug 525416 is fixed, a SeaMonkey dashboard will not be super useful because it will be ranked by all application ADU instead of just SeaMonkey.

I've been running reports manually for the Thunderbird team when they request them, so I'll send KaiRo one for SM 2.1 and he can distribute as needed.
No longer blocks: 576305
Depends on: 647029, 647023
Made possible in bug 647029. Closing because I doubt sm 2.1 is still relevant; we can drop in a more recent sm version.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
(In reply to comment #15)
> Made possible in bug 647029. Closing because I doubt sm 2.1 is still relevant;
> we can drop in a more recent sm version.

Well 2.1 is our upcoming version, I'm hoping to spin it within the next week if I can.

After that is 2.2.
(In reply to comment #16)
> (In reply to comment #15)
> > Made possible in bug 647029. Closing because I doubt sm 2.1 is still relevant;
> > we can drop in a more recent sm version.
> 
> Well 2.1 is our upcoming version, I'm hoping to spin it within the next week if
> I can.
> 
> After that is 2.2.

FYI to those CC-ed, the addon reported linked in the URL field of bug is up and running it seems, though it reports for SeaMonkey 5.0 this will need fixing.
Depends on: 668661
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: