Acid 2 Test on n810 does not render at all

VERIFIED FIXED in fennec1.0b4

Status

Firefox for Android Graveyard
General
--
blocker
VERIFIED FIXED
9 years ago
5 years ago

People

(Reporter: aakashd, Assigned: vingtetun)

Tracking

Trunk
fennec1.0b4
ARM
Maemo
Dependency tree / graph
Bug Flags:
wanted-fennec1.0 ?
in-litmus +

Details

(Whiteboard: [fennecb3testday])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Steps to Reproduce:
1. Go to http://www.webstandards.org/files/acid2/test.html
2. lick on "Take the Acid2 Test".

Actual Results:
Nothing happens

Expected Results:
The smiley face (in some sort of form should show up)
Flags: wanted-fennec1.0?
Flags: in-litmus?
(Reporter)

Updated

9 years ago
tracking-fennec: --- → ?
Whiteboard: [fennecb3testday]
I believe we need to add back the "scroll" event support that was in CanvasBrowser, but not ported to the tile system.

See bug 452286 and bug 470861 and bug 499388
(In reply to comment #2)
> Created an attachment (id=396722) [details]
> Patch v0.1
> 
> mainly a backport of the patch for bug 452286

I guess this probably belongs in bug 512277...
Depends on: 512277

Updated

9 years ago
Attachment #396722 - Flags: review? → review?(froystig)
Duplicate of this bug: 499388

Updated

9 years ago
Attachment #396722 - Flags: review?(froystig) → review+
Comment on attachment 396722 [details] [diff] [review]
Patch v0.1

>+    let zoomLevel = this._browserViewportState.zoomLevel;
>+    Browser.contentScrollboxScroller.scrollTo(scrollX * zoomLevel, scrollY * zoomLevel);

We're pretty consistent with this everywhere else, so collapse these two lines to:

>     Browser.contentScrollboxScroller.scrollTo(this.browserToViewport(scrollX), this.browserToViewport(scrollY));

r+ with that.
Created attachment 397249 [details] [diff] [review]
Address Roy's comments
Attachment #396722 - Attachment is obsolete: true
Attachment #397249 - Flags: review?(froystig)

Updated

9 years ago
Attachment #397249 - Flags: review?(froystig) → review+
Blocks: 512277
No longer depends on: 512277
Keywords: checkin-needed
https://hg.mozilla.org/mobile-browser/rev/63986b01506d
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → B4
(Reporter)

Comment 9

9 years ago
So, the smiley is showing up, but it looks maimed and disfigured...so, that'll hopefully be taken care of with bug 499388

verified FIXED on builds: 

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.3a1pre) Gecko/20090901 Fennec/1.0a3

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090901
Fennec/1.0b4pre
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

9 years ago
This bug is on our litmus BFT via testcase:

https://litmus.mozilla.org/show_test.cgi?id=7386
Flags: in-litmus? → in-litmus+
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.