bookmarks -> view -> Update Bookmarks

RESOLVED WONTFIX

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
18 years ago
6 years ago

People

(Reporter: rw263, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ben-postRTM][2012 Fall Equinox][Extension Fodder])

(Reporter)

Description

18 years ago
On Netscape x.x there has always been under bookmarks an option in the bookmarks 
view menu "Update Bookmarks". I think this is a superb option and I use it quite 
often. Tis actually one of the reasons I still stay with Netscape. I just d/l 
Milestone 17 and didn't see this option. Please, bring it back!!

Comment 1

18 years ago
In Netscape 4.75 on windows, I don't see a View submenu in the Bookmarks menu.  
Could you please explain further?
Summary: bookmarks -> view -> Update Bookmarks → [RFE] bookmarks -> view -> Update Bookmarks

Comment 2

18 years ago
In email from reporter:

"I am Running Netscape Communicator 4.75. When you press ctrl-b you get a
bookmark window, there is a view menu there. (that is what I am referring
to)."

confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
 
Assignee: slamm → ben
Netscape Nav triage team: this is not a Netscape beta stopper.
Keywords: nsbeta1-

Comment 5

18 years ago
bug 8648, bug 13012, bug 22714, bug 23212. Is there an issue not covered in
those bugs that should be in the update feature?

Comment 6

17 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future

Updated

17 years ago
Blocks: 23212

Comment 7

17 years ago
One issue this bug addresses that isn't addressed in the other "bugs" is the
ability for the user to instantly check a specified number of links by selecting
them or the parent folder. Under the current system, this is not possible. I
personally would like this feature to be implemented.
This sounds like fun. I'd like to do this after RTM.

This could include updating the date, and displaying a different icon if the
document no longer exists. (Maybe even with an audit allowing the pruning of
dead links). 

Whiteboard: [ben-postRTM]

Comment 9

17 years ago
After RTM???  <sigh>

For those of us with 160K bookmark files, this is much desired...
see also: 
http://www.geocrawler.com/archives/3/119/1999/12/0/3033755/

I guess I'll just wish for the following to be included under "Update Bookmarks"

- find dupes (ask user, by default; option to delete one, or delete both and
copy one to some location)

- http validator (with gamespy-like options to auto-delete if bookmark fails x
times in y days, etc.)

- barring all else, just make it faster; I can only stomach trying to manage
bookmarks for a short while before I get totally frustrated at the speed -- and,
yeah, its only a 266...

Comment 10

17 years ago
Ok... less itchy now. :)

Here's a quick Perl hack for the inclined.  Uses the (unused?) description field
to store the http HEAD code.  Amazon.com doesn't like HEAD requests, oh well.

I'm filing a bug about not being able to delete URLs from the bookmark search
results window.  That kinda ruins the fun of this script.

I saw one 404 that wasn't really 404 (?)

caveat emptor


#!/usr/local/bin/perl -w

use strict;

# Create a user agent object
use LWP::UserAgent;

my $ua;
my $req;
my $res;

$ua = new LWP::UserAgent;
$ua->agent("AgentName/0.1 " . $ua->agent);

$ua->timeout(5); # in seconds; pretty short, change as you like

open BM, "<bookmarks.html";
open OM, ">outmarks.html";

my $indent = '';

for my $line (<BM>)
{
	# *** WARNING WARNING WARNING ***
	#
	# DANGER, WILL ROBINSON, DANGER!
	#
	# skip definition/description/comments lines
	#
	# If you use your description field for anything, you'll want to change
	# this.  Fair warning.
	# OTOH, we're not clobbering your file, unless you have a file called
	# outmarks.html...
	#
	next if $line =~ /\s*<DD>/;
	
	# print all the other lines
	print OM $line;

	# don't do anything if the line doesn't have an http URL
	next unless $line =~ s/^(\s*).*?HREF="(.*?)".*/$2/;

	$indent = $1 . "    ";

	chomp( $line );
	
	# get the HTTP code and message

	# Create a request
	$req = new HTTP::Request HEAD => "$line";

	# Pass request to the user agent and get a response back
	$res = $ua->request($req);

	# print the code in a <DD> line
	print OM "$indent<DD>", $res->code, " ", $res->message, "\n";
}

close BM;
close OM;


Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen

Comment 12

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 13

17 years ago
How about integrating this work with bug 74627-  'schedule' and 'notify'
bookmarks globally - with the addition of an option to "notify global
immediately" which would be exactly the same as "update all bookmarks." All we
need for "update all bookmarks" is a fix for 74627 and an option to set
notification to now instead of some future time.

Updated

16 years ago
Blocks: 121751

Updated

16 years ago
Blocks: 74627
This is the one bug that is keeping me from switching from Internet Explorer as
my default browser.   I have a list of 200 sites that I check daily for updates.
 IE 5.x (Mac OS, Mac OS X) has a feature that checks all marked Favorites for
updates.  As soon as this is implemented in Mozilla (preferably just as it
worked in 4.x) then I have no use for IE.   IE is unstable and incompatible with
quite a few pages.  I have not yet found a page I can't use Mozilla in, and even
though it still needs some work, it seems to be a better browser.   IE for Mac
OS X doesn't even include an e-mail client, let alone a page composer!
Keywords: 4xp, mozilla1.2, nsbeta1

Comment 15

16 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
*** Bug 160895 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 36495 has been marked as a duplicate of this bug. ***

Updated

16 years ago
URL: n/a
Summary: [RFE] bookmarks -> view -> Update Bookmarks → bookmarks -> view -> Update Bookmarks

Comment 18

14 years ago
*** Bug 239026 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Comment 19

12 years ago
The description of the bug itself isn't very clear about the function of the "update button". What I read from the comments is that it checks if the bookmarked site has been updated. Is this correct?
Assignee: bugs → nobody
QA Contact: claudius → bookmarks

Comment 20

6 years ago
On one hand this is still valid rfe, on other this may be done as add-on, but I can find only a bit outdated https://addons.mozilla.org/en/firefox/addon/bookmarks-linkchecker/
Priority: P3 → --
Whiteboard: [ben-postRTM] → [ben-postRTM][2012 Fall Equinox]

Comment 21

6 years ago
Plus these days people would be using RSS feeds to track updates.
Extension Fodder=> WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Whiteboard: [ben-postRTM][2012 Fall Equinox] → [ben-postRTM][2012 Fall Equinox][Extension Fodder]
You need to log in before you can comment on or make changes to this bug.