Saved passwords with multiple account, identical with different case.

RESOLVED DUPLICATE of bug 499649

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 499649
9 years ago
6 years ago

People

(Reporter: Florian Fischer, Unassigned)

Tracking

4.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

I have 2 accounts on www.puzzleup.com, one is Grimbal, the other is grimbal.  Both have saved passwords.

If I enter "grimbal" in the user field, it gets changed to "Grimbal" at the same time where the password gets restored.  In fact, it now is impossible to enter the lowercase version.  But if I remove the saved password for "Grimbal", then "grimbal" remains "grimbal" and the password is restored propertly.

That problem wasn't there in Firefox 3.0 (or so).

It looks to me that the search for a saved password was made case-insensitive. The first approximate match is now used, even though an exact match might exist further in the list.  This is inappropriate.  An exact match must be preferred before a case-insensitive match.

PS:  Actually it is worse.  Now that I have removed the saved "Grimbal", it is impossible to log in as "Grimbal".  If I enter "Grimbal" it gets replaced by "grimbal".  Even preferring an exact match wouldn't help.  A solution must be found to make it possible again to log in with an account that differs from a saved account by the case only.

I would propose to stop auto-correcting the case of the user name when restoring the password.  Instead, suggest the correction of the user name via the autocomplete drop-down list.

Reproducible: Always

Steps to Reproduce:
- go to a page that asks for a user and password
- enter user Toto, password toto, click login
- ask to remember the password
- go back to the login page
- try to log in as user toto (in lowercase).
Actual Results:  
The user name gets replaced by "Toto".  You can not login as "toto".

Expected Results:  
I want to login sometimes as "toto", sometimes as "Toto".  And save the passwords.
(Reporter)

Comment 1

9 years ago
I would reformulate the bug as:

The search for a user name in the saved passwords was made case-insensitive in version 3.5 or so.  This makes it impossible to enter some user names.  It must be made case-sensitive again.
OS: Windows 2000 → All
Hardware: x86 → All
Version: unspecified → 3.5 Branch

Comment 2

9 years ago
I have the same issue. Two different logins on the same site with different cases and passwords. Really annoying; I can't login at all if I want Firefox to remember my passwords.

Comment 3

9 years ago
This looks like a dupe of Bug 499649.

Comment 4

9 years ago
or maybe Bug 516037 is a dupe of this one

Comment 5

9 years ago
This one and bug #516037 should be marked as duplicates of bug #499649.

Comment 6

9 years ago
516037 and 499649 are very similar but not necessarily the same bug. :-/

Comment 7

9 years ago
Right, indeed they are not the same bug. Either way, some cleanup/triaging needs to be done, I can find at least 4 bugs that describe a similar issue or family of issues: bug #499649, bug #510573, bug #512101 and bug #523899.

Comment 8

9 years ago
I have the same issue:

Usernames stored in"Tools > Options > Security > Saved Passwords are NOT CASE-SENSITIVE but they need to be.

Comment 9

8 years ago
This mess is a result of the unfortunate "Fix" for Bug #447788. Unfortunately, it appears that the responsible developers have decided that it is a bad idea to have multiple accounts that differ by case, so they have no interest in supporting that use case
Reporter, are you still seeing this issue with Firefox 4.0.1 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-05-30]
(Reporter)

Comment 11

7 years ago
The bug is still present.  Saving the password for johndoe makes it impossible to login as JohnDoe.

In my humble opinion, there is no excuse for a browser to change the input of an user in a web form.  If a web site works better when the browser adjusts the user input, then the web site is broken, not the browser.
No reply, INCOMPLETE. Please retest with Firefox 4 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). Also, ensure you have the most up to date graphics drivers, operating system updates, and plugin versions (flash, java, etc). If you continue to see this issue with the newest Firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 13

7 years ago
The last test I did was just 2 weeks ago and I am pretty sure it was Firefox 4 already.  Anyway, I checked for updates, I restarted Firefox with a clean profile, and I confirm the problem is still there.

I even put up a test page and discovered it is a bit more broken than I thought it is.

- Go to http://florian.net/firefox/testlogin.php.  It is a dummy login page.
- enter user "toto" and password "secret".
- When asked, request to save the password.  You can see that "toto" and "secret" was submitted.  So far, so good.
- Without going back to the first page, enter user "TOTO" and password "supersecret".
- Save the password.
- You can see that "TOTO" and "supersecret" was successfully submitted.  If you check your saved passwords, you can see both usernames and passwords were saved.
- But that works only one time.  Now, whatever you do, if you enter "TOTO", "Toto", "TotO", or whatever, it reverts to "toto"!

That needs to be fixed, right?  ;-)

So if someone volunteers to work on this, I'd be very grateful if you could take the extra step to actually fix it.  The only thing I ask is that Firefox doesn't change the case of what I enter after I entered it.  And let the web sites decide if they want to be case sensitive or not.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Updated

7 years ago
Whiteboard: [CLOSEME 2011-05-30]
Version: 3.5 Branch → 4.0 Branch

Comment 14

7 years ago
Bug confirmed in firefox 5.
(Reporter)

Comment 15

7 years ago
Bug confirmed (yawn..) in Firefox 6.0.

Note that it doesn't just fail to save the password for the other password.  It prevents me completely from logging in in my other account.

So what am I doing?  I am using Safari for the other account.  And guess what, then I use Safari for the first account too, and for other pages.  And for other sites.  If it were not for a color problem in Safari, I would have completely switched to Safari.

Updated

6 years ago
Duplicate of this bug: 787661

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499649
You need to log in before you can comment on or make changes to this bug.