deleting an IMAP subfolder leaves the folder visible

RESOLVED FIXED in Thunderbird 3.0rc1

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: brandt24, Assigned: Bienvenu)

Tracking

Thunderbird 3.0rc1
x86
Windows Vista
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090827 Shredder/3.0b4pre

deleting an IMAP subfolder from trash does not remove the folder until restarting TB

Reproducible: Always

Steps to Reproduce:
1. Create an IMAP account.
2. Create a folder.
3. Delete it.
4. Make sure it is moved to Trash.
5. Now try to delete this subfolder.

Actual Results:  
After being deleted it is still visible.

Expected Results:  
The folder should be gone.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0
(Reporter)

Comment 1

9 years ago
Sorry, it does not happen always.
(Reporter)

Updated

9 years ago
Version: 3.0 → unspecified
(Reporter)

Updated

9 years ago
Summary: deleting an IMAP subfolder → deleting an IMAP subfolder leaves the folder visible
Version: unspecified → 3.0
(Reporter)

Comment 2

9 years ago
By that I mean the it is reproducible sometimes.
(Reporter)

Comment 3

9 years ago
Tested it with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090909 Shredder/3.0b4pre, the issue is still present.
Severity: normal → major
Flags: blocking-thunderbird3?
I just tried this and it WFM.

Can you attach a protocol log showing a failing delete?

https://wiki.mozilla.org/MailNews:Logging
Keywords: qawanted
(Assignee)

Comment 5

9 years ago
I believe in some cases some piece of code is holding the db open and preventing us from removing the folder - but restarting should fix it, I believe.
Assignee: nobody → bienvenu
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0rc1
(In reply to comment #0)
> deleting an IMAP subfolder from trash does not remove the folder until restarting TB

Restart of Tb is really mandatory?
This kind of issue is folder pane refresh/update issue in many cases. And, AFAIR, one of next was effective manual recovery procedure in many cases.
(1) Collapse/re-expand, parent folder, account.
(2) If (1) is not effective, open new Tb window, and close old Tb window.
    Context menu of account/folder, "Open".
Is (1) or (2) effectibve in your environemnt?

Does same problem occur with "Empty Trash"?

By the way, I saw similar phenomenon by rename of Gmail IMAP folder with Tb 2009/9 /09 build. (1) was effective recovery procedure in my case.
(Reporter)

Comment 7

9 years ago
I just tried it with:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090913 Shredder/3.0b4pre

and the issue is still present. I created a new folder called Folder to be deleted, which I then deleted and it was moved to Trash. After trying to delete it from there, the folder is still present. After a few clicks around in the program I get an alert: The current command did not succeed.  The mail server responded:Mailbox doesn't exist: Trash.Folder to be deleted

Restarting TB twice finally took the folder away.
(Reporter)

Comment 8

9 years ago
okay, I created the log, how shall I send it to you? Do I need to sanitize it someway too?
(Assignee)

Comment 9

9 years ago
I'm not sure that a log is going to be helpful here, since it's the local client code that's holding the db open. If I can't reproduce this, I might ask for a log...
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 10

9 years ago
Ok.
(Assignee)

Comment 11

9 years ago
Created attachment 400816 [details] [diff] [review]
proposed fix

Make nsImapMailFolder::Delete tell all db listeners about the db going away, even if its cached db pointer has already been cleared. nsLocalMailFolder::Delete already does this.
Attachment #400816 - Flags: superreview?(bugzilla)
Attachment #400816 - Flags: review?(bugzilla)
(Assignee)

Updated

9 years ago
Keywords: qawanted
Whiteboard: [has patch for r/sr standard8]

Updated

9 years ago
Whiteboard: [has patch for r/sr standard8] → [no l10n impact][has patch for r/sr standard8]
(Assignee)

Updated

9 years ago
Duplicate of this bug: 517419
(Assignee)

Comment 13

9 years ago
would be nice to get this reviewed and landed soon, because I believe there are a fair number of bugs that can be closed once this lands.
Attachment #400816 - Flags: superreview?(bugzilla)
Attachment #400816 - Flags: superreview+
Attachment #400816 - Flags: review?(bugzilla)
Attachment #400816 - Flags: review+
(Assignee)

Comment 14

9 years ago
fix checked in - I'll try to find the various bugs that also are fixed by this...
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][has patch for r/sr standard8] → [no l10n impact]
(Assignee)

Updated

9 years ago
Duplicate of this bug: 515319
(In reply to comment #14)
> fix checked in - I'll try to find the various bugs that also are fixed by
> this...

Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.9.1.4pre) Gecko/20090922 Lightning/1.0pre Shredder/3.0pre

i don't see it fixed (the problem reported in bug 517419)
Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.9.1.4pre) Gecko/20090923 Lightning/1.0pre Shredder/3.0pre

not fixed
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 18

9 years ago
it's working here - I can't reproduce any issues, whereas it was easy to reproduce earlier.
Then is bug 517419 not a dupe of this bug
(Assignee)

Comment 20

9 years ago
They both work here - if you're seeing 517419 but not 513012, then I would say your situation is not a dup. Are you seeing this bug, bug 513012?
(In reply to comment #20)
> They both work here - if you're seeing 517419 but not 513012, then I would say
> your situation is not a dup. Are you seeing this bug, bug 513012?

I can delete a folder so i don't see this bug (anymore).
(Assignee)

Comment 22

9 years ago
ok, I'll re-mark this fixed and undupe bug 517419.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.