Closed Bug 513168 Opened 11 years ago Closed 7 years ago

Remove "Stop" and "Reload" from View menu

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 25

People

(Reporter: Dolske, Assigned: dao)

References

(Depends on 1 open bug)

Details

(Keywords: useless-UI, Whiteboard: [killthem])

Attachments

(1 file, 2 obsolete files)

These seem not-so-useful and are accessible from other parts of the UI.
Whiteboard: [killthem]
It serves as a reminder for the keyboard shortcuts (esc/ctrl-r)
Menu items as keyboard command reminders aren't really all that helpful. We can add the keyboard shortcuts to the tooltips.
(In reply to comment #2)
> Menu items as keyboard command reminders aren't really all that helpful. We can
> add the keyboard shortcuts to the tooltips.

Which a mouse-less user won't be able to discover, though. One "Help -> Keyboard Shortcuts" item should be able to replace all such menu items in a sec508 compatible manner, though.
suggesting to include in this discussion also "back" "forward" and "home" from the history menu, which stand on similar footing
eyal, you should probably file a new bug on that since they are in a different menu and would have a slighty different discussion on why or why not they are useful.
Keywords: useless-UI
Depends on: 519921
Attached patch Patch (v1) (obsolete) — Splinter Review
Based on my patch in bug 519921, and the suggestion in comment 2.
Assignee: nobody → ehsan.akhgari
Status: NEW → ASSIGNED
Attachment #403985 - Flags: review?(dao)
Comment on attachment 403985 [details] [diff] [review]
Patch (v1)

I don't see how tooltips solve the a11y issue. Comment 3 makes more sense to me.
Attachment #403985 - Flags: review?(dao) → review-
Depends on: 519927
Attached patch Patch (v2) (obsolete) — Splinter Review
With the new Keyboard Shortcuts Help menu item.
Attachment #403985 - Attachment is obsolete: true
Attachment #403992 - Flags: ui-review?(beltzner)
Attachment #403992 - Flags: review?(dao)
Comment on attachment 403992 [details] [diff] [review]
Patch (v2)

>--- a/browser/base/content/baseMenuOverlay.xul
>+++ b/browser/base/content/baseMenuOverlay.xul
>@@ -86,16 +86,20 @@
>                   key="key_openHelp"/>
> #endif
> # Show IE Users menu item on Windows only
> #ifdef XP_WIN
>         <menuitem label="&helpForIEUsers.label;"
>                   accesskey="&helpForIEUsers.accesskey;"
>                   oncommand="openHelpLink('ieusers');"/>
> #endif
>+        <menuitem id="keyboardShortcuts"
>+                  accesskey="&helpKeyboardShortcuts.accesskey;"
>+                  label="&helpKeyboardShortcuts.label;"
>+                  oncommand="openHelpLink('keyboard-shortcuts')"/>

I'd probably add this above the "For IE Users" item.

>+                     tooltipkey="key_reload"

Is this still worthwhile?
Attachment #403992 - Flags: review?(dao)
Updating to reality: I won't have the time to work on this for the foreseeable future!
Assignee: ehsan.akhgari → nobody
Status: ASSIGNED → NEW
Duplicate of this bug: 580958
Attachment #403992 - Flags: ui-review?(mbeltzner)
appears to be gone now
An opposite bug: bug 737015.
Depends on: 896918
Attached patch patchSplinter Review
Assignee: nobody → dao
Attachment #403992 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #779694 - Flags: review?(mak77)
No longer depends on: 519927
Should we get accessibility review on these changes? may the removal cause any issues to our blind users?
My understanding is that regardless they have other ways to access the same functionality, as well as reach the new shortcuts menuitem in the Help menu.
But may be good to get them in the loop for a confirmation.
Attachment #779694 - Flags: feedback?(marco.zehe)
Comment on attachment 779694 [details] [diff] [review]
patch

As long as we have an up-to-date shortcuts list handy from the help menu, i don't see a problem with removing the menu items. The shortcuts (ctrl+r for reload, escape for stop, both on Windows) are unaffected by this, and they are probably being used way more often than the View menu options. I personally don't remember ever using the View menu for this. ;-) f=me.
Attachment #779694 - Flags: feedback?(marco.zehe) → feedback+
Attachment #779694 - Flags: review?(mak77) → review+
https://hg.mozilla.org/mozilla-central/rev/711c00277568
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
You need to log in before you can comment on or make changes to this bug.