sending to existing AB mail address with trailing space <foo@bar.com > adds another malformed AB entry <"foo"@bar.com>, and sending will fail

RESOLVED DUPLICATE of bug 286760

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 286760
9 years ago
6 years ago

People

(Reporter: j.h.figel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.18; nse) Gecko/20081107 Firefox/2.0.0.18 Flock/1.2.7
Build Identifier: 

REPOSTS ADDRESS IN ADDRESS BOOK WITH QUOTATION MARKS WHEN I SEND A MESSAGE TO
CERTAIN PEOPLE . N0T ALL ADDRESSES DO IT . PROBABLY ONLY ABOUT FIVE.
EXAMPLE SENT FROM ADDRESS BOOK  lu_al_0572@ REPOSTS A NEW ONE IN ADDRESS BOOK BELOW GOOD ONE  " lu_al_0572" 

Reproducible: Sometimes

Steps to Reproduce:
1.JUST USE ADDRESS BOOK TO SEND MESSAGE
2.
3.
Actual Results:  
" lu_al_0572"  POSTED BELOW ORIGINAL ADDRESS IN ADDRESS BOOK 

Expected Results:  
NO CHANGE IN ADDRESS BOOK

NOTHING TO ADD
j.h.figel what version you use?
Can you explain better your problem?
from private email:
>I am not sure what version I am using . I believe it is -US/thunderbird/2.0.0.23
Jim could be a dupe of bug #339594?
from private mail:
>I don't think it is a duplicate of bug #339594 as that removes the quotes , 
>mine reposts the address  with quotes , so now I have two addresses , 
>one with  , and one without ,  in my address book .The original  did not have >quote marks

Thanks for feedback Jim (next time reply directly here on bugzilla) ;-)

Comment 5

6 years ago
This bug is quite well described as Bug 622309.
Grrr. Bad summary, useless steps.
Can somebody provide detailed steps to reproduce? It's really hard to parse comment 0 and the following wfm:

1) have existing ab entry in AB "collected addresses", filled with only email field: foo_bar@asdf.com
2) send another test msg to that address
-> no duplicate entries in AB created

(In reply to Claude Schnéegans from comment #5)
> This bug is quite well described as Bug 622309.

Imo, bug 622309 looks different from this one.

Comment 7

6 years ago
>>Imo, bug 622309 looks different from this one.

IMO it is exactly the same. The only difference is that the submitter did not noticed that extra spaces after the address caused the trouble.
(In reply to Claude Schnéegans from comment #7)
> > Imo, bug 622309 looks different from this one.
> IMO it is exactly the same. The only difference is that the submitter did
> not noticed that extra spaces after the address caused the trouble.

Thanks Claude, excellent analysis.
I have just duped Bug 622309 to bug 286760, so there we go...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286760
Summary: when I send to ; address recopies into address book with quotation marks " lu_al_0572" → sending to existing AB mail address with trailing space <foo@bar.com > adds another malformed AB entry <"foo"@bar.com>, and sending will fail
You need to log in before you can comment on or make changes to this bug.