Closed Bug 513587 Opened 11 years ago Closed 11 years ago

more link on cc line in sent folder works wrong

Categories

(Thunderbird :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 499989

People

(Reporter: rbh00, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.13) Gecko/2009080317 Fedora/3.0.13-1.fc10 Firefox/3.0.13
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4pre) Gecko/20090828 Shredder/3.0b4pre

When msg has been cc'ed to more than 3 email addresses (8 in this case) a 'more' link appears at the cc line's right.  Click on it and the additional 5 email addresses appear correctly on 2 more lines.  But 'more' link now appears at the 'from' line's right.  Clicking the new 'more' link removes the link but doesn't do anything else: 'cc' still shows as 3 lines.  And the frame containing this header information cannot be resized to contain it all:  a scrollbar on the right can't be gotten rid of.

The 'more' link should change to a 'less' link or similar, positioned on the 'cc' line, and clicking on it should restore the 'cc' line to a single line with the first 3 addresses.

Reproducible: Always

Steps to Reproduce:
1. Send an email to one address and cc it to 8 others.
2. Examine the appropriate "Sent" folder.
3. Observe that a 'more' link is at the right end of the 'cc' line.
4. Click on 'more' and observe that
4a. a 'more' link is now on the 'from' line
4b. the 'cc' information is now correctly displayed on 3 lines
5. Click on 'more' at the 'from' line and observe that
5a. the 'more' link disappears
5b. the information otherwise is as it was at 4b. above

Expect a way to revert the 'cc' line to a single line with a 'more' link: perhaps a 'less' link to be displayed in the same place.
Actual Results:  
See 'steps to reproduce' above

Expected Results:  
See 'steps to reproduce' above

Here is the raw email header, with email addresses obfuscated:
From - Sun Aug 30 02:03:36 2009^M 
X-Mozilla-Status: 0001^M 
X-Mozilla-Status2: 00800000^M
X-Mozilla-Keys:       
Message-ID: <4A9A4067.5030708@netcom.com>^M
Date: Sun, 30 Aug 2009 02:03:35 -0700^M
From: My Name <myuserid@netcom.com>^M
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4pre) Gecko/20090828 Shredder/3.0b4pre^M
MIME-Version: 1.0^M
To: recipient1@aol.com^M
CC: cc1@duo-county.com, cc2@cox.net, cc3@sbcglobal.net, ^M
 cc4@aol.com, cc5@cableone.net, cc6@verizon.net, ^M
 cc7@aol.com, cc8@sbcglobal.net^M
Subject: Re: Update on Jane's sister Jody^M
References: <bdd.5841b7f8.37cb4c4f@aol.com>^M
In-Reply-To: <bdd.5841b7f8.37cb4c4f@aol.com>^M
Content-Type: multipart/alternative;^M
 boundary="------------050908030703050303010202"^M
^M
This is a multi-part message in MIME format.^M
--------------050908030703050303010202^M
Content-Type: text/plain; charset=ISO-8859-1; format=flowed^M
Content-Transfer-Encoding: 7bit^M 
^M
Richard could you provide a screen-shot of your issue please ?
Version: unspecified → 3.0
(In reply to comment #1)
> Richard could you provide a screen-shot of your issue please ?

No need to provide one. I should Have read your bug description more carefully.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499989
You need to log in before you can comment on or make changes to this bug.