If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RSS displaying summary when told not to.

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Robert Eden, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Thunderbird/1.0.6 Mnenhy/0.7.3.0

In the RSS settings there is a checkbox that states "Show the article summary instead of loading the web page".  Under Tbird 2, if that box was not checked you got the web page (some feeds don't have good summaries).   Under Tbird 3, you always see the summary.



Reproducible: Always

Steps to Reproduce:
1. Subscribe to a RSS feed and uncheck the "view summary"
2. Downlaod the feed
3. View the feed
Under the View method (when viewing an RSS message), there is a submenu "Feed Message Body as"... which option is selected?
(Reporter)

Comment 2

8 years ago
Interesting, never noticed that option. Yes, that let's me change the view and see the content, but it doesn't appear to be a "per-feed" or "per-folder" setting and I have feeds that go both ways.

Some RSS feeds provide usable summaries, others don't. Web pages take a while to load, so I prefer to read usable summaries.

In TB 2 I controlled what I saw on a per-feed basis via the feed setting.  That doesn't seem to work in TB 3.

What I first started using TB 3 I got lots of errors about RSS feeds being in the wrong format.  I get the impression that TB3 always wants a summary to be there and TB2 just displayed the web page when there wasn't a summary.
If you select default format, the message will be displayed according to the settings stored in the feed preferences. Except when the program forgets. Which I'm currently struggling with.
(Reporter)

Comment 4

8 years ago
Sorry for the delay, I thought I responded already.

That fixed it.  Maybe it should be the default setting?

Unless you want to keep it open to become the default, this can be closed.

Thanks.

Robert
(In reply to comment #4)
> Sorry for the delay, I thought I responded already.
> 
> That fixed it.  Maybe it should be the default setting?
> 
> Unless you want to keep it open to become the default, this can be closed.

Joshua ?

Comment 6

8 years ago
Is there a related bug to this or something?

And I was in a similar situation to Robert: playing around with the subscribe display summary checkbox with no real good result.

I would vote to say that the current set up in 3.0b4 is confusing.  Perhaps the subscription checkbox should be removed?

I'm actually still a little confused about the whole thing.  And what controls what.

Also, perhaps controlling summary vs webpage should be accessible via the new "other actions" button.

Comment 7

8 years ago
To me (in TB 3.0 RC1) the feeds don't shown nothing, with any options (including new option in the View menu). The feed web content or the summary is never showed.
This profile was upgraded from TB 2.0.
In TB 2.0 the feed worked fine.
(In reply to comment #7)
> To me (in TB 3.0 RC1) the feeds don't shown nothing, with any options
> (including new option in the View menu). The feed web content or the summary is
> never showed.
> This profile was upgraded from TB 2.0.
> In TB 2.0 the feed worked fine.

What happen if you rebuild the index ?

Comment 9

8 years ago
> What happen if you rebuild the index ?

The rebuild don't solve the problem, but I changed my default layout from Wide to Classic, and restarted TB and the Web content are showed correctly ! Then if I change the layout back to Wide , the RSS contend disappears immediately !
The problems seems to be related with the wide view.
I tried this steps several times and the behavior is alwways the same.
(In reply to comment #9)
> > What happen if you rebuild the index ?
> 
> The rebuild don't solve the problem, but I changed my default layout from Wide
> to Classic, and restarted TB and the Web content are showed correctly ! Then if
> I change the layout back to Wide , the RSS contend disappears immediately !
> The problems seems to be related with the wide view.
> I tried this steps several times and the behavior is alwways the same.

Can you raise a new bugs for that Fernando please ?
Component: General → Mail Window Front End
QA Contact: general → front-end

Comment 11

8 years ago
Done 
https://bugzilla.mozilla.org/show_bug.cgi?id=531397

Comment 12

8 years ago
OK, in addition to the view problem described above (no detail display in any view other than Classic), I'm also seeing the original bug described by Robert when sticking with Classic View.

In my RSS feed folders, had set up the Feed Properties with "Show the article summary..." unchecked. Feed entries that were posted before my switchover yesterday to TB 3.0 display an HTML page (as it should). Feed entries received after the switchover are just displaying a text summary. This is true for feeds from my web sites as well as from CraigsList and other sites.

Sounds like we have two separate issues going here.

Comment 13

8 years ago
OK, found the submenu item "Feed Message Body as..." and changed it to Default Format (what's the diff. between Default Format & Web Page???). Now viewing RSS feeds as web pages again. 

As I did an upgrade from TB 2.x, this setting should default to Default Format (or Web Page??) and not to Summary.

Comment 14

8 years ago
I think I finally get it... and why I was confused as heck.

The menu Feed Message Body As has three options: Web Page, Summary, Default Format.

The first two really mean "Always Show Web Page" and "Always Show Summary". The latter means "Use the option selected for the feed on a feed by feed basis".

I assumed, until I found this bug that the check box on the feed properties to "show summary instead of loading web page" would work when the Web Page format was selected. (Based on the text present in the menu's and the option itself I do not think this is an unreasonable assumption.)

Changing the menu item labels should suffice. I would recommend something like: Always load Web Page, Always show Summary, Allow Each Feed to Decide

(Don't really like the last one but the first two I think are critical changes.)

I would also point out the comment made by Joe Sabash on 2009-08-29 at 12:17:36 PDT on Bug 509913 as further possible evidence that other people are confused by the labels involved in this setting.
(Reporter)

Comment 15

8 years ago
How about "Always Show Web Page", "Always Show Summary" and "Use each Feed's Setting".

The Latter should be the default at least when upgrading from TB2. (I don't think it is... or at least wasn't)

In addition if an "Always" option is chosen the setting on the feed properties should be grayed out.
Bryan, this sounds like something we should be trying to improve in 3.1...
Flags: blocking-thunderbird3.1?
Duplicate of this bug: 533630
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 531560

Comment 19

8 years ago
> The Latter should be the default at least when upgrading from TB2. (I don't
> think it is... or at least wasn't)

I also upgraded from TB2 and since all my feeds were now showing the summary instead of the web page. I realized...

1. That was great for some feeds
2. Not great for ones that had empty summaries.

Thus leading me to try and figure out the permutations and being VERY confused.

I would also vote that upgrading from TB2 should default the setting to "Default". Whatever the new name is... OR at the very least, if possible, ask.

Comment 20

8 years ago
(In reply to comment #19)
> > The Latter should be the default at least when upgrading from TB2. (I don't
> > think it is... or at least wasn't)
> 
> I also upgraded from TB2 and since all my feeds were now showing the summary
> instead of the web page. I realized...
> 
> 1. That was great for some feeds
> 2. Not great for ones that had empty summaries.
> 
> Thus leading me to try and figure out the permutations and being VERY confused.
> 
> I would also vote that upgrading from TB2 should default the setting to
> "Default". Whatever the new name is... OR at the very least, if possible, ask.

please see Bug 491399 for some commentary.  note the issue of pre Tb2 downloaded feeds with Show Summary not checked - there won't ever be a summary to show; there used to be a warning dialog but it was deemed annoying and removed.

yes, the problem was/is that there are wide differences in content quality published in the summary.  in many cases, the summary is completely sufficient and does not require showing the web page.  in other cases, the summary is useless.

the goal was to allow quickly scanning summaries (if the individual feed was set to show summary, or the global override menuitem were set for summary) since this is much faster loading than a web page, and to use <enter> or double click to then toggle between summary and web page.  the handling, for feeds, of <enter> or double click is determined by the Message -> Open Feed Message option.

Comment 21

8 years ago
> > I would also vote that upgrading from TB2 should default the setting to
> > "Default". Whatever the new name is...

> please see Bug 491399 for some commentary.  note the issue of pre Tb2
> downloaded feeds with Show Summary not checked - there won't ever be a summary
> to show; there used to be a warning dialog but it was deemed annoying and
> removed.

To put it another way... my TB2 always showed Web Pages. When I upgraded to TB3 that behavior suddenly changed to show Summaries.

As far as I know was in a basically stock setup so if TB2 always showed Web Pages by default, then an upgraded profiles in TB3 should also show Web Pages by default.

Conversely if I manually changed it to Web Pages (and don't remember doing it) then that setting should be honored and kept at Web Pages. Either way, my profile should have ended up set to Web Pages.

Comment 22

8 years ago
perhaps the stock setting should have been Default.  but then people wouldn't necessarily ever discover the new features of toggling summary/web page and the global override, neither of which were possible before.  Tb3, for example, has removed toolbar icons and requires users to put them back, so this is neither a big deal nor unprecedented.  at least now you're educated about some rss features.

closing, as the original report is not a bug but a documentation item.  changing the stock setting is a new bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Flags: blocking-thunderbird3.1?
You need to log in before you can comment on or make changes to this bug.