Last Comment Bug 514630 - cannot bookmark pages using drag&drop
: cannot bookmark pages using drag&drop
Status: RESOLVED FIXED
: fixed-seamonkey2.0
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: seamonkey2.0
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
: 518640 521226 (view as bug list)
Depends on:
Blocks: 342296
  Show dependency treegraph
 
Reported: 2009-09-04 01:55 PDT by Rolf Bode-Meyer
Modified: 2010-07-27 20:32 PDT (History)
10 users (show)
kairo: blocking‑seamonkey2.0+
kairo: blocking‑seamonkey2.0b2-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Detect insertions (1.41 KB, patch)
2009-09-04 09:29 PDT, neil@parkwaycc.co.uk
iann_bugzilla: review+
Details | Diff | Splinter Review
Emulate old behaviour [Checkin: See comment 12] (1.16 KB, patch)
2009-09-04 09:33 PDT, neil@parkwaycc.co.uk
iann_bugzilla: review+
Details | Diff | Splinter Review

Description Rolf Bode-Meyer 2009-09-04 01:55:02 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2pre

In nightly 20090831 it worked, in 20090903 it doesn't anymore.


Reproducible: Always

Steps to Reproduce:
1. Load a page.
2. Drag its icon in the address bar into the personal toolbar or the bookmark manager window.
Actual Results:  
During drag I get an insertion cursor but after drop nothing happens.

Expected Results:  
Bookmark for site should get inserted into bookmark list.
Comment 1 Philip Chee 2009-09-04 08:48:06 PDT
Error: Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFContainer.Init]
Source file: chrome://communicator/content/bookmarks/bookmarks.js
Line: 1393

I think this is a regression caused by Bug 342296
Comment 2 neil@parkwaycc.co.uk 2009-09-04 09:29:07 PDT
Created attachment 398687 [details] [diff] [review]
Detect insertions

This just checks that the whole selection is movable, and if not, inserts it.
Comment 3 neil@parkwaycc.co.uk 2009-09-04 09:33:40 PDT
Created attachment 398689 [details] [diff] [review]
Emulate old behaviour
[Checkin: See comment 12]

The old behaviour was to try and delete as much of the selection as possible.

Thus the effect was to move where possible, and insert otherwise.
Comment 4 Ian Neal 2009-09-04 15:43:59 PDT
Comment on attachment 398689 [details] [diff] [review]
Emulate old behaviour
[Checkin: See comment 12]

Could you stick a var before the i in line 1240 whilst you're at it?
Comment 5 Rolf Bode-Meyer 2009-09-05 07:32:56 PDT
Requesting blocker for b2, this is a really annoying bug.
Comment 6 Robert Kaiser 2009-09-05 07:36:35 PDT
Not blocking a beta on this, bookmarks still can be added via the menus. Blocking final sounds reasonable though, marking that.
Comment 7 Dave Buco 2009-09-05 08:10:20 PDT
Don't know if this is related, but using the menu bar > bookmarks > bookmark this page, and/or right click page > bookmark this page does not work correctly. No options are given as to where to place the bookmark. It is placed generically and not in personal toolbar as previously.  It can only be found by clicking menu bar > bookmarks dropdown. 

See image here: http://i27.tinypic.com/2whgspx.jpg
Comment 8 Dave Buco 2009-09-05 08:12:01 PDT
Ooops. forgot build ID for above..

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4pre) Gecko/20090905 SeaMonkey/2.0pre - Build ID: 20090905005746
Comment 9 Robert Kaiser 2009-09-05 08:55:33 PDT
(In reply to comment #7)
> Don't know if this is related, but using the menu bar > bookmarks > bookmark
> this page, and/or right click page > bookmark this page does not work
> correctly. No options are given as to where to place the bookmark. It is placed
> generically and not in personal toolbar as previously.  It can only be found by
> clicking menu bar > bookmarks dropdown.

That's intended functionality. Only drag&drop or "File Bookmark..." can place items in the personal toolbar.
Comment 10 Dave Buco 2009-09-05 09:08:19 PDT
OK. Thanks for the clarification, Robert.
Comment 11 neil@parkwaycc.co.uk 2009-09-05 09:20:21 PDT
(In reply to comment #7)
> No options are given as to where to place the bookmark.
Open the Bookmarks Manager, then choose the desired folder and select
View - Set as New Bookmark Folder.
Comment 12 neil@parkwaycc.co.uk 2009-09-05 09:23:54 PDT
Pushed changeset 5cd46484def2 to comm-central.
Comment 13 Robert Kaiser 2009-09-24 14:33:15 PDT
*** Bug 518640 has been marked as a duplicate of this bug. ***
Comment 14 roman toledo 2009-10-05 13:00:50 PDT
I still have this problem in Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2

I do not see a plain 2.0 for download that says it's fixed. so I'm confused where is 2.0  not the beta version that has this problem fixed?
Comment 15 Robert Kaiser 2009-10-05 13:06:02 PDT
roman, it's fixed in current nightly versions that are on the way to 2.0 final, and so it will be fixed in the real 2.0 when it actually appears.
Comment 16 Robert Kaiser 2009-10-08 09:34:34 PDT
*** Bug 521226 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.