Provide an options menu preference for toggling the tab opening behavior

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: u88484, Unassigned)

Tracking

({uiwanted})

Trunk
x86
Windows Vista
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-IE])

(Reporter)

Description

8 years ago
The options menu should provided a preference for users to toggle the new tab opening behavior.  The new behavior is a drastic change from the tab opening behavior that has been in Firefox since probably the beginning.  A real discussion of this was not really talked about in the bug implementing this change.

The exposed preference to toggle this behavior in the options menu would compliment the existing preferences located here to alter the default tab behavior and in turn allowing the users more customization of their tabs.  With such a major change to the behavior of tabs, an easy way to revert back to the "old way" would be the best thing to do here instead of a hidden preference.

I do not like adding preferences to the UI as much as the next guy but how about doing this for at least the 3.6 release so that existing users can easily customize the tab opening behavior to their liking.  After 3.6 is release we can remove this from the UI since existing users would have already toggled this to their liking and new users will have started out with this behavior and would be less susceptible to changing this behavior.  Please don't WONTFIX this bug due to the previous suggestion alone.

FWIW, IE7 and 8 provide a option to do this in their options menu.
Flags: wanted-firefox3.6?
(Reporter)

Updated

8 years ago
Whiteboard: [parity-IE]
We have been clear that we don't think this needs a UI pref (nor did other significant changes, like selecting the "parent tab" in specific cases, or closebutton usage).  Given that we've wontfixed the UI portion of this before, and we explicitly pulled the UI from the patch, this isn't something we're going to do at this point.  We may reconsider based on future feedback, but this is WONTFIX at this time.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Comment 2

8 years ago
What kind of feedback would be needed to rethink this?
We know that user threatening with dropping firefox has no effect.
We all remember the "classic theme" drop poll and how that ended.
In the end, we also know this is not going anywhere, so can we at least get a relnote on this issue?
I'm not against improving UI, as long as it doesn't break what users are used to.
To me UI is like furniture at a blink man's house, it doesn't move, ever. It's not shiny or sparkly, it's just there to be used, as simple as that.
I'm not trying to rant here, just want you to see my point, and get real info on what can be done?
Thanks.
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> What kind of feedback would be needed to rethink this?
A lot of duplicate bugs, forums posts on SUMO and a high percentage of articles read on SUMO to be about this change.
> so can we at least get a relnote on this issue?
There will be relnotes and user-doc documentation on this feature

Comment 4

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > What kind of feedback would be needed to rethink this?
> A lot of duplicate bugs, forums posts on SUMO and a high percentage of articles
> read on SUMO to be about this change.
But that's only possible after the release, so no way for 3.6, right?
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > What kind of feedback would be needed to rethink this?
> > A lot of duplicate bugs, forums posts on SUMO and a high percentage of articles
> > read on SUMO to be about this change.
> But that's only possible after the release
Yep or during a beta when the release with this fix will be more widely used.

> so no way for 3.6, right?
Doesn't sound like it until and if this is found to be a common issue.

Updated

8 years ago
Duplicate of this bug: 536019
Shouldn't that be a dupe of bug 262459?

Updated

7 years ago
Duplicate of this bug: 547339
Flags: wanted-firefox3.6?
Duplicate of this bug: 554706
Duplicate of this bug: 554690

Comment 11

7 years ago
If there is not going to be any option to restore previous tab ordering
functionality via the UI, I demand that the original tab ordering functionality
be restored.

1. Have several pages open.
2. On first page, right click on link and open up in new tab.
3. On second page, right click on another link and open in new tab.
4. Do this once for each page originally open.
5. Tabs are not in order via the way they are opened.

Tab ordering is lost.

Comment 12

7 years ago
It's a shame this is WONTFIX.
I reverted the behavior by setting browser.tabs.insertRelatedAfterCurrent to false in about:config.

Comment 13

7 years ago
It is more than a shame.  I am curious how much was donated to get this implemented, and to not allow previous tab ordering to be available.  Isn't the idea behind good software to expand functionality while increasing intuitiveness?  This hinders both.

Updated

7 years ago
Duplicate of this bug: 569276
You need to log in before you can comment on or make changes to this bug.