Cannot disable Shredder start page, regardless of setting

VERIFIED FIXED in Thunderbird 3.0b4

Status

Thunderbird
Preferences
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: IU, Assigned: standard8)

Tracking

({regression})

Trunk
Thunderbird 3.0b4
regression
Bug Flags:
blocking-thunderbird3 +
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090905 Lightning/1.0pre

No longer able to disable the Shredder start page, regardless of the setting in Options

Regression:
Works: Gecko/20090904
Broken: Gecko/20090905


Reproducible: Always

Steps to Reproduce:
1. Go to Tools --> Options... --> General
2. Uncheck "Shredder Start Page"
3. Restart Shredder
4. Notice that the start page remains.  The region should be blank.

Actual Results:  
Start page persists

Expected Results:  
Region should be blank
(Reporter)

Updated

9 years ago
Blocks: 499306
Keywords: regression
Version: unspecified → Trunk
(Assignee)

Updated

9 years ago
Blocks: 504986
No longer blocks: 499306

Comment 1

9 years ago
Confirmed, the start page is shown regardless of mailnews.start_page.enabled being false [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090905 Shredder/3.0b4pre].
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

9 years ago
Assignee: nobody → bugzilla
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Target Milestone: --- → Thunderbird 3.0b4
(Assignee)

Updated

9 years ago
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 2

9 years ago
Created attachment 398868 [details] [diff] [review]
Proposed fix

I've done some digging and we are missing the option to check the preference. What we used to do is:

- Not show the start page if the enable preference is set to false.
- Show the start page if the user manually goes to Go -> Mail Start Page (whatever the state of the preference).
- If showing the start page, then we would show it once for each nsIMsgIncomingServer (so each mail server).

This patch does the following:

- Not show the start page if the enable preference is false.
- Disable Go -> Mail Start page if the preference is false.
- Disable the options to set the start page if the preference is false.
- Disables the Go -> Mail Start page option for non-folder pane tabs (e.g. message & gloda search).
- If the preference is true, we'll show the start page every time you click on a folder and nothing is automatically selected.

The last of these is possibly the most significant difference overall once we switch between the two, however when bug 505044 lands this will reduce the amount we actually show it, so I don't think that would be an issue.

The disabling of the mail start page follows what SeaMonkey does. We can in theory make Go -> Mail Start Page work whilst not enabling the preference but it does seem a little strange.

Anyway, asking for ui-review to see what Bryan thinks.
Attachment #398868 - Flags: ui-review?(clarkbw)
(Assignee)

Updated

9 years ago
Whiteboard: [needs review clarkbw]
Comment on attachment 398868 [details] [diff] [review]
Proposed fix

(In reply to comment #2)
> The disabling of the mail start page follows what SeaMonkey does. We can in
> theory make Go -> Mail Start Page work whilst not enabling the preference but
> it does seem a little strange.

This is the only part that I'm unsure about.  I guess it also brings in uncertainty with the idea of disabling the start page entry when the pref is disabled.

That system strikes me as a bit strict for the sake of being strict and not directly for the users benefit.

ui-r+ because I think we want this fix in and can work out this last part over time.
Attachment #398868 - Flags: ui-review?(clarkbw) → ui-review+
(Assignee)

Updated

9 years ago
Attachment #398868 - Flags: review?(mkmelin+mozilla)

Comment 4

9 years ago
Comment on attachment 398868 [details] [diff] [review]
Proposed fix

Yeah i agree it should be possible to load the start page by Go | Mail Start Page even if you don't have it enabled on startup

>+    document.getElementById("restoreDefaultStartPageButton").disabled = disabled;    

Trailing spaces.

More importantly though, this broke the Restore Default button

Error: startPage is not defined
Source File: chrome://messenger/content/preferences/general.js
Line: 35
Attachment #398868 - Flags: review?(mkmelin+mozilla) → review-

Updated

9 years ago
Whiteboard: [needs review clarkbw] → [needs new patch]
(Assignee)

Comment 5

9 years ago
Created attachment 400007 [details] [diff] [review]
Simpler Fix

Simpler fix, I think this gets us back to where we where before - even if the enable option is disabled in prefs, then we'll load up the url if the user goes to Go -> Start Mail Page.

I've also kept the change so that we only enable the Go -> Mail Start Page menu option on folder panes (e.g. message tabs etc don't want it).

Switching review to bienvenu as I think mkmelin said he was busy until the weekend and I'd like to fix this regression for b4.
Attachment #398868 - Attachment is obsolete: true
Attachment #400007 - Flags: ui-review?(clarkbw)
Attachment #400007 - Flags: review?(bienvenu)

Updated

9 years ago
Attachment #400007 - Flags: review?(bienvenu) → review+
Attachment #400007 - Flags: ui-review?(clarkbw) → ui-review+

Updated

9 years ago
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Keywords: checkin-needed
Whiteboard: [needs new patch] → [no l10n impact][ready for checkin]
(Assignee)

Comment 6

9 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/6033678956c1
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [no l10n impact][ready for checkin] → [no l10n impact]
(Reporter)

Comment 7

9 years ago
Verified:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090912 Lightning/1.0pre ID:20090912032112

Thanks
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.