Closed Bug 515095 Opened 12 years ago Closed 5 years ago

Enable ctrl-tab panel by default

Categories

(Firefox :: Tabbed Browser, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 565568
Tracking Status
blocking2.0 --- -

People

(Reporter: tim, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090902 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090902 Minefield/3.7a1pre (.NET CLR 3.5.30729)

A few weeks ago in the trunk builds of Firefox, Firefox had this very, VERY neat feature that I loved. In fact, I can't work without it :P

The new tabbed switcher was great on Windows and Linux, never did it ever not work. You see, it was really great that when pressing CTRL+Tab that you could see nine of your open windows, all presented in the format of the last used tab. And this was without any extensions!

But then one sad day, this beautiful feature in Firefox died. It got removed from both the Windows and Linux builds. I mean, sure, even though it did work better on Windows (transparent... mmmmm!) seeing the open windows, and being able to switch between them all without needing any extensions was a plus.

Please, please PLEASE! Bring back the new (or is that old - after it got removed) way to switch tabs by using CTRL+Tab. I really loved this feature; and now that I have used it, I really want it back!

Reproducible: Always
It's currently behind a hidden pref (browser.ctrlTab.previews) and disabled by default. The same applies to browser.allTabs.previews.
think this is INVALID, as it is not a bug, simply trying to set the pref.
Summary: Bring back the new tabbed window switcher in Firefox 3.5pre! → Bring back the new tabbed window switcher in Firefox 3.7
Version: unspecified → Trunk
At the moment it is available again in nightly builds of the upcoming Firefox 3.6. It's a dupe of bug 465076.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Summary: Bring back the new tabbed window switcher in Firefox 3.7 → Bring back the new tabbed window switcher in Firefox
Duplicate of bug: 465076
This is the result of bug 465076, not a duplicate.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
So do we wanna use this bug for re-enabling the pref per default at some time in the future or wontfix for now?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
This bug can just track the future of these prefs, yeah. "wontfix for now" wouldn't make a lot of sense.
Depends on: ctrl-tab-panel
Summary: Bring back the new tabbed window switcher in Firefox → Enable ctrl-tab/all-tabs panel per default in Firefox
These prefs might make more sense and easier to find if they were browser.previews.alltabs and browser.previews.ctrltabs, since previews are more abundant, including Vista taskbar previews and soon win7 multi-tab taskbar previews.
Blocks: 538812
Summary: Enable ctrl-tab/all-tabs panel per default in Firefox → Enable ctrl-tab panel by default
Severity: minor → enhancement
Blocks: 565568
No longer blocks: 538812
blocking2.0: --- → ?
Control-Tab isn't wanted for Fx4, if anything it should be removed. Definately not blocking.
blocking2.0: ? → -
I had a little talk about this in #ux. Both Boriss and shorlander weren't really against considering this to be enabled. As a long time user of this feature, together with browser.allTabs.previews, I'll list why I think this should be default (and would be a killer feature!).

The big win browser.ctrlTab.previews offers, is the switch to "Most recently used tab" instead of switching left/right. The tab preview is cool eyecandy on top of that, which is an extra plus for sure. So, my reasons for that:

- The current working set of a user consists mostly of just a few tabs (while he can have a lot of others in the tab bar). He will be using mostly these tabs, so having ctrl-tab going to the most recently used tab makes a lot of sense.

- Maybe one of those tabs is somewhere at the other side of the tab bar. It's the case with me, mostly. My current working set is somewhere on the right of my tab bar, while my Facebook tab is my first app tab. Using the keyboard, I would have to scroll through all my tabs to get there. Moreover, since Firefox 13 introduced "Don't load tabs until selected", a lot of them might be unloaded, so this would make them all load and might halt the browser for a while.

- Going to the most recently used tab is consistent with the behaviour of alt-tab in Windows, which switches between the most recently used applications. Afaik it's the same for most window managers in Linux and also cmd-tab in OS X behaves that way.

- You don't actually lose the ability to switch left/right, as ctrl+page-up/down does the same thing.


About browser.allTabs.previews (which isn't related to this bug, but anyway...), I can be short:

- It's doesn't get in the way of anyone who doesn't want to use it, as it's just an extra feature

- It has a search box, which is very useful. Panorama has this too, but I think it's rather slow and messy when you just want to search through your current tabs.


A reconsideration of this would be awesome :)
No longer blocks: 565568
Status: NEW → RESOLVED
Closed: 12 years ago5 years ago
No longer depends on: ctrl-tab-panel
Resolution: --- → DUPLICATE
Duplicate of bug: 565568
You need to log in before you can comment on or make changes to this bug.