[faceted search]: lots of "Cannot specify value for internal property. Error in parsing value for '-x-system-font'" warnings

RESOLVED WORKSFORME

Status

Thunderbird
Search
--
trivial
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: tessarakt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.2) Gecko/20090729 Firefox/3.5b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090910 Lightning/1.0pre Shredder/3.0b4pre

When using gloda facet, the following warning is repeated very often in the error console:

Warning: Cannot specify value for internal property.  Error in parsing value for '-x-system-font'.  Declaration dropped.
Source File: chrome://messenger/content/glodaFacetView.xhtml


It's a bit annoying ...

Reproducible: Always
We might just be stuck with it, on 1.9.1. The problem comes from 1.9.1 not having whichever of bug 475214 or bug 478156 fixed our particular problem, together with the way that SVG has its style parsed, serialized, then parsed again:

<bz> philor: Oh, SVG
<bz> philor: one sec
<bz> philor: I thought I filed a bug on this, but clearly no...
<bz> maybe I decided it wasn't worth dealing with
<bz> in SVG, all style attributes are parsed, then serialized, then parsed again
<bz> so any serialization bugs will bite you automatically
• hsivonen wonders why style attributes are parsed twice in SVG
<philor> ah, so it's unescapable (other than an escape to 1.9.2)
<bz> hsivonen: once on SetAttr, once on BindToTree
<bz> hsivonen: 'cause the base URI might have changed, see
<hsivonen> bz: doesn't the base URI change issue affect (X)HTML with xml:base set, too?
<bz> yes
<bz> but HTML parses the style attr lazily, iirc
<bz> or something

So protovis lets you pass in a font declaration, or defaults to "10px sans-serif", and lets you pass in a text-shadow declaration, and does a setAttribute("style", style) from what you passed in, that then gets (poorly) serialized, and reparsed in BindToTree. We could fix it by rewriting protovis to take a classname instead of the actual style rules, but I doubt that's really something we want to do.
Summary: [faceted search]: glodaFacetView.xhtml causes lots of warnings in error console → [faceted search]: lots of "Cannot specify value for internal property. Error in parsing value for '-x-system-font'" warnings
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Duplicate of this bug: 516162
Component: Mail Window Front End → Search
QA Contact: front-end → search
(Reporter)

Comment 3

8 years ago
Apparently fixed in 3.1 RC1.
Indeed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.