Last Comment Bug 516398 - No Lightning pref UI in SeaMonkey
: No Lightning pref UI in SeaMonkey
Status: RESOLVED FIXED
: fixed-seamonkey2.0, relnote
Product: Calendar
Classification: Client Software
Component: Lightning: SeaMonkey Integration (show other bugs)
: Trunk
: All All
-- normal (vote)
: 1.0b1
Assigned To: neil@parkwaycc.co.uk
:
:
Mentors:
: 516883 (view as bug list)
Depends on: 516453
Blocks: 517705 517700 517722
  Show dependency treegraph
 
Reported: 2009-09-14 06:39 PDT by Robert Kaiser
Modified: 2011-11-07 02:39 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
WIP (4.25 KB, application/vnd.mozilla.xul+xml)
2009-09-16 05:20 PDT, neil@parkwaycc.co.uk
no flags Details
diff -w (12.93 KB, patch)
2009-09-16 08:48 PDT, neil@parkwaycc.co.uk
mschroeder: review+
iann_bugzilla: review+
Details | Diff | Splinter Review
Fixed position of Lightning category (24.04 KB, patch)
2009-09-19 12:08 PDT, neil@parkwaycc.co.uk
no flags Details | Diff | Splinter Review
Fixed indentation (23.85 KB, patch)
2009-09-19 13:16 PDT, neil@parkwaycc.co.uk
iann_bugzilla: review+
Details | Diff | Splinter Review

Description User image Robert Kaiser 2009-09-14 06:39:06 PDT
When installing Lightning into SeaMonkey, there's no way to get to preferences UI as Lightning hooks into Thunderbird-specific UI for this.
Comment 1 User image Philip Chee 2009-09-14 08:05:51 PDT
I have a WIP patch for this.
Comment 2 User image neil@parkwaycc.co.uk 2009-09-16 05:20:54 PDT
Created attachment 400995 [details]
WIP
Comment 3 User image Robert Kaiser 2009-09-16 05:27:27 PDT
*** Bug 516883 has been marked as a duplicate of this bug. ***
Comment 4 User image neil@parkwaycc.co.uk 2009-09-16 08:48:50 PDT
Created attachment 401035 [details] [diff] [review]
diff -w
Comment 5 User image Martin Schröder [:mschroeder] 2009-09-19 09:05:19 PDT
Comment on attachment 401035 [details] [diff] [review]
diff -w

>diff -Npruw comm.d45144dc165c/calendar/base/content/preferences/timezones.xul comm/calendar/base/content/preferences/timezones.xul
>--- comm.d45144dc165c/calendar/base/content/preferences/timezones.xul	2009-09-16 15:27:02.000000000 +0100
>+++ comm/calendar/base/content/preferences/timezones.xul	2009-09-16 15:27:02.000000000 +0100
>@@ -58,14 +58,14 @@
>                         type="string"/>
>         </preferences>
> 
>+        <groupbox>
>         <caption label="&pref.calendar.timezones.list.caption;"/>
> 
>         <menulist id="calendar-timezone-menulist"
>                   preference="calendar-timezone-local">
>             <menupopup id="calendar-timezone-menupopup"/>
>         </menulist>
>-
>-        <separator/>
>+        </groupbox>
> 
>     </vbox>
> </overlay>

I'm not sure this is needed but okay. Obviously, it is needed for SeaMonkey because you merge the content of general and timezone preference panes. ;-)


>diff -Npruw comm.d45144dc165c/calendar/lightning/content/communicator-overlay-preferences.xul comm/calendar/lightning/content/communicator-overlay-preferences.xul
>--- comm.d45144dc165c/calendar/lightning/content/communicator-overlay-preferences.xul	1970-01-01 01:00:00.000000000 +0100
>+++ comm/calendar/lightning/content/communicator-overlay-preferences.xul	2009-09-16 15:27:02.000000000 +0100
[...]
>+    <treechildren id="prefsPanelChildren">
>+        <treeitem container="true"
>+                            id="lightning"
>+                            label="&lightning.taskLabel;"
>+                            prefpane="paneLightning">

The indentation of the attributes seems to be off here and everywhere in this file. The original (messenger-overlay-preferences.xul) has them aligned correctly. Please, fix this before checkin.


r=mschroeder, but please get additional review for the SeaMonkey overlay from someone who knows SeaMonkey better than me.
Comment 6 User image Ian Neal 2009-09-19 09:10:19 PDT
With this patch the Lightning Prefs are the last entry, it probably needs:
insertafter="editor,mailnews,navigator"
adding to the the first treeitem in the overlay.
Comment 7 User image Ian Neal 2009-09-19 09:17:05 PDT
(In reply to comment #6)
> With this patch the Lightning Prefs are the last entry, it probably needs:
> insertafter="editor,mailnews,navigator"
> adding to the the first treeitem in the overlay.

Okay, that shifts it above Debug but still below Privacy & Security and Advanced, so needs something more than that.
The "Alarms" and "Views" pref panels go off the edge of the Preferences window.
Comment 8 User image neil@parkwaycc.co.uk 2009-09-19 10:24:26 PDT
(In reply to comment #5)
>(From update of attachment 401035 [details] [diff] [review])
>>diff -Npruw
>The indentation of the attributes seems to be off here
That would be due to the -w diff ;-)

(In reply to comment #7)
>(In reply to comment #6)
>>With this patch the Lightning Prefs are the last entry, it probably needs:
>>insertafter="editor,mailnews,navigator"
>>adding to the the first treeitem in the overlay.
Where would you like it to be?

>The "Alarms" and "Views" pref panels go off the edge of the Preferences window.
With those fixes they didn't for me on Windows. I'm not sure what's best here.
Comment 9 User image Robert Kaiser 2009-09-19 10:26:48 PDT
(In reply to comment #8)
> >The "Alarms" and "Views" pref panels go off the edge of the Preferences window.
> With those fixes they didn't for me on Windows. I'm not sure what's best here.

I think we should get it in as it is for now and look at those in a followup.
Comment 10 User image Ian Neal 2009-09-19 11:59:13 PDT
(In reply to comment #8)
> (In reply to comment #7)
> >(In reply to comment #6)
> >>With this patch the Lightning Prefs are the last entry, it probably needs:
> >>insertafter="editor,mailnews,navigator"
> >>adding to the the first treeitem in the overlay.
> Where would you like it to be?
I would say before Privacy & Security - sorted with deleting/editing localstore.rdf
> 
> >The "Alarms" and "Views" pref panels go off the edge of the Preferences window.
> With those fixes they didn't for me on Windows. I'm not sure what's best here.
They definitely are off the edge on Linux. Follow-up bug 517705
Comment 11 User image Ian Neal 2009-09-19 12:01:12 PDT
Comment on attachment 401035 [details] [diff] [review]
diff -w

r=me for SM with position of lightning preference category before privacy & security and advanced
Comment 12 User image neil@parkwaycc.co.uk 2009-09-19 12:08:49 PDT
Created attachment 401650 [details] [diff] [review]
Fixed position of Lightning category
Comment 13 User image Martin Schröder [:mschroeder] 2009-09-19 12:26:21 PDT
(In reply to comment #12)
> Created an attachment (id=401650) [details]
> Fixed position of Lightning category

communicator-overlay-preferences.xul still seems to have wrong indentation, also without -w option (which doesn't influence new files afaik).
Comment 14 User image neil@parkwaycc.co.uk 2009-09-19 13:16:07 PDT
Created attachment 401657 [details] [diff] [review]
Fixed indentation

Sorry for the misunderstanding.
Comment 15 User image Ian Neal 2009-09-19 13:54:51 PDT
Comment on attachment 401657 [details] [diff] [review]
Fixed indentation

Chatzilla will need be fixed too, but that would have to be in another bug.
Comment 16 User image Ian Neal 2009-09-19 14:14:46 PDT
(In reply to comment #14)
> Created an attachment (id=401657) [details]
> Fixed indentation
> 
> Sorry for the misunderstanding.
a-SM2.0=me for SM part of patch. There is a blank line at the end of the prefs overlay you could get rid of too.
Comment 17 User image neil@parkwaycc.co.uk 2009-09-19 15:51:24 PDT
(In reply to comment #15)
> (From update of attachment 401657 [details] [diff] [review])
> Chatzilla will need be fixed too, but that would have to be in another bug.
Chatzilla was using editor,mailnews,navigator which was wrong anyway :-(
Comment 18 User image neil@parkwaycc.co.uk 2009-09-19 15:56:49 PDT
Pushed changeset 7d8e4a617bb4 to comm-central.
Comment 19 User image Philipp Kewisch [:Fallen] 2011-11-07 02:39:08 PST
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".

Note You need to log in before you can comment on or make changes to this bug.