If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Keyboard shortcuts don't work in Eudora 8.0b7

RESOLVED FIXED

Status

Penelope
Mail Window
P1
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Cy Cantrell, Assigned: Jeff Beckley)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090903 Eudora/3.0b3

System: MacBook Pro 17", Mac OS 10.5.8
Problem: Keyboard shortcuts don't work in Eudora 8.0b7
Description: The keyboard shortcuts for delete, copy and paste don't work in 8.0b7. The corresponding menu items still work.

Reproducible: Always

Steps to Reproduce:
1.Launch Eudora 8.0b7.
2.Open a window to compose a message.
3.Attempt to copy text previously pasted from another message, or another application using the usual Mac keyboard shortcut (Command-v).
Actual Results:  
Copy, paste and delete keyboard shortcuts don't work.

Expected Results:  
Copy, paste and delete keyboard shortcuts have worked in every previous version of Eudora for Mac.

Updated

8 years ago
Duplicate of this bug: 515050

Comment 2

8 years ago
Additionally, see https://bugzilla.mozilla.org/show_bug.cgi?id=515050 which contains information about arrow keys not working in compose windows.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

8 years ago
Assignee: mozilla-bugs → beckley

Comment 3

8 years ago
similarly, in eudora 8.0b7 the 'pg-up' and 'pg-down' keys dont seem to work while they did in 8.0b6

Comment 4

8 years ago
pg-up pg-down was on vista box not mac doh
(Assignee)

Comment 5

8 years ago
For those with initiative, this bug is fixed in the Penelope hg source code
depot: <http://hg.mozilla.org/penelope/rev/05812a9a095a>.

Otherwise you'll have to wait until the next release, Eudora 8 beta 8/Penelope
0.5a5.
Severity: normal → major
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Priority: -- → P1
Hardware: Other → All
Resolution: --- → FIXED
Target Milestone: --- → 0.5
Version: unspecified → 0.5
(Assignee)

Updated

8 years ago
Duplicate of this bug: 519000

Comment 7

8 years ago
I'd like to see if this works -- I don't see how the changes in 05812a9a095a could make "Command-D" work, when 8.0b7 already had:
  key_penelopeDelete=meta][D][

In 8.0b7, pressing "Command-D" makes the Message menu highlight/unhighlight, but does not delete the message (this is in a 2-pane view, with the message to be deleted selected in the open "Inbox" window).  The actual Message->Delete menu selection does work.

How do I "enable" the penelope extension (0.5a5) with Thunderbird 3.1a1pre ?  It (Shredder) says Penelope's not compatible and disables it.  I installed the Compatibility Reporter which -- according to documentation -- is _supposed_ to allow you to enable/use "incompatible" extensions -- but it doesn't (or I haven't figured out how to do it).

Is making Penelope "compatible" a simple matter of changing the "minVersion"/"maxVersion" strings in 'install.rdf' ?   How are the "min" and "max" compared to the actual ?  'install.rdf' for Penelope 0.5a5 has a "min" of '3.0b4' and a "max" of '3.0'; a strict lexicographical comparison would say that '3.0b4' is "greater than" '3.0'....

Should Penelope 0.5a5 _work_ with TBird 3.1a1pre ?

Updated

8 years ago
Target Milestone: 0.5 → ---
You need to log in before you can comment on or make changes to this bug.