Closed Bug 516860 Opened 11 years ago Closed 11 years ago

Using stars for NEW messages and starred messages is confusing.

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: mlissner+bugzilla, Assigned: andreasn)

Details

(Whiteboard: [no l10n impact])

Attachments

(6 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4pre) Gecko/20090913 Ubuntu/9.04 (jaunty) Firefox/3.5.2
Build Identifier: 3.0b4pre

In the area where messages are displayed, it's possible to move columns around, and to star messages.

It's confusing to use stars for so many things. Look at my screenshot for an example of what happens if the starred message column is placed next to the subject column.

While that's not good, even when it's in the default location, it's pretty confusing.

Reproducible: Always
Lots and lots of blurriness, but the point is clear if you take note of the stars.
So I've placed the subject column next to the star one. But I don't reproduce your issue. This WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090930 Shredder/3.0pre.

Michael can you try to find out how you ended up in this situation and then comment here with something like :

1) did ....
2) did yyyy

oups stars are now confused.
Here's another demo, again with tons of bluriness.

Here's the process:
1. Send yourself some messages (don't read them, leave them as unread!)
2. Note that new messages get little stars next to them, to the left of the subject field.
3. Star a couple of those messages as favorites.
4. Note how quickly it becomes chaotic.

The star field doesn't HAVE to be next to the subject field, but it's certainly more confusing if it is.
Should show the multi-star problem.
(In reply to comment #3)
> Here's another demo, again with tons of bluriness.
> 
> Here's the process:
> 1. Send yourself some messages (don't read them, leave them as unread!)

Can you create a message that has this behaviour  ? Save it and attach it here ?

> 2. Note that new messages get little stars next to them, to the left of the
> subject field.

If I follow your instructions I don't get a second star. Are you using a theme ?
All my messages have this behavior until I read them, however I just noticed that marking a message as unread after having read it doesn't make the star turn up again. 

I'll attach a message that has this behavior, but I'll be surprised if it teaches anybody anything, since it's just a normal old message.

Could it be a linux/GTK+ thing?
Oh, also, no, I don't have any themes installed.
Yep, the small yellow star is shown for NEW messages. It's per design, but perhaps a bit confusing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Using stars for new messages and starred messages is confusing. → Using stars for NEW messages and starred messages is confusing.
I'd say the star is overloaded:
 - Address book
 - new messages
 - starred messages

If all three are selected, you start having stars all over the place. Not sure the value of starring new messages vs. bolding unread messages...
I recall Bryan suggesting we should use colored text, just as we do for the new messages in the sidebar. I'll take care of this.
Assignee: nobody → nisses.mail
Messages are already colored though, if tagged with a color, right? 

(not to be too much of a naysayer)
Is it possible to color tag a new, unread message?
Yep. Via a filter. I do.
lets try making the new color and make sure that it gets overridden by any tag colors that are applied.
(In reply to comment #14)
> lets try making the new color and make sure that it gets overridden by any tag
> colors that are applied.

Sounds like a good idea!
It doesn't hurt to try, but I'm wondering what the value of labeling a message as new vs labeling it as unread. It seems confusing to me to have more than a couple colors going on.

So, for example, if I get a message that's new, it's going to be purple (for example). If I have a filter that tags things, then that message is going to be red, or maybe blue or green. Once I've read the purple message, it turns black. Once I've read the red, blue or green message, it stays red. That seems awfully confusing to me. 

I'm assuming the push for marking messages as new is because marking them as unread isn't helpful (since we never read things with subjects like "your item has shipped"). I'm not sure though that multiple colors are the answer, nor stars.

Might the answer - this is crazy, I know - be to stop marking them as read/unread, and to instead mark as new/old? The point of read/unread was to help people find new stuff, right? If people are using it to mark things that are important to them, then they should be using stars or tags, right? Maybe? 

Alternatively, may I suggest italics for new messages? We don't want to overload color in order to avoid overloading stars.
It's not about read/unread. NEW =~ you haven't seen even then header of this message before - it's unread and you wasn't in the folder last time you entered it.
Right, but isn't that the desired functionality/purpose of the read/unread? I mean, what if we stopped labeling things as read/unread, and switched to new/old? 

Just thinking outside the box here, but is there some value to breaking things down into three quadrants:

-------------------------
| Old/Unread | Old/Read |
-------------------------
| New/Unread |    n/a   |
-------------------------

Is there really a difference between new/unread and old/unread in terms of how people use the functionality, or is it just a technical thing we, as designers have created? 

To me, it seems overly complicated, and this bug is just a symptom of the UI not knowing how to cope.

(my 2 cents, of course)
Some people care and some don't, but those that care do care quite a bit, from what i've read (it's been discussed earlier). 
It's a subtle difference, but i think it's quite nice when you do know it.
Flags: blocking-thunderbird3?
Attached patch gnomestripe patch (obsolete) — Splinter Review
Ok, slightly misusing bugzilla to temporary storing my patches to transfer between my machines. ;)
Anyway, this is the gnomestripe part, uses the same color as in the sidebar for new messages (Highlight) and if there is a tag color automatically applied to new messages, the tag color get displayed. Pinstripe and Qute coming up.
Can I r- it now?

I thought I already had a comment in this bug about the reddish-yellow splats that we used in 2.0, but apparently not.

We had no problem at all when starred was a yellow five-point star, and new was an eight-point star/splat with a yellow center and red arms. They didn't look at all like the same thing, nobody ever confused the two.

The solution to having confused things by changing the eight-point stars to five-point yellow stars is *not* to drop the icon and change to color: the problem that this bug reported, "if I have a filter that adds a star, then a new message has two stars together," would go away, but only by being replaced with "if I have one new message, but that message had a tag added by a filter, then it's absolutely impossible to tell what was new." The solution to having confused things by changing to five-point yellow stars is to switch back away from them. Conveniently, we still have the previous ones all over the place, in server.png overlaying the second row of icons (and the second row of folder.png for Qute) and at the end of message.png.
Even though philor don't agree on the approach, I'm attaching the color parts for qute anyway. I will however, work out a graphics-only patch as well using a sparkle (that don't resemble a star like the current one do) that I hope have a bigger chance of getting in.
Attachment #407038 - Attachment is obsolete: true
Please don't use "color: Highlight" anywhere for anything. Highlight is a background and border color. It may look good on your system/theme, but not on mine: My Highlight color is a bright turquoise, which looks awful as text color, and is hard to read.

Please go back to using icons. Yes, star may be overloaded, but I'm sure we can find another eye-catching symbol. The meaning will be obvious from the function.
FWIW, the correct (and common) usage is:
color: HighlightText;
background-color: Highlight;
but that's inappropriate in this case, because that's for selection.
That also shows the problem: If you use a very faint color as selection background color (e.g. black on yellow), you get a very strange effect when using that (yellow) as *foreground* color (with a white background).
This uses a sparkle instead of the star as graphics, just like qute currently do.
Attachment #407245 - Flags: ui-review?(clarkbw)
Attachment #407245 - Flags: review?(philringnalda)
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Whiteboard: [no l10n impact]
Comment on attachment 407245 [details] [diff] [review]
patch using 'sparkle' (or splat) instead of star

looks like a splat to me
Attachment #407245 - Flags: ui-review?(clarkbw) → ui-review+
Attachment #407245 - Flags: review?(philringnalda) → review+
Flags: in-testsuite-
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 3.0rc1
Version: unspecified → Trunk
Checked in: http://hg.mozilla.org/comm-central/rev/a6535d21f9ef
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Right on folks. Thanks for jumping on this!
You need to log in before you can comment on or make changes to this bug.