Scrolling in Filter rules dialog is too slow

VERIFIED DUPLICATE of bug 444793

Status

--
minor
VERIFIED DUPLICATE of bug 444793
9 years ago
8 years ago

People

(Reporter: stepand76, Unassigned)

Tracking

({perf, testcase})

x86
Windows Vista
perf, testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

2.43 KB, application/octet-stream
Details
1.17 MB, application/octet-stream
Details
2.38 KB, application/octet-stream
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4

I have a filer with many rules (~80). Scrolling is very slow. It depends on how much of filters is visible (it means the bigger dialog, scrolling is slower).

Reproducible: Always

Steps to Reproduce:
1. Create filter with many (~80) rules.
2. Maximize the Filter Rules dialog and try to scroll in list of rules by clicking to the scrollbar or by PgUp/PgDown
3. You will see late response of the list of rules.
Component: General → Mail Window Front End
Keywords: perf
QA Contact: general → front-end
Version: unspecified → 3.0

Comment 1

9 years ago
do you see this problem in version 2?
can you send ludo or me the filter file for us to test? (save us time from creating such a large filter)
Component: Mail Window Front End → Search
QA Contact: front-end → search
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> do you see this problem in version 2?
No.

> can you send ludo or me the filter file for us to test? (save us time from
> creating such a large filter)
It is not difficult to create that filter rules. Attached is msgFilterRules.dat and a video demonstrating the late response. I noticed high CPU usage while scrolling. Hope this helps.
(Reporter)

Comment 3

9 years ago
Created attachment 402543 [details]
Filter Rules
(Reporter)

Comment 4

9 years ago
Created attachment 402544 [details]
Video demonstrating the late response
(In reply to comment #3)
> Created an attachment (id=402543) [details]
> Filter Rules

I crash when I load it http://crash-stats.mozilla.com/report/index/4d557d8c-01cf-41a4-92e2-f0a2a2090924
(Reporter)

Comment 6

9 years ago
Created attachment 402577 [details]
Filter Rules (no crash)
(Reporter)

Comment 7

9 years ago
(In reply to comment #5)
> I crash when I load it
> http://crash-stats.mozilla.com/report/index/4d557d8c-01cf-41a4-92e2-f0a2a2090924

Sorry. I just attached correct msgFilterRules.dat
(In reply to comment #7)
> (In reply to comment #5)
> > I crash when I load it
> > http://crash-stats.mozilla.com/report/index/4d557d8c-01cf-41a4-92e2-f0a2a2090924
> 
> Sorry. I just attached correct msgFilterRules.dat

We found another bug don't be so sorry :-)
Yes I definitively perceive the perf issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
(Reporter)

Comment 10

9 years ago
Hi Ludovic, is there any chance to fix it soon?
(In reply to comment #10)
> Hi Ludovic, is there any chance to fix it soon?

Someone needs to take the bug and fix it. Patches are welcome.

Updated

9 years ago
Severity: normal → minor

Comment 12

9 years ago
in fact, we're a dupe :)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 444793

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.