Closed Bug 519429 Opened 11 years ago Closed 11 years ago

Customize toolbar is broken

Categories

(Thunderbird :: Toolbars and Tabs, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0rc1

People

(Reporter: Aureliano, Assigned: bwinton)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
With today build

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090929 Lightning/1.0pre Shredder/3.0pre ID:20090929031525

opening "custumize toolbar" window, no additional button is present.

When closing window clicking "done" button, main menu in TB is disable.

It is possible that this issue is related to landing of bug #509044: i have all text beside icons, but I don't have select this (see screenshot)
WFM on the mac. I supose the error console is empty ?
It seems none related to this (all are related to gloda).

Here it happens also in safe-mode.
Assignee: nobody → bwinton
Status: NEW → ASSIGNED
No, Error console has:
Error: document.getElementById("labelAlignToolbar") is null
Source File: chrome://messenger/content/mailCore.js
Line: 190
Error: document.getElementById("labelAlign") is null
Source File: chrome://messenger/content/mailCore.js
Line: 191
Error: window.frameElement is null
Source File: chrome://messenger/content/mailCore.js
Line: 40
Error: gToolbox is null
Source File: chrome://global/content/customizeToolbar.js
Line: 55
(In reply to comment #3)
> No, Error console has:
> Error: document.getElementById("labelAlignToolbar") is null
> Source File: chrome://messenger/content/mailCore.js
> Line: 190
> Error: document.getElementById("labelAlign") is null
> Source File: chrome://messenger/content/mailCore.js
> Line: 191
> Error: window.frameElement is null
> Source File: chrome://messenger/content/mailCore.js
> Line: 40
> Error: gToolbox is null
> Source File: chrome://global/content/customizeToolbar.js
> Line: 55

Here no (I don't know why), but yours listed errors they seems related to this issue.

Also for you Thomas, after clicking "done" button in custumize toolbar window, main menu is disable (unusable) until restart TB?
> Also for you Thomas, after clicking "done" button in custumize toolbar window,
> main menu is disable (unusable) until restart TB?

Yes, but a workaround is to open a new 3-pane-window by invoking "Open" from a folder's context menu, e.g. the Inbox.
(In reply to comment #3)
> Error: document.getElementById("labelAlignToolbar") is null
> Error: document.getElementById("labelAlign") is null

I've fixed these.

> Error: window.frameElement is null
> Error: gToolbox is null

Which OS are you getting these on?

Thanks,
Blake.
(In reply to comment #6)
> > Error: window.frameElement is null
> > Error: gToolbox is null
> 
> Which OS are you getting these on?

Windows Vista. Am I alone in seeing these? ;)
I don't see them on OS X this morning, but I did see them at 1:00am last night, so no, you're not alone.

Until now, I didn't know what caused them.  But now I think it's OS X vs. Windows, so I've written a patch, and will test it under both, and then post it.

Thanks,
Blake.
Flags: blocking-thunderbird3?
I see this on both Linux and Vista.
OS: Windows XP → All
Flags: blocking-thunderbird3? → blocking-thunderbird3+
And here we go.  It would be really cool to get this into tonight's build so that the localizers can see the results of translating the new "Icons beside Text" string.

I didn't make the duplicated bit of code into a function, because we only use it twice, and the occurrences are right beside each other.

Thanks,
Blake.
Attachment #403496 - Flags: review?(philringnalda)
Comment on attachment 403496 [details] [diff] [review]
Fix the customization of toolbars on non-OSX platforms.

Stealing review from philor.  r=dmose.
Attachment #403496 - Flags: review?(philringnalda) → review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/7fae8af6c3b3
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0rc1
Duplicate of this bug: 519644
Duplicate of this bug: 519712
My evaluation of the 09/30/2009 Windows build indicates the patch works and the Customize function is restored. I think we can mark this one Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.