Last Comment Bug 519451 - [10.5] Crash [@objc_msgSend | CanonIJPDE@0x1531e]
: [10.5] Crash [@objc_msgSend | CanonIJPDE@0x1531e]
Status: VERIFIED FIXED
: crash, verified1.9.2
Product: Core
Classification: Components
Component: Printing: Output (show other bugs)
: 1.9.1 Branch
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: Steven Michaud [:smichaud] (Retired)
:
:
Mentors:
Depends on: 396680
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-29 08:32 PDT by Carsten Book [:Tomcat]
Modified: 2011-06-09 14:58 PDT (History)
13 users (show)
mbeltzner: blocking1.9.2-
mbeltzner: wanted1.9.2+
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.2-fixed
.9-fixed


Attachments

Description Carsten Book [:Tomcat] 2009-09-29 08:32:16 PDT
seems this crash is related to a Canon Driver and Mac 10.5.x

http://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A3.5.3&query_search=signature&query_type=exact&query=&date=&range_value=1&range_unit=weeks&do_query=1&signature=objc_msgSend%20|%20CanonIJPDE%400x1531e

a lot of comments mentioned that this happened during printing
Comment 1 Matthias Versen [:Matti] 2009-09-29 09:43:49 PDT
dupe or related to bug 460963 ?
Comment 2 Damon Sicore (:damons) 2009-09-29 15:21:35 PDT
Have we reproduced this?
Comment 3 Mats Palmgren (:mats) 2009-09-29 16:24:02 PDT
FWIW, a Canon printer driver also crashes on Windows: bug 517233.
Comment 4 Carsten Book [:Tomcat] 2009-10-05 16:37:40 PDT
do we have someone with this Printer in MV ?
Comment 5 Smokey Ardisson (offline for a while; not following bugs - do not email) 2009-10-06 09:30:38 PDT
(In reply to comment #1)
> dupe or related to bug 460963 ?

Yes.  chofmann mentions offset 0x1531e in bug 460963 comment 42 (though it looks like the bug was originally filed about a crash at offset 0x14111).
Comment 6 Carsten Book [:Tomcat] 2009-10-12 12:20:50 PDT
(In reply to comment #5)
> (In reply to comment #1)
> > dupe or related to bug 460963 ?
> 
> Yes.  chofmann mentions offset 0x1531e in bug 460963 comment 42 (though it
> looks like the bug was originally filed about a crash at offset 0x14111).

so duping to bug 460693 ?
Comment 7 Carsten Book [:Tomcat] 2009-10-12 15:55:30 PDT
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #1)
> > > dupe or related to bug 460963 ?
> > 
> > Yes.  chofmann mentions offset 0x1531e in bug 460963 comment 42 (though it
> > looks like the bug was originally filed about a crash at offset 0x14111).
> 
> so duping to bug 460693 ?

bug 460963 of course
Comment 8 Daniel Veditz [:dveditz] 2009-10-15 13:45:23 PDT
Not clear why this was nominated as a 1.9.1 branch blocker. Do we think this is a problem in our code, or one we can mitigate? Rather than block we'll look at the fix after we have one since it will presumably block 1.9.2 as a topcrash
Comment 9 Mike Beltzner [:beltzner, not reading bugmail] 2009-10-29 09:14:51 PDT
Not a blocker, though wanted.

Kev: do we have contacts at Canon? This is getting increasingly strange.
Josh: do we know why this would be a Firefox + driver problem?
QA: can we buy one of these printers and get a trace in a debugger?
Comment 10 Marcia Knous [:marcia - use ni] 2009-10-29 09:28:10 PDT
Mike: I have a Canon Printer down in the lab, and I have seen several Canon Pixma printers scattered about the office. I will investigate further with my 10.5 machines since it appears from the comment in the other bug that it was not happening on 10.6.

(In reply to comment #9)
> Not a blocker, though wanted.
> 
> Kev: do we have contacts at Canon? This is getting increasingly strange.
> Josh: do we know why this would be a Firefox + driver problem?
> QA: can we buy one of these printers and get a trace in a debugger?
Comment 11 Mike Shaver (:shaver -- probably not reading bugmail closely) 2009-10-29 09:32:20 PDT
Is this "carbon print dialog from cocoa app makes world sad"?  Are we going to land that Cocoa printing stuff on 1.9.2 after all?  (Or maybe, as would have been wise, we did that before the beta!)
Comment 12 Marcia Knous [:marcia - use ni] 2009-10-29 11:16:47 PDT
So far I have tried to reproduce this on an 10.5.8 Intel Mac running 3.5.4 and a PPC Mac using two different Canon printers - ip4300 and ip2600. In both cases I used old printer drivers and so far I have not been able to crash. I tried different variations of settings as well. I noticed in the list of crash reports that they all seem to be 3.5.3, so I will revert to that version and report back.
Comment 13 Marcia Knous [:marcia - use ni] 2009-10-29 11:24:53 PDT
No crash using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 and printing to the Canon IP4300.
Comment 15 Steven Michaud [:smichaud] (Retired) 2010-01-03 07:19:18 PST
This bug might be a dup of bug 525277, which is fixed (in current
Minefield nighlies) by my patch for bug 396680.

If any of you can still reproduce this bug's crash in a current FF 3.6
beta or nightly, please also try a current Minefield (trunk,
mozilla-central) nightly.  Let us know your results.
Comment 16 Steven Michaud [:smichaud] (Retired) 2010-01-08 09:54:01 PST
http://crash-stats.mozilla.com shows that these crashes all happen on OS X 10.5.X.
Comment 17 Steven Michaud [:smichaud] (Retired) 2010-03-01 15:08:24 PST
This should be fixed by my patch for bug 396680, which has been on the trunk for a while, and just landed on the 1.9.2 and 1.9.1 branches.
Comment 18 Al Billings [:abillings] 2010-03-22 10:39:25 PDT
QA cannot verify this fix since we cannot get the initial crash to occur. We'll have to see how the crash stats look post-release to see if the problem was addressed for the users seeing it.
Comment 19 Steven Michaud [:smichaud] (Retired) 2010-04-07 09:15:24 PDT
These crashes are completely gone from FF 3.6.2 and 3.6.3.

Note You need to log in before you can comment on or make changes to this bug.