Closed Bug 519792 Opened 12 years ago Closed 9 years ago

Clicking on Growl new message opens new window (behavior change)

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
macOS
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: eugene.vasserman, Unassigned)

References

Details

In TB3b1, clicking on Growl notification for new mail caused the folder with the new mail to be displayed, with the new message selected (and readable in 3-pane view). Now clicking on Growl notifications causes the new message to be displayed in a new message window.

I liked the old behavior. I know this is a personal preference, and bug #467159 already had a discussion about making the Growl click behavior a preference, but the sudden behavior change is jarring, and the preference seems to not have been implemented yet. At least I can't find it.
Bryan thoughts ?
Actually I believe sid0 may be working on this.
The new behavior is this:
Message opens in new window
Folder with new message is NOT selected
When message is deleted, a new message from the same folder as the new message is displayed
When message window is closed, the same folder/message that were selected before new email was received are visible in 3-pane view.

To me, this behavior is inconsistent on a number of levels. Ignoring that I liked the old way, the new way should not open another message when the new message is deleted, IMHO.  It is unexpected and illogical (to me), since the next message opened is old. Also, TB should deposit you in the same folder as the new message when that message is closed or deleted.
Duplicate of this bug: 522083
Sorry, Growl support has been removed from the current versions.

Mass bug change. Please reopen if you disagree.
Status: NEW → RESOLVED
Closed: 9 years ago
Depends on: 792793
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.