Closed Bug 519951 Opened 12 years ago Closed 12 years ago

Closing a contentTab leaks an nsBrowserStatusFilter and others

Categories

(Thunderbird :: Toolbars and Tabs, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: memory-leak)

Attachments

(1 file)

Attached patch The fixSplinter Review
I saw this on the bloat boxes the other day when I'd temporarily let the what's new page check be broken and so it was actually being shown and causing a lot of leaks.

The issue is that we're setting up a c++ instance (the nsBrowserStatusFilter) with a listener (tabProgressListener) that is holding onto the tab object (mTab et al) which is then holding onto the c++ instance.

We need to break this cycle when we close the tab - so we save the listener and then remove it later.

I would also like to enable the content tab in the bloat tests, but it appears when we switch/close the content tab back to the main 3 pane tab, we're causing a bunch of other leaks - so I'll raise a bug on following that up as well and that can be the one to enable the content tab on the leak tests.
Attachment #404016 - Flags: review?(bienvenu)
Blocks: 519955
Attachment #404016 - Flags: review?(bienvenu) → review+
Attachment #404016 - Flags: approval-thunderbird3+
Checked in: http://hg.mozilla.org/comm-central/rev/d4529d3c2429
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.