Warning: XUL box for hbox element contained an inline img child when opening addressbook

RESOLVED FIXED in Thunderbird 3.0rc1

Status

Thunderbird
Address Book
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: Valery Kondakoff, Assigned: philor)

Tracking

Trunk
Thunderbird 3.0rc1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.4pre) Gecko/20090930 Shredder/3.0pre

Every time when opening address book there are two warnings in error console:

Warning: XUL box for hbox element contained an inline img child, forcing all its children to be wrapped in a block.
Source File: chrome://messenger/content/addressbook/addressbook.xul
Line: 0

Reproducible: Always
Duplicate of this bug: 519443
Set to minor (or better trivial?)
Severity: normal → minor
(Assignee)

Updated

9 years ago
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Target Milestone: --- → Thunderbird 3.0rc1
Version: unspecified → Trunk
(Assignee)

Comment 3

9 years ago
Created attachment 404392 [details] [diff] [review]
Fix v.1

I like this a little better than the other alternative dbaron offered, to do what the code that issues the warning does and wrap an html:div around the html:img (with the slight improvement that if we do it, we can skip where it wraps the spacers, too).
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #404392 - Flags: review?(bugzilla)
(Assignee)

Comment 4

9 years ago
Created attachment 404466 [details] [diff] [review]
Fix v.2

Neil pointed out that he already fixed this for editing cards, in bug 513471, and we might as well use that same solution for display.
Attachment #404392 - Attachment is obsolete: true
Attachment #404466 - Flags: review?(bugzilla)
Attachment #404392 - Flags: review?(bugzilla)
Attachment #404466 - Flags: review?(bugzilla) → review+
(Assignee)

Comment 5

9 years ago
Comment on attachment 404466 [details] [diff] [review]
Fix v.2

Trivial console-noise-shusher.
Attachment #404466 - Flags: approval-thunderbird3+
(Assignee)

Comment 6

9 years ago
http://hg.mozilla.org/comm-central/rev/1ea1a945d4a0
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

6 years ago
Blocks: 762669
You need to log in before you can comment on or make changes to this bug.