If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot disable master password, activated automatically after upgrade

NEW
Unassigned

Status

Thunderbird
Security
--
major
8 years ago
a year ago

People

(Reporter: Nicola Ottomano, Unassigned)

Tracking

({qawanted, regression})

x86
Windows XP
qawanted, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [223 Migration][gs], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.1.4) Gecko/20091007 Firefox/3.5.4
Build Identifier: 3.0b4

After upgrading from TB 2.0.x to TB 3.0b4, I cannot disable Master Password.

Unchecking it from Security options does not work.

In fact if I close and reopen TB3, it prompt me an input box asking for master password.

Reproducible: Always
(Reporter)

Updated

8 years ago
Keywords: regression
Version: unspecified → 3.0
Whiteboard: [223 Migration]

Updated

8 years ago
Blocks: 521381
did this get tested in another bug?
Keywords: qawanted
rsx11m, by chance have you tested this? if not, could you?

Comment 3

8 years ago
I'm not using that feature, therefore no, I didn't test it...

Updated

8 years ago
Duplicate of this bug: 532681
confirmed per duplicate?
Nicola, you had master password set in version 2?
What do you get when you uncheck Use Master Password?
Do you see 
  You have deleted your Master Password. Your stored web and email passwords, 
  form data, and private keys will not be protected.


(If Nicola had a password test in version 2, this might not be Ahmet's problem)

Comment 7

8 years ago
may be i tested master password 2.0 . i don't remember but TB 2.0 newer ask me master password. i have a master password on firefox i test it but it is not passible. there are 5 account on my tb.
(Reporter)

Comment 8

8 years ago
Hi,
here what I've done:

1-On TB2 I set up a Master password just to try it.
2-After 1 week I've unckecked "Use master password".
3-After some months I've installed TB 3.0b4
4-On the firs run TB3 asked me for my master password... but my master password was already disabled.
5-I've unckecked "Use master password" again under TB3.
6-At every run of TB3 it ask me for master password.
7-If I try to change master password  with a new one, nothing happens. When I run TB3 it ask me for the old master password.

No error messages are promted to me when change master password or disable it. 

I hope this will help you guys in debugging TB3.
Bye

Nicola

Comment 9

8 years ago
i think i have a same problem with Nicola. But i can't remember what is my master password. 
Ahmet
workarounds - 2 references, same method:
 http://getsatisfaction.com/people/jtbaum
 http://kb.mozillazine.org/Master_password#Resetting_the_master_password
Severity: normal → major

Comment 11

8 years ago
From what I can tell TB3 has changed the behavior of master password for email accounts.
It used to be that you didn't need to enter the security device password to allow TB to login and get mail but did need to enter it to user a private key / certificate. As of this upgrade it seems to require it for both of these functions. 

I disabled the master password option on the Preferences, Passwords dialog so that TB can get mail unhindered but it appears that the security device password is also now disabled.

I have no idea what they were thinking here. It makes no sense. Getting plain text email with no master password is something I'm willing to allow on my machine but I still should be able to protect the security device for encrypted/signed messages. The two should not be lumped together. I would call this a bad choice because it forces someone to unprotect their certificate store just because they want easy email retrieval.

Is this a bug? I think it is. At least it's a terrible design choice.
(Reporter)

Comment 12

8 years ago
Hi Wayne Mery,
your solution does not work on my TB.
after I pasted openDialog("chrome://pippki/content/resetpassword.xul")
and pressed the Evaluate button, TB really reset my master password and all other passwords... but if I restart TB and select "get mail", it does not asks me for email account passwords but returns me an error messsage (I translate from Italian, so, I don't know if the error is exactly the same in English): "There was an error in receiving email password".
So, now I cannot download emails with TB3 and I cannot set accounts password.

Anyone can help?
Bye

Nicola
"Show Passwords" window display your saved pwds?
Try to delete your saved passwords and then re-input them when TB "get messages".
(Reporter)

Comment 14

8 years ago
The "Show Passwords" dialog window is empty.

Nicola
Do you use TB 3.1a1 20091214?
(Reporter)

Comment 16

8 years ago
I started with TB 3.b4 and now I use TB3 final release in Italian under WinXp Home SP3

Comment 17

8 years ago
I have had the same problem: After an upgrade to TB 3 (as proposed by the "check for updates" dialog), Thunderbird popped up with this "master password" dialog.
Needless to say: a master password has NOT been activated in the previous version (not sure if it maybe was active once in the past, it definitely wan't before the upgrade).
After resetting the password using the abovementioned command and re-entering my 2 passwords, everything seems OK.
Firefox 3 passwords were *NOT* affected by this, luckily.

I propose to rename this bug to something that reflects the fact that the master PW got activated automatically after upgrade.

The main question stays - why did TB activate the nonexistenmt master password after the upgrade?

And maybe a separate bug: ehwn trying to remove the master PW in TB, the password prompt would show the "Remove" button inactive, even when I typed in a password. Is it checking the password for validity on the fly, or does it just forget to activate that button?

Comment 18

8 years ago
536064 seems a duplicate of this.
It happened to my sister on Windows Vista from Thunderbird 2.0.0.22 to 3.0.4,
it didn't had a master password in 2.0.0.22.
Had to solve it with the Error Console trick, it would be nice to have that
feature in the passwords tab (reset the master password and loose all
passwords).
Thanks!!!

Comment 19

7 years ago
I have the same issue with the last version of Thunderbird: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110110 Thunderbird/3.3a2pre. Uncheck the master password box has not effect.
Vincent, coming from which version?

(In reply to Vincent DEBOUT from comment #19)
> I have the same issue with the last version of Thunderbird: Mozilla/5.0
> (Windows NT 5.1; rv:2.0b9pre) Gecko/20110110 Thunderbird/3.3a2pre. Uncheck
> the master password box has not effect.
Duplicate of this bug: 536064

Comment 22

6 years ago
I have no idea, I'm using Thunderbird for years now and I don't remember when I set the master password.
this seems to have missed the boat ... perhaps because attention got deflected into the SM report at bug 506638.  should 506638 move to Thunderbird or core?

disturbing number of gsfn reports, and for current versions of thunderbird. Surprising that no one is merging any of them, but that may be because there is not a clear canonical topic?  I've not picked a canonical topic, so tentatively labeled them as https://getsatisfaction.com/mozilla_messaging/tags/mpw

support article mentioned in bug 506638 at http://support.mozillamessaging.com/en-US/kb/master-password-requested-but-not-set?s=master&as=s which fails to mention this bug.
Status: UNCONFIRMED → NEW
Depends on: 506638
Ever confirmed: true
Summary: Cannot disable master password → Cannot disable master password, activated automatically after upgrade
Whiteboard: [223 Migration] → [223 Migration][gs]

Comment 24

5 years ago
This bug is still active.
Person on forum just updated to version 17.0.4 and suddenly is being asked for a Master Password that was never set.
Tried removing key3.db, but this does not work.
One very unhappy Thunderbird user:
https://getsatisfaction.com/mozilla_messaging/topics/password-cq7v9
(shouldn't depend on SM bug, unless that's got more/better info and it's toolkit or core)

I'd be surprised if all or even most https://getsatisfaction.com/mozilla_messaging/tags/mpw issues are this bug.
You need to log in before you can comment on or make changes to this bug.