Excessive and repeated timeouts when LDAP server not available

RESOLVED DUPLICATE of bug 332169

Status

Thunderbird
Address Book
P2
normal
RESOLVED DUPLICATE of bug 332169
9 years ago
8 years ago

People

(Reporter: Michael Dunn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Inserting addresses from local or collected AB is extremely painful when LDAP is configured but not found. Thunderbird seems to pay the same time out price over and over within the same email compose session.

Once LDAP server fails to be found Thunderbird should behave like it is turned off untill the next Thunderbird session

Maybe we could surface in the Menu UI a notion of LDAP off line and the user could toggle.
Whiteboard: dupeme

Comment 1

9 years ago
For me, it's actually worse than that. I access a slow Exchange server's LDAP dir over VPN, so LDAP response time is quite slow. Every address I type in the address bar of a compose window (indeed, almost every character I type for the address) causes a complete hang of the TB UI... *and* all of GNOME. It appears the LDAP lookup is blocking the GNOME UI thread. Once LDAP replies (perhaps 20s later), the address completion list displays, and selecting an address from the list is fast.

The problem affects both TB2 and TB3.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 332169

Comment 3

9 years ago
OK, if you want to make it just about disabling an LDAP server, I can open a different bug on the UI interactivity problem. That's probably a better idea anyway. Sorry for confusing two separate concerns.

Comment 4

9 years ago
Kibry, I've filled such one Bug 533656
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.