Last Comment Bug 525842 - Going offline tries to synchronize saved search folders with IMAP server
: Going offline tries to synchronize saved search folders with IMAP server
Status: RESOLVED FIXED
: fixed-seamonkey2.0.1
Product: MailNews Core
Classification: Components
Component: Networking: IMAP (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: Thunderbird 3.0rc1
Assigned To: David :Bienvenu
:
Mentors:
: 522202 523313 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-02 03:24 PST by Craig Emery
Modified: 2009-12-13 06:05 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (1.01 KB, patch)
2009-11-02 10:02 PST, David :Bienvenu
mozilla: review+
mozilla: superreview+
standard8: approval‑thunderbird3+
Details | Diff | Review

Description Craig Emery 2009-11-02 03:24:44 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4

I have a saved search folder. It isn't listed in the folders that can be synchronized on this computer. Thus it clearly isn't supposed to be synchronised. However when I go off-line, TB does try and synchronize it and so I get the error:

The current command did not succeed. The mail server responded:Mailbox does not exist.

Reproducible: Always

Steps to Reproduce:
1. Do a search
2. Save as a saved search folder
3. Go off-line
Actual Results:  
Error dialog with:
The current command did not succeed. The mail server responded:Mailbox does not exist.

Expected Results:  
No error dialog. No attempt to synchronize this folder should be made.

Search on-line is not selected for this saved-search folder.
Comment 1 Ludovic Hirlimann [:Usul] 2009-11-02 08:33:11 PST
*** Bug 523313 has been marked as a duplicate of this bug. ***
Comment 2 Ludovic Hirlimann [:Usul] 2009-11-02 08:33:19 PST
*** Bug 522202 has been marked as a duplicate of this bug. ***
Comment 3 Ludovic Hirlimann [:Usul] 2009-11-02 08:34:26 PST
Seeing this too. Marking new as I couldn't find any other bugs to duplicate this too.
Comment 4 David :Bienvenu 2009-11-02 10:02:04 PST
Created attachment 409714 [details] [diff] [review]
proposed fix

attaching reviewed patch to right bug.
Comment 5 David :Bienvenu 2009-11-02 10:06:51 PST
fixed on trunk.
Comment 6 David :Bienvenu 2009-11-02 10:07:33 PST
Comment on attachment 409714 [details] [diff] [review]
proposed fix

this is a safe fix for an annoying issue.
Comment 7 David :Bienvenu 2009-11-02 13:38:03 PST
fixed for 3.0 rc1 as well, a=standard8.

Note You need to log in before you can comment on or make changes to this bug.