Closed Bug 527324 Opened 12 years ago Closed 12 years ago

[account autoconfig]When I create a new account tb stay in "checking password..." indefinitely

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set
critical

Tracking

(thunderbird3.0 .1-fixed)

VERIFIED FIXED
Thunderbird 3
Tracking Status
thunderbird3.0 --- .1-fixed

People

(Reporter: giutino, Assigned: bwinton)

Details

(Keywords: hang, Whiteboard: [tb3ride-along][fixed RC1 build 2])

Attachments

(3 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.6pre) Gecko/20091108 Shredder/3.0pre

I follow the procedure to create a new account (@gmail.com).
It seems that all work properly but, after that TB found the configuration settings and I select the button "create account" TB remain in the state "check password..." indefinitely.

Reproducible: Always

Steps to Reproduce:
1.I start TB3 and select an existing account in the left sidebar
2.On the right I select "create a new account" 
3.I put the datas and select continue
4.Shredder find the settings for my email account
5.I select the button "create account"
6. Shredder start to "check password..." but continue indefinitely.
Actual Results:  
Shredder remain in "check password..." state and nothing appen.

Expected Results:  
Shredder confirm the account creation and it is displayed in the left sidebar

A strange behavior during the process of creation is that if I put in the email address field:
myEmailAddress@Gmail.com and select continue tb need about 15 secs and return me the following configuration
Username:myEmailAddress (without @Gmail.com)
Incoming:imap.Gmail.com IMAP:993 SSL/TLS
Outgoing:smtp.Gmail.com SMTP:587 STARTTLS

if i put in the email address field:
myEmailAddress@gmail.com (the difference is only "Gmail" vs "gmail")and select continue tb need about 1 sec and return me the following configuration
Username:myEmailAddress@gmail.com (WITH @gmail.com)
Incoming:imap.googlemail.com IMAP:993 SSL/TLS
Outgoing:smtp.googlemail.com SMTP:465 SSL/TLS
Giuseppe , can you have a look in Tools -> Error console and see if there are error messages when you are doing that ?
Yes, there's this error:
"Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgAccountManager.removeIncomingServer]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://messenger/content/accountcreation/verifyConfig.js :: anonymous :: line 257"  data: no]
Blake what else would you need here to figure out what the issue might be ?
Well, if I can replicate it with the uppercase Gmail, that should be good enough.

(I'm having problems building these days, so it might be a little while before I can get to it.)
Yeah, I can replicate it, and it seems like a huge pain to only be able to use lower-case in your email address, without any notification of that fact, and with a strange error when you don't follow the unwritten rule.  ;)

In bug 525532, Magnus made it so that we ignore the case of the email address when we figure out whether or not to show the Reply All button.  Perhaps we should lower-case the email address here as well, at least for the purposes of checking.

At the very least, we should probably mention it in the release notes, or something.

Thanks,
Blake.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3?
Assignee: nobody → bwinton
OS: Windows 7 → All
Hardware: x86 → All
Severity: major → critical
Keywords: hang
Version: unspecified → 3.0
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Whiteboard: [tb3ride-along]
It's not perfect, but it should let us find our stored configs a little better.

Note: I believe this is equivalent to doing the check on the server side, with the possible difference being the case of what gets shown in the username field.

Thanks,
Blake.
Attachment #412638 - Flags: ui-review?(clarkbw)
Attachment #412638 - Flags: superreview?(bienvenu)
Attachment #412638 - Flags: review?(philringnalda)
Okay, we're only going to lower-case the domain part, because we know it'll be ascii for the next little while.

The other change in this patch is to re-lowercase the domain if the user has changed it and hits "Re-test config".

Thanks,
Blake.
Attachment #412638 - Attachment is obsolete: true
Attachment #412662 - Flags: ui-review?(clarkbw)
Attachment #412662 - Flags: superreview?(bienvenu)
Attachment #412662 - Flags: review?(philringnalda)
Attachment #412638 - Flags: ui-review?(clarkbw)
Attachment #412638 - Flags: superreview?(bienvenu)
Attachment #412638 - Flags: review?(philringnalda)
Does this override user-visible things, like the account name we create, if the user uses mix-case? My inclination would be to lower-case the url we run right before we run it, not change the case on the user-visible strings, if there's a safe way of doing so.
Attached image The created account
In the final account, we have mixed case, except for items which are domain names.

Another screenshot is coming up soon.
The first shot is after I've typed in the mixed case address, and hit "continue".
The second shot is after I've hit "edit", and changed the case of "latte".
The third shot is after I've hit "Re-test Configuration".

Does that UI seem okay to everyone?  (By which I mean Bryan. ;)

Thanks,
Blake.
Attachment #412662 - Flags: review?(philringnalda) → review+
Comment on attachment 412662 [details] [diff] [review]
A better version of the patch.

cool, thx, Blake.
Attachment #412662 - Flags: superreview?(bienvenu) → superreview+
Comment on attachment 412662 [details] [diff] [review]
A better version of the patch.

bryan is traveling today, so I don't expect he'll get to it.  I'm going to channel him and say that that UI seems good to me.

We should file a followup bug on IDN domains in autoconfig, for 3.1.
Attachment #412662 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 412662 [details] [diff] [review]
A better version of the patch.

Requesting approval, based on the tb3ride-along whiteboard note.
Attachment #412662 - Flags: approval-thunderbird3?
Comment on attachment 412662 [details] [diff] [review]
A better version of the patch.

a=Standard8. Please land on comm-central and comm-1.9.1.

I'll land on the relbranch within the next 12 hours.
Attachment #412662 - Flags: approval-thunderbird3? → approval-thunderbird3+
Whiteboard: [tb3ride-along] → [tb3ride-along][ready to land]
Checked in as:
http://hg.mozilla.org/releases/comm-1.9.1/rev/3b5f2b677918
http://hg.mozilla.org/comm-central/rev/990cc59beac8
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Checked in for build 2 of RC1:
http://hg.mozilla.org/releases/comm-1.9.1/rev/2aaa7e7e813a
Whiteboard: [tb3ride-along][ready to land] → [tb3ride-along][fixed RC1 build 2]
Target Milestone: --- → Thunderbird 3
(In reply to comment #12)
> (From update of attachment 412662 [details] [diff] [review])
> bryan is traveling today, so I don't expect he'll get to it.  I'm going to
> channel him and say that that UI seems good to me.

Channeled correctly!
Status: RESOLVED → VERIFIED
Whiteboard: [tb3ride-along][fixed RC1 build 2] → [tb3ride-along][fixed RC1 build 2][fixedtb301]
Whiteboard: [tb3ride-along][fixed RC1 build 2][fixedtb301] → [tb3ride-along][fixed RC1 build 2]
You need to log in before you can comment on or make changes to this bug.