Persona reset after applying when previewing another persona

RESOLVED DUPLICATE of bug 522188

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 522188
9 years ago
9 years ago

People

(Reporter: rdoherty, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
This was hard to reproduce, so here's a screencast:

http://www.screencast.com/users/rdoherty/folders/Jing/media/29bb9ad8-1c10-4296-94c4-d58bc0f9d0ef

STR:
1) Apply a persona
2) Apply a different persona
3) Visit a 3rd persona's page and mouseover/out the preview image.
4) Witness your persona reverting to the first persona.

Comment 1

9 years ago
Yeah, I've run into this a great deal. 
In addition, if I attempt to install a new persona (using Firefox 3.7a):
1) I hover over the "Wear This" button - new persona displays.
2) I click on it, a notice "A new theme has been installed" appears.
3) I move off of "Wear This" to close the notice or go to manage themes. Immediately I revert to the old theme.
4) I open "Manage Themes". I am informed I am using the new theme even though the old theme is active.

At this point, the following workaround usually succeeds.
5) Click on the old theme, choose "Use this theme".  The blank and reload occurs as it "switches" to the old theme which it is already displaying.
6) Choose "Use this theme" for the new theme.  At this point it switches and is fine.

I've also run into the situation where, on uninstalling an old theme, after having switched to the new theme, it applied the old theme.  At that point I'm stuck since the old theme is uninstalled and I can't do (5) and (6).  The only solution is to restart, at which point the new theme is correctly displayed.
(Reporter)

Comment 2

9 years ago
CC'ing Johnath, want to make sure this doesn't get forgotten.

It appears that if the 'ResetBrowserThemePreview' event is fired after the 'InstallBrowserTheme' event, Firefox resets to the *previous* persona instead of not resetting at all.

Expected behavior: 

'ResetBrowserThemePreview' event is ignored if the previous event is not 'PreviewBrowserTheme'.
This might be related to a bug already on Dao's radar, but he's the best person to comment directly. Thanks for the FYI, Ryan!
Blocks: 511104
Yep, this is bug 522188.
No longer blocks: 511104
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522188
You need to log in before you can comment on or make changes to this bug.