Crash in [@nsMediaCache::BlockIsReusable(int) ] when switching out of full screen video mode

VERIFIED FIXED

Status

()

defect
--
critical
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: marcia, Assigned: roc)

Tracking

({regression, topcrash, verified1.9.2})

1.9.2 Branch
x86
Windows NT
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.2 +
in-litmus +

Firefox Tracking Flags

(status1.9.2 beta4-fixed)

Details

(Whiteboard: [crashkill], crash signature)

Seen in crash stats, and easily reproduced using  Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2. 

STR:
1. Visit http://www.spreadfirefox.com/5years/en-US/
2. Use the controls to enter full screen mode.
3. Play the video in full screen and then exit
4. After I exit and then click in the controls, I crash.

http://crash-stats.mozilla.com/report/index/290e59c0-8241-4851-a9aa-ec3bd2091112

Bug 520528 seems similar and was found during mochitests.
Flags: blocking1.9.2?
Further down in the list of crash reports there are also crashes in _alldiv which seem to be the same crash - the comments there describe full screen and watching the sfx video - http://crash-stats.mozilla.com/report/index/1df0349a-d6d4-43d2-9ec7-b1c7d2091111 is one example.

Comment 2

10 years ago
this appears to be a low volume crash around at least back into early oct. that now has spiked with increased use of the betas

 0   total crashes for nsMediaCache on 20091021-crashdata.csv
 0   total crashes for nsMediaCache on 20091022-crashdata.csv
 0   total crashes for nsMediaCache on 20091023-crashdata.csv
 1   total crashes for nsMediaCache on 20091024-crashdata.csv
 1   total crashes for nsMediaCache on 20091025-crashdata.csv
 2   total crashes for nsMediaCache on 20091026-crashdata.csv
 0   total crashes for nsMediaCache on 20091027-crashdata.csv
 3   total crashes for nsMediaCache on 20091028-crashdata.csv
11   total crashes for nsMediaCache on 20091029-crashdata.csv
 8   total crashes for nsMediaCache on 20091030-crashdata.csv
11   total crashes for nsMediaCache on 20091031-crashdata.csv
22   total crashes for nsMediaCache on 20091101-crashdata.csv
17   total crashes for nsMediaCache on 20091102-crashdata.csv
18   total crashes for nsMediaCache on 20091103-crashdata.csv
20   total crashes for nsMediaCache on 20091104-crashdata.csv
 6   total crashes for nsMediaCache on 20091105-crashdata.csv
15   total crashes for nsMediaCache on 20091106-crashdata.csv
 4   total crashes for nsMediaCache on 20091107-crashdata.csv
 3   total crashes for nsMediaCache on 20091108-crashdata.csv
 8   total crashes for nsMediaCache on 20091109-crashdata.csv
11   total crashes for nsMediaCache on 20091110-crashdata.csv
36   total crashes for nsMediaCache on 20091111-crashdata.csv

Comment 3

10 years ago
34 total crashes for nsMediaCache::BlockIsReusable on 20091111-crashdata.csv
0 start up crashes inside 3 minutes

os breakdown

  16 nsMediaCache::BlockIsReusable(int) Windows NT 6.1.7600
   8 nsMediaCache::BlockIsReusable(int) Windows NT 5.1.2600 Service Pack 3
   4 nsMediaCache::BlockIsReusable(int) Windows NT 6.0.6002 Service Pack 2
   2 nsMediaCache::BlockIsReusable(int) Windows NT 5.1.2600 Service Pack 2
   2 nsMediaCache::BlockIsReusable(int) Windows NT 5.1.2600 Dodatek Service Pack 3
   1 nsMediaCache::BlockIsReusable(int) Windows NT 6.1.7100
   1 nsMediaCache::BlockIsReusable(int) Windows NT 6.0.6001 Service Pack 1


distribution of all versions where the nsMediaCache::BlockIsReusable crash was found on 20091111-crashdata.csv
  34 Firefox 3.6b2

most of the problem is with video we are hosting, but there are other sites

 17 nsMediaCache::BlockIsReusable(int) http://www.spreadfirefox.com/5years/en-US/
   3 nsMediaCache::BlockIsReusable(int) http://www.spreadfirefox.com/5years/de/
   2 nsMediaCache::BlockIsReusable(int) http://www.spreadfirefox.com/5years/it/
   2 nsMediaCache::BlockIsReusable(int) http://videos.mozilla.org/fyfx/Firefox_Final_VO.ogv
   2 nsMediaCache::BlockIsReusable(int) \N
   1 nsMediaCache::BlockIsReusable(int) http://www.spreadfirefox.com/5years/ru/
   1 nsMediaCache::BlockIsReusable(int) http://www.spreadfirefox.com/5years/pt-BR/
   1 nsMediaCache::BlockIsReusable(int) http://www.spreadfirefox.com/5years/pl/
   1 nsMediaCache::BlockIsReusable(int) http://www.pcwelt.de/start/software_os/audio_video_foto/praxis/193783/pc_welttv_fuer_firefox_35/inde
x.html
   1 nsMediaCache::BlockIsReusable(int) http://www.mozilla-europe.org/it/firefox/
   1 nsMediaCache::BlockIsReusable(int) http://tinyvid.tv/show/3c71xf11glwr5
   1 nsMediaCache::BlockIsReusable(int) http://thevideobay.org/play/2689/Agnes+Carlsson+-+Release+Me+-+Official+Video+HQ/
   1 nsMediaCache::BlockIsReusable(int) http://mozillalinks.org/wp/

Updated

10 years ago
Keywords: crashregression, topcrash
Whiteboard: [crashkill]
Roc: I think this should probably block; you?
Yes
Assignee: nobody → roc
Flags: blocking1.9.2? → blocking1.9.2+
Flags: in-litmus?
Probably fixed by the patch in bug 529105.
Whiteboard: [crashkill] → [crashkill][depends on 529105]

Comment 7

10 years ago
this appears to be 2cd ranked most frequent regression crash going from beta1 to beta in some new analysis and reporting we are doing

http://people.mozilla.com/~chofmann/crash-data/new-crashes/new-in-3.6b2-from-35x+36b1.html

does that info sound like it could be correct?

looks like bug 529105 has a patch now.  do we think that patch might need a beta, or is it likely to be pretty safe and easy to confirm?
Marking fixed on trunk due to landing of bug 529105.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Marking fixed on branch due to landing of bug 529105. I hope.
Whiteboard: [crashkill][depends on 529105] → [crashkill]
Verified fixed on the 1.9.2 branch using  Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b4pre) Gecko/20091123 Namoroka/3.6b4pre. Adding keyword. I no longer crash following the STR in Comment 0.
Keywords: verified1.9.2
This is litmus testcase: https://litmus.mozilla.org/show_test.cgi?id=7060
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus+
Crash Signature: [@nsMediaCache::BlockIsReusable(int) ]
You need to log in before you can comment on or make changes to this bug.