When sending mail without specifying a recipient, improve "Send Message Error" so that it's more like a reminder

RESOLVED DUPLICATE of bug 68784

Status

Thunderbird
Message Compose Window
--
trivial
RESOLVED DUPLICATE of bug 68784
8 years ago
5 years ago

People

(Reporter: Thomas D. (currently busy elsewhere), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 412489 [details]
Screenshot: Message boxes (actual vs. expected behaviour)

STR

1 compose msg without recipient
2 Send

Actual behaviour:

Error message:
+----------------------------------------------------------------------------+
| Send Message Error                                                         |
+----------------------------------------------------------------------------+
| Sending of message failed.                                                 |
| No recipients were specified. Please enter a recipient or newsgroup in the |
| addressing area.                                                           |
+----------------------------------------------------------------------------+

This message is very hard to parse, as neither the title nor the first sentence tell you anything useful. At first sight, this creates the wrong impression that the message was actually sent, and something went terribly wrong. The truth is, we didn't even start sending because the user simply forgot to specify a recipient. That's the main message to convey, and it sounds a lot less techie and less dangerous. Furthermore, it's more action-oriented:

Expected behaviour:

"No recipient" reminder:

+----------------------------------------------------------------------------+
| No recipient specified                                                     |
+----------------------------------------------------------------------------+
|  /\  You need to specify a recipient before sending your message.          |
| /! \ Please enter an email recipient or newsgroup in the addressing area.  |
+----------------------------------------------------------------------------+

This provides the most important information already in the title, so even without reading the small print you'll immediately know what to do and why.

I recommend fixing this together with  Bug 68784: When sending mail, should first check "no recipient", then "no subject".
I wonder if we can go one step further and get rid of the whole error box itself by providing some check if there is a receiver to begin with before making it possible to send a message (similar to how it's impossible to outdent a piece of text in the compose area if it's not indented to begin with).
I'd recommend a solution that avoids the dialog about no recipients completely.  I'm not sure why we don't just disable the send button when there are no recipients.  Maybe philor has some perspective.
hmm, we do have bug 431217 and it appears this bug might want to dupe against bug 499137
(Reporter)

Comment 4

5 years ago
-> duping to Bug 68784

Bug 68784 to check recipient before subject was fixed and if there's no recipient will show a better error message as requested in this bug:

Invalid Recipient Address (1)
-------------------------
No recipients were specified. Please enter a recipient or newsgroup in the addressing area. (2)

However, Bug 431217 disabled the send button if there's no recipient, so we are no longer showing an error message at all if there's no recipient, as suggested by Bryan's comment 2.

(1) http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/messenger/messengercompose/composeMsgs.properties#263

263 addressInvalidTitle=Invalid Recipient Address
264 addressInvalid=%1$S is not a valid e-mail address because it is not of the form user@host. You must correct it before sending the e-mail.

(2) http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/messenger/messengercompose/composeMsgs.properties#41

40 ## @name NS_MSG_NO_RECIPIENTS
41 12511=No recipients were specified. Please enter a recipient or newsgroup in the addressing area.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
See Also: → bug 499137
Duplicate of bug: 499137
(Reporter)

Comment 5

5 years ago
Sorry, keyboard lag pasted the wrong bug into the duplicate box...
-> correctly duping against bug 68784
Duplicate of bug: 68784
You need to log in before you can comment on or make changes to this bug.