sent mail text disapears (file size of Sent exceeded 4GB)

VERIFIED DUPLICATE of bug 387502

Status

defect
--
critical
VERIFIED DUPLICATE of bug 387502
10 years ago
9 years ago

People

(Reporter: yael, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(8 attachments)

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: toshiba laptop

the content of sent mails messages in the sent mail folder of the last 4 days just disparres. When I check the sent messages - they are empty. Started today and affected the mails that were sent 4 days ago.

very big problem as I have to keep copies of all my sent mails.


Reproducible: Always

Actual Results:  
i hdo not know - i just have to send an e.mail and in the sent mail folder the text disapeer.

Expected Results:  
recover the mails as they were

behave as it used to.
* Version of thunderbird ?
* Pop/imap ?
Summary: sent mail text dispeers → sent mail text disapears
Reporter

Comment 2

10 years ago
versione 2.0.0.23 (20090812)
POP i guess - if this is regarding the mail server - sorry totaly not an expert just a normal user.
thanks a lot
It's dupe of bug #526476.

yael could attach here 2 screenshots using above "Add an attachment" link?

see this steps:

_screenshot_1_: your sent box folder. Click with mouse right button for show context menu and then click on "properties" item on this menu. In the window that is open select tab "retention policy": capture image and attach here screenshot 1.

_screenshot_2_: select menu-->tools-->account settings. Go to account that has this problem and select tab "disk space" capture image and attach here screenshot 2.
Reporter

Comment 4

10 years ago
Thank you all so much - will send snapshots tommorow morning (:-)
Reporter

Comment 5

10 years ago
screenshot 1 - as requested by ulysse
Reporter

Comment 6

10 years ago
Ciao yael.

Attach also a screenshot of disk space on your local folders ("cartelle locali") because your account store messages on local folders. ;-)
Reporter

Comment 8

10 years ago
Grazie Ulysse
I might have a problem with the space but I have a lot of e mails with foto's and drawings and NEED to be able to find them.
Reporter

Comment 9

10 years ago
Posted image 20 G mails
I know I have 20G of mails (:-)
(In reply to comment #9)
> Created an attachment (id=413303) [details]
> 20 G mails
> 
> I know I have 20G of mails (:-)
Retention policy is right.
Should be a "corrupted" profile. Try with this steps:
0. close TB
1. goto your profile folder (see http://kb.mozillazine.org/Profile_folder_-_Thunderbird );
2. find folder Mail\Local Folders
3. in this folder search *Sent.msf* and delete it. Restart TB.

This help you?

*n.b.*: you should manage profile folder with care: it is reccomanded (if you are newbie) to backup profile first (see http://www.mozilla.org/support/thunderbird/profile )
Reporter

Comment 11

10 years ago
Hi
The problem is not solved - still the messages in the sent mail folder are totaly empty even if the text is received by who ever I write the e-mails to.
grazie - yael
Ops... probably I read wrongly: your problem is that you have (for example) mail [A] in sent box, but the mail [A] body is empty or that mail [A] is vanished?
If your case is the first, please yael could attach here one of this strange emails using above "Add an attachment" link?
Reporter

Comment 13

10 years ago
Posted file empty e mail
:-o
If this is your real mail (you don't have edit source with editor, right?) it is very strange.
It seems that source has only one "attached" part... have you any antivirus installed? Could see if AV has quarantined anything?
Reporter

Comment 15

10 years ago
Posted file not empty e mail
hi
i have attached the empty mail how it is in my sent mail folder and the mail how it should ( sent it to my self so i have the copies at least)

I tried : have put all the problematic email in a folder and in proprieta cartella ricostruisci indici (folder propreties->riconstrut index)all the problematic e-mail disapeerd and now that folder is empty - maybe this can help
Reporter

Comment 16

10 years ago
I do not have a quarantine with my antivirus - I use Avast
sorry but i do not understand: you don't have edit source with editor, right? but i presum not (:-)
grazie
(In reply to comment #16)
> sorry but i do not understand: you don't have edit source with editor, right?
> but i presum not (:-)
Ok too me :-)

It happens also when you disable avast?
Reporter

Comment 18

10 years ago
yes it happens also when i disable avast
Keywords: dataloss
Reporter

Comment 19

10 years ago
if i send e mails with attachments - this is how they appear in the sent mail folder. The attahments is not ther any more.
Reporter

Comment 20

10 years ago
Posted file empty incoming mail
atached an incoming mail - empty as the sent ones. In another html mail - TB sais it cannot open html. It is getting worth everyday (:(
(In reply to comment #9)
> 20 G mails
> I know I have 20G of mails (:-)

Check file size of sent folder. At Command Prompt.
  C:
  CD C:\Document...\...\...\Local Folders
  DIR /S > C:\DIR-LIST.TXT
  notepad.exe C:\DIR-LIST.TXT
What is file size of "Sent"? (not "Sent.msf")
Reporter

Comment 22

10 years ago
hi 
23/11/2009  12.12     4.353.925.811 Sent
23/11/2009  12.16     2.995.338 Sent.msf
(In reply to comment #22)
> 23/11/2009  12.12     4.353.925.811 Sent

Larger than 4GB(2**32, 4294967296). DUP of bug 387502.
Once file size excceds 4GB due to bug 387502, Tb can't manupilate it as mail folder normally. You need to split the file to two unix mbox files smaller than 4GB in order to recover your sent mail data. Keep backup of "Sent" file ASAP.
(In reply to comment #25)
> Once file size excceds 4GB due to bug 387502, Tb can't manupilate it as mail
> folder normally. You need to split the file to two unix mbox files smaller than
> 4GB in order to recover your sent mail data. Keep backup of "Sent" file ASAP.
And when you update to TB 3.x you can use Archives features to create subsets of your mailboxes based to on year that you have received or sent.

Let us know your opinion yael.
Reporter

Comment 27

10 years ago
Thanks - How do I split the sent file in 2 mbox files ? and where do i find TB 3 ? - I found only beta realeses.- grazie
(In reply to comment #27)
> How do I split the sent file in 2 mbox files?

Tools for "Unix Mbox file", or simple script, which reads the greater than 4GB file and writes mail data(separated by "From ..." line) to files smaller than 4GB, will be required. (Search Google for "Unix Mbox", please.)
Summary: sent mail text disapears → sent mail text disapears (file size of Sent exceeded 4GB)
(In reply to comment #23)
> (In reply to comment #22)
> > 23/11/2009  12.12     4.353.925.811 Sent
> 
> Larger than 4GB(2**32, 4294967296). DUP of bug 387502.

Duping.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: tb-4gb
v.dup

see also 
http://kb.mozillazine.org/Edit_large_mbox_files
http://kb.mozillazine.org/Limits_-_Thunderbird#Folders_and_messages
Severity: major → critical
Status: RESOLVED → VERIFIED
Version: unspecified → 2.0
You need to log in before you can comment on or make changes to this bug.