Closed Bug 530504 Opened 12 years ago Closed 9 years ago

Mouse wheel scrolling interferes with action popup in applications tab of preferences

Categories

(Firefox :: Preferences, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- -

People

(Reporter: eyalgruss, Assigned: enndeakin)

Details

Attachments

(2 files, 2 obsolete files)

goto options->applications->mailto and open the action pulldown menu.
you can highlight the various options moving your mouse pointer
now scroll with the mouse scroll wheel, this interferes with the highlighting until you scroll back to the original position
Please always give more information when you are using the advanced bug filing page. We miss the version number and especially information if this is a regression. Can you please add those information? Thanks.
sorry,

this happens on both 3.6b3 and 3.7a1pre (clean profile). i do not have an older version to check for regression.
Can you please check in a 3.5.5 or 3.5.6pre build? Unzipping those builds is not a big deal and will help us a lot. For build information please always post the whole user agent string with the build id which included the date information of that build.
yup this happens also on 3.5.5.
these are my builds:

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3 (.NET CLR 3.5.30729)

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091121 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Can we use the mouse wheel scrolling event to step through the items inside the action popup instead of scrolling the whole list?
Component: Menus → Preferences
QA Contact: menus → preferences
Summary: scrolling interferes with mouse highlighting in options->applications->action → Mouse wheel scrolling interferes with action popup in applications tab of preferences
mousewheel events should probably just not propagate outside of menus and popups.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #419744 - Flags: review?(neil)
Comment on attachment 419744 [details] [diff] [review]
add preventdefault for mouse scroll on menulist, also adds a general menulist test

I'm not quite sure what this is supposed to achieve - it depends on the mouse being over the menulist, and it doesn't depend on the menulist being open.
Hmmm, not really sure what heuristic we want here.
Attachment #419744 - Flags: review?(neil)
Comment on attachment 419744 [details] [diff] [review]
add preventdefault for mouse scroll on menulist, also adds a general menulist test

I'll let you think about it then ;-)
Attached patch updated patch (obsolete) — Splinter Review
Changed to check if the popup is open first. I don't think the mouse position affects the outcome should it?

The test also adds a check for bug 543065 which I discovered while working on this.
Attachment #424606 - Flags: review?(neil)
Comment on attachment 424606 [details] [diff] [review]
updated patch

It looks as if this doesn't actually work because the listbox not only captures DOMMouseScroll but ignores preventDefault anyway.
Attachment #424606 - Flags: review?(neil) → review-
I'm not sure if there is still an issue here. The menulist in Application preferences works fine, and a menulist in a listbox works fine. I don't see any issues with this wherever the mouse pointer is located.
Attachment #419744 - Attachment is obsolete: true
Attachment #424606 - Attachment is obsolete: true
Attachment #427617 - Flags: review?(neil)
i just found  Bug 515979 , is this a duplicate?
Comment on attachment 427617 [details] [diff] [review]
change listbox.xml and add a menulist in a listbox test

Curiouser and curiouser. The big problem with your test is that the menulist dwarfs the listbox, so it is practically impossible to scroll it when the menulist is open. I found the best way to demonstrate the problem was to have the menulist as the fifth of at least 9 rows in the listbox, using rows="5" rather than a height. (Also I have no idea what the overflow style is supposed to achieve). In fact under these conditions I didn't seem to have any useful control over the scrolling; sometimes the listbox would just scroll of its own accord, while scrolling with the mousewheel was a hit-and miss affair whether or not the mouse was over the popup. (While over the menulist itself the scrolling was inhibited as expected.) This rather detracted from the demonstration of the incorrect hit-testing for the hovered popup item.
(In reply to comment #15)
> sometimes the listbox would just scroll of its own
> accord

Have you tested this with the patch for bug 543065?
Steps to reproduce problem:
1. Scroll the listbox so that the menulist is the first visible row.
2. Open the popup. Make a mental note of where each menuitem appears.
3. Close the popup, and scroll the listbox back up.
4. Open the popup, and use the scroll wheel to scroll the listbox back down.
5. Hover over where the menuitems would have been, and note the hover effect.
Attachment #427617 - Flags: review?(neil) → review-
(In reply to comment #17)
> Steps to reproduce problem:
> 1. Scroll the listbox so that the menulist is the first visible row.
> 2. Open the popup. Make a mental note of where each menuitem appears.
> 3. Close the popup, and scroll the listbox back up.
> 4. Open the popup, and use the scroll wheel to scroll the listbox back down.
> 5. Hover over where the menuitems would have been, and note the hover effect.

I don't see this problem. I'm not able to scroll the listbox while the menulist is open in step 4.
I think that's a platform-specific difference. On Windows we allow mouse wheel events on windows behind a popup, on Mac we block them.
That seems(In reply to comment #19)
> I think that's a platform-specific difference. On Windows we allow mouse wheel
> events on windows behind a popup, on Mac we block them.

That seems like a bug then, or is this specific to XP? On other applications on Windows 7, wheel scrolling can only occur if the control is focused.
I don't have ready access to Windows 7 but I've tried W2K XP and Vista and they all allow me to scroll the listbox while the menulist popup is showing.
(In reply to comment #21)
> I don't have ready access to Windows 7 but I've tried W2K XP and Vista and they
> all allow me to scroll the listbox while the menulist popup is showing.

Which listbox is this?

Are you referring to your testcase? I don't see that problem with the patch applied.
blocking2.0: --- → ?
This seems a narrow case of annoyance in secondary UI, not something we'd hold the release for. Can whoever asked for blocking explain why it's so dire, and re-request?
blocking2.0: ? → -
it just looks broken
Could my just-filed Bug 632938 be a dupe of this bug?
Duplicate of this bug: 515979
there is a patch for this at bug 515979
Neil, does the patch in bug 515979 fix the problem you were seeing (comment 17)?

If so, would that patch or both that and the one in this bug be suitable to fix this?
nice
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.