Closed Bug 543065 Opened 12 years ago Closed 12 years ago

menulist hover causes scroll on parent

Categories

(Core :: XUL, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: enndeakin, Assigned: enndeakin)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached file testcase
The attached test has a menulist inside a scrollable container.

1. Open the menulist
2. Move and hover over each item
3. Instead of highlighting the item, the parent area scrolls
Attached patch only scroll one level (obsolete) — Splinter Review
The popup should already be visible so only scroll one level.

I'll include a test as part of bug 530504 where I discovered the bug in testing.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #424281 - Flags: review?(roc)
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100220112323
Status: RESOLVED → VERIFIED
Backed this out again due to regression bug 548011.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Depends on: 548011
It seems that the SCROLL_FIRST_ANCESTOR_ONLY should stop at the first scrollable container, not just the first parent.
Attachment #424281 - Attachment is obsolete: true
Attachment #428804 - Flags: review?(roc)
http://hg.mozilla.org/mozilla-central/rev/ea63501d0e62
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100303 Minefield/3.7a3pre
Status: RESOLVED → VERIFIED
Duplicate of this bug: 549985
Duplicate of this bug: 543650
Component: XP Toolkit/Widgets: Menus → XUL
You need to log in before you can comment on or make changes to this bug.