Closed Bug 530545 Opened 10 years ago Closed 10 years ago

Ctrl+Cursor Down Keyboard Shortcut for showing Lightning's Today tab breaks message list selection of multiple messages

Categories

(Calendar :: Lightning Only, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 427403

People

(Reporter: bugzilla2007, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access)

It's unfortunate, but we definitely can't use Ctrl+Cursor Down to open up Lightning's today tab, because we're breaking keyboard selection of multiple messages, which is a "major" problem in terms of accessibility.

STR

1a without Lightning installed
1b with Lightning installed
2 click on 1st message of msg list in tb main screen
3 hold Ctrl key for keyboard selection of multiple messages that aren't in a row (say 1st, 3rd and 5th message of the list), press cursor down to move focus for selection of non-neighbouring messages (with space bar)

Actual
1a without Lightning: correct behaviour (focus moves down the list, can select the msgs)
1b with Lightning: Today tab will open -> can't select other msgs (the bug)

Expected
1a move focus down the list to select multiple non-neighbouring msgs
1b move focus down the list to select multiple non-neighbouring msgs

We should help Lightning find a better shortcut for this.
Lightning should help us do so by providing a list of its shortcuts (in the making).

Brainstorming ideas for alternative shortcuts:

What we could use:

a) Alt+END: actually, that might be pretty cool as we'd have
Alt+HOME for Mail start page, and
Alt+END for Calendar start page (Lightning's Today tab)
Easy to remember, and right below each other on desktop keyboards. Btw, TB has alt+home because FF has alt+home...

b) Alt+Cursor right/left: currently unused

What we shouldn't use / can't use
- Ctrl+cursor up (same problem as described in this bug)
- Ctrl+page up/down (same problem, perhaps a little less severe; TB has a bug here as it doesn't move focus, right behaviour e.g. in Windows XP explorer)
- Ctrl+cursor left/right (should switch between tabs although it doesn't right now)
- anything Ctrl+Shift+Movement keys (also needed for list selection)
- Ctrl+Home/End (keyboard navigation)
perhaps this bug should have a better "version" than unspecified, please set
Keywords: access
Flags: blocking-calendar1.0?
Summary: [accessibility] Ctrl+Cursor Down Keyboard Shortcut for showing Lightning's Today tab breaks message list selection of multiple messages → Ctrl+Cursor Down Keyboard Shortcut for showing Lightning's Today tab breaks message list selection of multiple messages
What is the difference to Bug 427403?
(In reply to comment #0)
> Shortcuts we can't use
> - Ctrl+page up/down (same problem, perhaps a little less severe; TB has a bug
> here as it doesn't move focus, right behaviour e.g. in Windows XP explorer)
> - Ctrl+cursor left/right (should switch between tabs although it doesn't right
> now)
Oh, TB uses Ctrl+page up/down for switching between tabs, as does FF. I guess that's alright...
(In reply to comment #2)
> What is the difference to Bug 427403?

Doh. None!

Except that bug 427403 's summary wasn't good enough to find it,
AND this one is more systematically exploring alternatives ;)
AND it's hard to believe that such a major accessibility breaker could survive longer than a couple of months (bug 427403 is from April 2008 which is currently 1 1/2 years ago)

Duping.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 427403
Flags: blocking-calendar1.0?
You need to log in before you can comment on or make changes to this bug.