Closed Bug 427403 Opened 13 years ago Closed 10 years ago

CTRL+Cursor Down for selecting multiple items from a list of Mail messages or Tasks loses focus (need new keyboard shortcut for Lightning's Today tab)

Categories

(Calendar :: Lightning Only, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Grrubin, Assigned: mmecca)

References

Details

(Keywords: access, polish, Whiteboard: [not needed beta][has l10n impact])

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: 2008033120

When the keys CTRL and Down are pressed together, the view switches to the Calendar view.  This is a problem because they are commonly used for multi-select functionality in the email lists.  Ctrl+Up still demonstrates the correct behavior.

Reproducible: Always

Steps to Reproduce:
0. Go to the E-mail view in Thunderbird
1. Go to an email folder with multiple emails.
2. Select any email except for the last
3. Hold down the Ctrl key
4. Press the down arrow.
Actual Results:  
The view switched to the Calendar.

Expected Results:  
The next email in the list should have been highlighted (but not selected) so that the user has the option to either select it (by pressing the space key) or continue on to the next (by pressing the CTRL key).
Confirmed. Currently, Ctrl+VK_DOWN seems to be "go to today":

<key oncommand="goToDate(now())" id="go_to_today_key" keycode="VK_DOWN"
     observes="calendar_go_to_today_command" modifiers="accel"/>

Christian, any preference of the new key to use for go to today?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Ctrl+Up and Ctrl+Down have been used for Go To Date and Go To Today in Sunbird since years and I'd prefer if they stay. For Lightning they should be only active if the main calendar view is focused.
That makes sense to me as well.  UI consistency is important.  We just need to maintain it in both Mail and Calendar modes.
Confirmed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080213 Lightning/0.8 Thunderbird/2.0.0.12 ID:2008021305
Stefan, I see your reasoning, but this combination isn't a good choice, even in the calendar view or sunbird. While it is much less annoying in calendar view or sunbird, pressing ctrl+down in the unifinder to try to select more than one row, causes the calendar to refresh and the focus to be lost.
(In reply to comment #5)
Different issue. Selecting an event in unifinder (either mouse or keyboard) will always move the focus to the calendar view (Bug 348481).
Summary: CTRL+Down switches to calendar view → CTRL+Down in Mail or Task Mode switches to Calendar Mode
Are we going to have to wait for 0.9 for this to be fixed, or is there a way to override this shortcut in the short term? I can't seem to find any documentation on changing keyboard shortcuts...
This is an absolutely horrid default - holding ctrl and using up/down arrows to move between items in a list (like the list of emails in a mailbox) to select multiple (using space) is a very common task, and having it suddenly interrupted to switch to mail is extremely bad.

If these must remain, I would argue they absolutely must be made optional, as this is a huge break from standard application behavior everywhere else.
Hmm, I seem to have misread an earlier comment - Stefan's solution in comment 2 would be great, having the hotkey only be active when you're in calendar mode, as then mail functionality is left untouched in this case.
Confirmed and agreed Stefan Sitter's suggestion (comment 2)
Duplicate of this bug: 448294
ok, as of 0.8 or 0.9, CTRL-Down no longer "switches" to calendar, but still does NOTHING anymore. Therefore this shortcut seems to be broken.
Was really disappointed to find that this wasn't fixed. It seems minor, but it's incredibly frustrating. Also makes it feel unpolished.
Any chance on getting this fixed for the next release? This makes selecting emails with the keyboard simply horrible and a huge regression over regular Thunderbird usage.
Flags: tb-integration?
Flags: blocking-calendar1.0?
Summary: CTRL+Down in Mail or Task Mode switches to Calendar Mode → CTRL+Down selecting item from a list in Mail or Task tab looses focus
Actually, I much prefer that Pg-Up/Down change between tabs, as it currently does. The functionality for selecting messages via Ctrl+Pg-Up/down can be achieved via the arrows. Maybe this isn't my use case, but why do people need to select the entire page of emails simultaneously?
I think you've misunderstood. This bug is about the down arrow, not page down.
Ha. Indeed. Pretend like I don't exist.
Duplicate of this bug: 530545
This is a major problem for accessibility, and should block. Also, more than 1 1/2 after the fact, it should be FIXED.

From duplicate bug 530545:

We should help Lightning find a better shortcut for this.
Lightning should help us do so by providing a list of its shortcuts (in the
making).

Brainstorming ideas for alternative shortcuts:

*** What we could use:

a) Alt+END: actually, that might be pretty cool as we'd have
Alt+HOME for Mail start page, and
Alt+END for Calendar start page (Lightning's Today tab)
Easy to remember, and right below each other on desktop keyboards. Btw, TB has
alt+home because FF has alt+home...

b) Alt+Cursor right/left: currently unused


*** What we shouldn't use / can't use

- Ctrl+cursor up (same problem as described in this bug)
- Ctrl+page up/down (same problem, perhaps a little less severe; TB has a bug
here as it doesn't move focus, right behaviour e.g. in Windows XP explorer)
- Ctrl+cursor left/right (should switch between tabs although it doesn't right
now)
- anything Ctrl+Shift+Movement keys (also needed for list selection)
- Ctrl+Home/End (keyboard navigation)
Severity: normal → major
Keywords: access
Summary: CTRL+Down selecting item from a list in Mail or Task tab looses focus → CTRL+Cursor Down for selecting multiple items from a list of Mail messages or Tasks tab loses focus (need new keyboard shortcut for Lightning's Today tab)
Summary: CTRL+Cursor Down for selecting multiple items from a list of Mail messages or Tasks tab loses focus (need new keyboard shortcut for Lightning's Today tab) → CTRL+Cursor Down for selecting multiple items from a list of Mail messages or Tasks loses focus (need new keyboard shortcut for Lightning's Today tab)
OS: Windows XP → All
Hardware: x86 → All
(In reply to comment #19)
> We should help Lightning find a better shortcut for this.


Lightning already has Ctrl+Shift+C to shift to/open the calendar view, which TB had to give up to make available to them, causing some amount of grumbling when we had to learn a new key to Mark Folder Read.

Once on the Calendar view, using Ctrl+Down to shift the date to Today is fine if that's what they want to use.  (IMO Ctrl+Home would be more intuitive.)  It is not acceptable to grab that keystroke globally, however.
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Whiteboard: [not needed beta][has l10n impact]
This is really not nice, just to make it painstakingly clear: This bug represents a remap of OS default key usage for windows. This has been a default selection method for ages (win95, probably 3.1 and pre?) and works across all applications - except absurd ones, like thunderbird? Big vote for this.
Is there a workaround? Can I remap in a file somewhere? That would be great.
Assignee: nobody → matthew.mecca
Changes calendar_go_to_today_command to observe calendar_mode_calendar to prevent firing command on other tabs. This should preserve the calendar view behavior without interfering with the mail or task view tabs.
Attachment #454397 - Flags: review?(philipp)
Status: NEW → ASSIGNED
Comment on attachment 454397 [details] [diff] [review]
Restrict calendar_go_to_today_command to calendar tab

This probably won't work out the way we want it to. In the Thunderbird "Go" menu, there is an entry to go to today, which should switch to the calendar tab and show today's date.

If we take this fix, it will only be enabled in calendar mode which makes it a little less useful. It would be nice to know how many people actually use this sort of key combination to go to today. Maybe we can just get rid of the key combination instead?
Attachment #454397 - Flags: review?(philipp) → review-
Removes the key from the menu command, adds a new key specific to calendar mode.
Attachment #454397 - Attachment is obsolete: true
Attachment #472105 - Flags: review?(philipp)
Matthew, this does fix it for mail mode and I'd be ok with taking this patch. The issue still kind of remains though: in calendar mode, in the unifinder, Ctrl+Down still goes to today. 

I think in the long run we're going to need a new shortcut and I'd rather take a patch with a new shortcut. Matthew, what do you think?
Comment on attachment 472105 [details] [diff] [review]
Move key from global menu to calendar mode

r+ codewise, awaiting reply to previous comment.
Attachment #472105 - Flags: review?(philipp) → review+
I agree, this key combination's not going to work. Maybe Ctrl+T would be a good alternative? Philipp, do you think this should replace the original global key, or stay specific to the calendar mode to prevent future key conflicts? Or do you think the shortcut should just be dropped completely?
Comment on attachment 472105 [details] [diff] [review]
Move key from global menu to calendar mode

I'm not quite sure, lets have a ui-expert reply to the previous comment.

Pro Global Hotkey:
* This gives an easy way to go to today from any tab.
* We can show the hotkey in the "Go" Menu.
* If the hotkey is not global, then people might not know of it since its not mentioned everywhere.

Con:
* The Hotkey might be taken by Thunderbird or a different extension in the future
* Ctrl+Shift+C and then a non-global hotkey might be sufficient

Personally I don't think I've ever used the Go-To-Today key, but that doesn't mean a thing.

(Note: andreasn, this feedback is rather on the comments than on the patch)
Attachment #472105 - Flags: feedback?(nisses.mail)
Philipp, any chance to get a keyboard shortcut list of lightning published somewhere?

(In reply to comment #28)
> I agree, this key combination's not going to work. Maybe Ctrl+T would be a good
> alternative?

Probably not. Definitely not if you want Ctrl+T as a global Shortcut (because of Bug 458069).

> do you think this should replace the original global key,
> or stay specific to the calendar mode to prevent future key conflicts? Or do
> you think the shortcut should just be dropped completely?

Global would be fine if we can find one that is unlikely to be taken by TB itself. Like ALT+END which I proposed in comment 19. It might look odd at first, but has several advantages:

> a) Alt+END: actually, that might be pretty cool as we'd have
> Alt+HOME for Mail start page, and
> Alt+END for Calendar start page (Lightning's Today tab)
> Easy to remember, and right below each other on desktop keyboards.
> Btw, TB has alt+home because FF has alt+home...

Otherwise, perhaps ALT+Shift+HOME?
- advantage: similar/derived from ALT+HOME for mail start page
- disadvantage: 3-key-shortcut
- is it taken for anything else?
If I would have to decide, I'd use Alt+END. But remember I've never used this shortcut, so I may not be the best person to decide on this ;-) I'll leave the rest to andreasn.

(In reply to comment #30)
> Philipp, any chance to get a keyboard shortcut list of lightning published
> somewhere?
We should do this on devmo, it shouldn't be too much work. Could you file a website bug and mention that I'd like to see this on devmo?
> > Philipp, any chance to get a keyboard shortcut list of lightning published
> > somewhere?
> We should do this on devmo, it shouldn't be too much work. Could you file a
> website bug and mention that I'd like to see this on devmo?

Actually, its rather a support issue, so better put it on the mozilla messaging KB.
Attached patch Change key to Alt+END (obsolete) β€” β€” Splinter Review
I think Alt+End makes the most sense here.
Attachment #472105 - Attachment is obsolete: true
Attachment #480554 - Flags: ui-review?(nisses.mail)
Attachment #480554 - Flags: review?(philipp)
Attachment #472105 - Flags: feedback?(nisses.mail)
Comment on attachment 480554 [details] [diff] [review]
Change key to Alt+END

Codewise r+, lets wait for ui-review.
Attachment #480554 - Flags: review?(philipp) → review+
(In reply to comment #29)
> * Ctrl+Shift+C and then a non-global hotkey might be sufficient

From a consistency point of view this would make sense. "Mail start page" is grayed out from Calendar, so it makes sense for things to be the same the other way around as well. So, in favor of a non-global hotkey. Ctrl+home feels more natural than ctrl+end, but that could work too.
(In reply to comment #35)
> From a consistency point of view this would make sense. "Mail start page" is
> grayed out from Calendar, so it makes sense for things to be the same the 
> other way around as well. So, in favor of a non-global hotkey. 

Just to clarify, do you mean disabling the Go -> Today menu item entirely outside of the calendar tab (Philipp was against this in comment #24)? Or leave the menu item as is, with a keyboard shortcut only being available on the calendar tab?

> Ctrl+home feels more natural than ctrl+end, but that could work too.

While probably less commonly used, I think Ctrl+Home and Ctrl+End would have the same conflict with keyboard navigation in the unifinder. Do you agree Alt+End would be better?
(In reply to comment #36)
> (In reply to comment #35)
> > From a consistency point of view this would make sense. "Mail start page" is
> > grayed out from Calendar, so it makes sense for things to be the same the 
> > other way around as well. So, in favor of a non-global hotkey. 
> 
> Just to clarify, do you mean disabling the Go -> Today menu item entirely
> outside of the calendar tab (Philipp was against this in comment #24)? Or leave
> the menu item as is, with a keyboard shortcut only being available on the
> calendar tab?

Yes, especially if we want to act in a similar way to the "Mail start page" menu item, and I think that's a good thing. Having it globaly accessible would indeed make it quicker to go there from anywhere (ux-efficiency - see http://spreadsheets.google.com/pub?key=tJxF8zTuLdEj9pUcxnLAemA&output=html)
At the same time it could end up in more wtf-moments if people access it accidentally from the mail view, say if you want to access the mail start page and press the wrong buttons (ux-error-prevention) and I feel it's slightly odd from a natural mapping point of view to be able to access it from the mail view (ux-natural-mapping).
Coming back to the efficiency argument, doing a quick ctrl+shift+c and then ctrl+home would achieve the same thing for the keyboard heavy users without too much extra labor.

> 
> > Ctrl+home feels more natural than ctrl+end, but that could work too.
> 
> While probably less commonly used, I think Ctrl+Home and Ctrl+End would have
> the same conflict with keyboard navigation in the unifinder. Do you agree
> Alt+End would be better?
If it's not taken, sure. Alt+home is used by the "mail start page", so an alt-combo would be consistent with that.
1) Let's not make this more complex as it actually is.
2) And let's not get confused about those ux-terms.
3) And let's not violate default/standard/good practice keyboard interaction
4) Let's not for a wrong understanding of consistency add extra steps when the same action can be had with less steps

1) Let's not try all of those ux-terms as we have already heard professionals elsewhere saying that while their original intention certainly has value and adds some illustration of good ux, their actual usability is doubtful (for a start, there are too many of them)

2) ux-error-prevention certainly doesn't mean we can't use alt+end for the calendar start page (today tab) just because some people who actually need to press alt+home for the mail start page might accidentally press alt+end instead. If at all, it works the other way round: if alt+end is too unintuitive, people might try alt+home for the calendar start page and end up wrongly. Let's make no mistake: the number of shortcuts is limited, we (lightning) are an addon to a full-fledged application, and so we can't have the shortcuts we might want to have in an ideal world. Let's be honest: Learn your shortcut, or leave it. With Alt+END, we would actually do a very good job in making it memorizable by aligning it to the alt+home shortcut that's known for the mail start page.

3) Ctrl+Home is NOT available, as it is used for keyboard navigation/selection within lists such as the tasks list. We'd only be reproducing another variant of this bug, as pointed out in previous comments.

4) Forcing people into extra steps by deliberately disabling a viable and sensible lightning shortcut within TB is a very dubious understanding of consistency. Again, it works the other way round: both alt+home and alt+end should be available as global shortcuts from whatever tab we are on. We have a bug for the alt+home part of that: Bug 530558  - Alt+Home and "Go > Mail start page" should work from all tabs (faceted search results, thread pane results, Lightning etc.). There hasn't been a negative response from developers on that one. On the contrary, from painful experience I have reason to believe that Bryan will actually prefer focus-ignorant, i.e. context-insensitive global shortcuts over focus-respecting, context-sensitive local shortcuts.

Alt+END does seem to be good choice both as global and local shortcut for the calendar start page alias today tab, unless we'd want it for a calendar start page that actually shows online information about lightning.
Philipp, Andreas: if you agree, maybe we can disable the menu item per Andreas' comments, and file a followup bug dependent on the Bug 530558 Thomas D. mentioned to reevaluate this if Thunderbird changes the Mail Start Page menu behavior.
Changes key to Alt+End, disables command outside Calendar tab
Attachment #480554 - Attachment is obsolete: true
Attachment #483058 - Flags: ui-review?(nisses.mail)
Attachment #483058 - Flags: review?(philipp)
Attachment #480554 - Flags: ui-review?(nisses.mail)
(In reply to comment #39)
> Philipp, Andreas: if you agree, maybe we can disable the menu item per Andreas'
> comments, and file a followup bug dependent on the Bug 530558 Thomas D.
> mentioned to reevaluate this if Thunderbird changes the Mail Start Page menu
> behavior.

Yes, that sounds like a good idea. I'm not married to the idea of globally disabling it in any way, but lets do that for now at least.
Oh, this is fun. Either the patch isn't working properly, or my local build is behaving odd in some way, because it don't jump to the right day properly.
My mac build on the other hand refuses to build at all :)
Comment on attachment 483058 [details] [diff] [review]
Change key to Alt+END, Calendar tab only

Andreas, are you still having these issues? The patch works fine for me and its code looks fine too.

r=philipp
Attachment #483058 - Flags: review?(philipp) → review+
Comment on attachment 483058 [details] [diff] [review]
Change key to Alt+END, Calendar tab only

I'm going to assume ui-r+ based on comment 41. Andreas, please let me know if this does not match your opinion.
Attachment #483058 - Flags: ui-review?(nisses.mail) → ui-review+
Flags: tb-integration?
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/873e68c06d96>
-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
Backported to comm-1.9.2 <http://hg.mozilla.org/releases/comm-1.9.2/rev/3b1a758259ce>
a=philipp
Target Milestone: Trunk → 1.0b3
You need to log in before you can comment on or make changes to this bug.