Closed Bug 531244 Opened 11 years ago Closed 8 years ago

Growl doesn't show notifications when messages are filtered to subfolders

Categories

(Thunderbird :: OS Integration, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: davide.ficano, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; it; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: 

I use mail filters to *move* messages to folders, but when filters take action no growl notification appears.

If I disable filters and email go to standard root folder Growl works fine.

Reproducible: Always

Steps to Reproduce:
1. Create a filter for emails that moves to a specified subfolder
2. Move focus to an application different from Thunderbid
3. Wait a message to be filter arrive
Actual Results:  
The growl notification doesn't appear

Expected Results:  
The growl notification must appear as it already does when mails arrive to default root folder 

This problem occurs also on Linux so I think it is related to filters
Component: General → OS Integration
QA Contact: general → os-integration
(In reply to comment #0)
> I use mail filters to *move* messages to folders, but when filters take action
> no growl notification appears.

Where are you moving the messages to/from? IMAP -> IMAP, POP -> POP, IMAP -> Local Folders etc?
(In reply to comment #1)
> (In reply to comment #0)
> > I use mail filters to *move* messages to folders, but when filters take action
> > no growl notification appears.
> 
> Where are you moving the messages to/from? IMAP -> IMAP, POP -> POP, IMAP ->
> Local Folders etc?

I use only POP.

Move from POP to Local Folders.
I am having what seems like the same problem, but with IMAP->Local Folders.  

Mail that is sent by a filter to a folder in Local Folders does not trigger a Growl alert.  Mail that remains in the IMAP Inbox folder does.
I am having the same frustration. Growl notification worked fine for filtered messages in Thunderbird 2 but no longer seems to in Thunderbird 3.

I use POP filters based on to: and cc: fields. No filtered messages are notified via Growl and since all my incoming POP messages are sorted into subfolders, only IMAP messages are notified.
Growl used to work in TB 2 and even in TB 3 until I deleted the Growl extensions, that should be unnecessary, as Growl notifications are included in the main code.

Now I can't get it to work again, even after re-installing Growl Notifications 1.0.2 and   Growl New Message Notification with extensions.checkCompatibility set to off (because they aren't compatible with TB 3).
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Grow New Message Notification in it's newest versions 0.4.0&1 now supports Thunderbird 3 (at least the current 3.1.1) without changing extensions.checkCompatibility.
I am having the same problem with TB 3.1.6 and Growl 1.2.1 on my Mac Pro Quad-Core Snow Leopard 10.6.4.  Any messages that are in subfolders do not trigger Growl notification.
Duplicate of this bug: 544641
Duplicate of this bug: 624643
Still having same issue with Thunderbird 7.0.1 and Growl 1.2.2 on OS X 10.6.8
Blocks: biff
Sorry, Growl support has been removed from the current versions.

Mass bug change. Please reopen if you disagree.
Status: NEW → RESOLVED
Closed: 8 years ago
Depends on: 792793
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.