Last Comment Bug 533201 - Cannot adjust volume for <audio> element
: Cannot adjust volume for <audio> element
Status: RESOLVED DUPLICATE of bug 502892
: polish, testcase, ux-control
Product: Toolkit
Classification: Components
Component: Video/Audio Controls (show other bugs)
: 1.9.2 Branch
: All All
: -- major with 12 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 534572 587269 638961 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-06 14:30 PST by Tim Babych
Modified: 2013-06-20 11:25 PDT (History)
31 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.x+


Attachments
testcase (158 bytes, text/html)
2010-06-17 00:59 PDT, j.j.
no flags Details

Description Tim Babych 2009-12-06 14:30:57 PST
when I hover on volume icon the slider appears. But when I try to reach for it with the mouse - the slider disappears.

AUDIO element is not that tall as VIDEO is, and mouse has to leave it to grab and drag the slider. And that is the moment slider disappears, making it useless.

See http://tymofiy.livejournal.com/149235.html
Comment 1 Tim (fmdeveloper) 2009-12-07 00:29:31 PST

*** This bug has been marked as a duplicate of bug 502892 ***
Comment 2 Dão Gottwald [:dao] 2010-02-03 07:21:33 PST
Bug 502892 comment 0 says: "The volume change is still working - moving the mouse up and down still changes the volume of the audio."

As far as I can see, this is not the case here.
Comment 3 Ben Bucksch (:BenB) 2010-02-17 08:16:53 PST
Does it work for <video> for you?
Comment 4 84user 2010-03-28 18:06:55 PDT
I can reproduce this problem in Firefox 3.6.2, for audio OGG files both local and embedded in web pages, and also small videos. Moving the mouse up and down does not change the volume. See my notes at http://en.wikipedia.org/wiki/Wikipedia:Village_pump_%28technical%29#Volume_stuck_with_OGG and http://en.wikipedia.org/wiki/Template_talk:Listen#Volume_stuck_with_OGG 

What sometimes works is the up and down arrow keys will control the volume.
Comment 5 j.j. 2010-06-17 00:52:48 PDT
*** Bug 534572 has been marked as a duplicate of this bug. ***
Comment 6 j.j. 2010-06-17 00:57:45 PDT
We should have basically working audio controls, really! (Request blocking)
Comment 7 j.j. 2010-06-17 00:59:03 PDT
Created attachment 451883 [details]
testcase

Try to adjust volume
Comment 8 Loïc Grobol 2010-06-23 07:05:11 PDT
Hi, there
I have the same issue, and I can't adjust volume on the testcase.
Comment 9 Justin Dolske [:Dolske] 2010-07-20 23:37:36 PDT
Not sure what happened here, adjusting volume on <audio> used to work, so this is likely a regression.
Comment 10 vondemleschker@hotmail.com 2010-07-25 03:22:56 PDT
Veryfying, volumecontrol doesn't work. this Bug is just ridiculous, somebody should fix this, such basic things should work...
Comment 11 Benjamin Flesch 2010-07-25 07:37:00 PDT
I can reproduce this bug on Ubuntu with Firefox version 3.6.7. I tried this testcase: http://tymofiy.livejournal.com/149235.html - audio slider hides whenever I try to reach it.
Comment 12 imnolatino 2010-07-25 07:59:53 PDT
Even better: right click/hide controls.  Where did it go?

Out of sight.
Out of my mind.
Comment 13 Christian Ertl 2010-07-25 12:49:06 PDT
Seems to be the same issue as bug 502122.
Comment 14 Dave Webber 2010-07-25 13:35:59 PDT
(In reply to comment #13)
> Seems to be the same issue as bug 502122.

Not quite. They're similar issues, but distinct: The issue in bug 502122 is that the volume control gets hidden by the chrome when the audio element is at the top of the page, because the volume does not appear below the audio element when there is too little room above the element to accommodate the volume control. The issue in this bug is that the volume control can't be used, regardless of where the element is on the page or in the window, because the volume is closed as soon as the mouse is moved over it, as the mouse is necessarily moved out from over the audio element's bounding box to reach the volume control.
Comment 15 Alice0775 White 2010-08-13 21:23:49 PDT
*** Bug 587269 has been marked as a duplicate of this bug. ***
Comment 16 Chris Pearce (:cpearce) 2010-09-30 21:07:53 PDT
I don't think this is a regression. This bug exists in FF 3.6.2 according to comment 4, and I can repro it in 3.6.10. There's no volume control in 3.5, only a mute button. I've tried a few nightly builds since the volume control landed in March 2009, and this bug seems to always have been there.
Comment 17 Johnathan Nightingale [:johnath] 2010-10-01 12:57:43 PDT
Dolske - who do you think should own this, assuming it still blocks?
Comment 18 Chris Pearce (:cpearce) 2010-10-03 16:24:23 PDT
The problem here is that when we move the mouse from the mute button to the volumeStack for an audio-only media element, we're receiving an mouseout event with a relatedTarget of the body element (or whatever's containing the audio element) rather than the volumeStack as the relatedTarget. onVolumeMouseInOut() calls isEventWithin(), and because the relatedTarget is not the volumeStack, that's not stopping us from exiting, so we're fading out the volume stack.

Even if I disable the fading out, we still can't change the volume, the volumeStack doesn't respond to mouse clicks, and the relatedTarget of mouseout events is still the element's container. It's as if the volumeStack doesn't work if it's being drawn out of bounds of the mediaControlFrame.
Comment 19 Chris Pearce (:cpearce) 2010-10-03 18:26:49 PDT
This problem also affects the scrubber/timelabel; you can't seek by clicking and dragging the timelabel balloon if you click on the portion of the balloon which extends outside of the controlBar, you must click on the portion which is drawn inside the controlBar.
Comment 20 pietro.brenna 2011-01-08 05:25:05 PST
I think this bug should be quickly fixed because it affects, for example, every <audio> in the wikimedia project, and for the end user it turns up very annoying.
A solution, if there is no workaround in javascript for this, could be to place the volumeStack inside the mediaControlFrame, horizontal, always visible or shown at mute button.onmouseover (like in youtube). This could help solving bug 502122, as it wouldn't be needed extra space on top of the video.
Comment 21 Alice0775 White 2011-03-04 16:02:54 PST
*** Bug 638961 has been marked as a duplicate of this bug. ***
Comment 22 Vitaliy 2011-03-08 13:46:13 PST
I am not a Firefox dev or anything close like that, but how hard is it to fix this bug??
Comment 23 Jennifer Morrow [:Boriss] (UX) 2011-03-28 18:15:13 PDT

*** This bug has been marked as a duplicate of bug 502892 ***
Comment 24 lazy.false@gmail.com 2011-05-06 03:47:38 PDT
It's still exists in 4.0.
Is any one can fix this bug?

userAgent: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Comment 25 vondemleschker@hotmail.com 2011-05-06 09:50:06 PDT
well it tok it's time, but now it's work in progress. The slider will be removed in one of the next version's of FF and they are going to make a new control panel.
Comment 26 Benjamin Peng 2012-09-17 20:47:02 PDT
why had this bug been marked as "resolved"?

I still can't change the volume of audio element (like this example):
http://www.w3schools.com/html5/tryit.asp?filename=tryhtml5_audio

however, if you open .ogg file directly, you can chane the volume..
Comment 27 welp 2013-05-10 11:32:35 PDT
Volume slider is not shown on Aurora 22.0a2 (2013-05-10) / Windows 8.

When I hover over the volume icon, nothing happens. But when I click on it, it mutes the audio.

Note You need to log in before you can comment on or make changes to this bug.